
NIS-Elements AR

Manual
Publication date 17.04.2015

v. 4.40.00

No part of this publication may be reproduced or transmitted except with the written permission of
Laboratory Imaging, s. r. o. Information within this publication is subject to change without notice.
Changes, technical inaccuracies and typographical errors will be corrected in subsequent editions.

LABORATORY IMAGING, spol. s.r.o.
Za Drahou 171/17
102 00 Praha 10
Czech Republic





Table of Contents
1. Command Line Startup Options ........................................................................................... 1
2. Installation and Settings ..................................................................................................... 5

2.1. Installation and Updates .......................................................................................... 5
2.2. Additional Modules Available in NIS-Elements AR ..................................................... 11
2.3. User Rights .......................................................................................................... 14
2.4. NIS-Elements Preferences ...................................................................................... 21

3. User Interface ................................................................................................................. 25
3.1. Main Window Components ..................................................................................... 25
3.2. Image Window ...................................................................................................... 28
3.3. Arranging User Interface ........................................................................................ 31
3.4. Layouts ............................................................................................................... 32
3.5. Layout Manager .................................................................................................... 33
3.6. Modifying Toolbars ................................................................................................ 34
3.7. Modifying Menus ................................................................................................... 36
3.8. Running a Macro Upon Layout Change ..................................................................... 37
3.9. Appearance Options .............................................................................................. 37

4. Cameras & Devices .......................................................................................................... 41
4.1. Basic Workflows .................................................................................................... 41

5. Image Acquisition ............................................................................................................ 63
5.1. Introduction to Image Acquisition ............................................................................ 63
5.2. Shading Correction ............................................................................................... 64
5.3. Camera ROI ......................................................................................................... 65
5.4. About ND Acquisition ............................................................................................. 67
5.5. Time-lapse Acquisition ........................................................................................... 69
5.6. Multi-point Acquisition ........................................................................................... 73
5.7. Z-series Acquisition ................................................................................................ 77
5.8. Multi-channel Acquisition ....................................................................................... 79
5.9. Large-image Acquisition ......................................................................................... 80
5.10. Inputs/Outputs Control ........................................................................................ 82
5.11. Combined ND Acquisition ..................................................................................... 82
5.12. Capturing to Ring Buffer ....................................................................................... 87

6. Displaying Images ............................................................................................................ 89
6.1. Open, Save, Close Images ...................................................................................... 89
6.2. Image Layers ........................................................................................................ 95
6.3. ND Dimensions ................................................................................................... 100
6.4. Large Images ..................................................................................................... 122
6.5. LUTs - Non-destructive Image Enhancement ........................................................... 125
6.6. Organizer ........................................................................................................... 133

7. Image Analysis ............................................................................................................... 139
7.1. Preparation ........................................................................................................ 139
7.2. Image Segmentation ........................................................................................... 143
7.3. Binary Layers ...................................................................................................... 149
7.4. Regions of Interest - ROIs ..................................................................................... 157

8. Measurement ............................................................................................................... 163
8.1. Basic Workflows .................................................................................................. 163

iii

NIS-Elements AR



8.2. Manual Measurement ......................................................................................... 178
8.3. Automated Measurement ..................................................................................... 184
8.4. Time Measurement ............................................................................................. 186
8.5. Measurement Features ....................................................................................... 191

9. Creating Reports ........................................................................................................... 211
9.1. Report Generator ................................................................................................ 211
9.2. Report Objects ................................................................................................... 211
9.3. Report Templates ................................................................................................ 213

10. Macros ....................................................................................................................... 215
10.1. Creating Macros ................................................................................................ 215
10.2. Running a Macro ............................................................................................... 217
10.3. Macro Language Syntax ..................................................................................... 217
10.4. Controlling Cameras by Macro ............................................................................ 225
10.5. Macro Preferences ............................................................................................ 225

11. Movies ....................................................................................................................... 227
11.1. Capturing AVI Movie ........................................................................................... 227
11.2. Save ND2 as AVI ............................................................................................... 227
11.3. Creating a Movie ............................................................................................... 227
11.4. About Video Compression .................................................................................. 229

General Index ................................................................................................................... 231

iv



1. Command Line Startup Options
See also 2.1.3. Command Line Installation Options [9].

When starting NIS-Elements from the command line (or when editing the desktop shortcut properties),
you may append some switches with parameters to the main command and thereby modify the startup
behavior.

Note

Some switches do not have parameters.

Example 1.1. Command line switches syntax

“ NIS-Elements executable” switch#1 parameter#1 switch#2 parameter#2 etc.

For example, to run NIS-Elements AR and open the starting_image.jp2 at straight away, run.:

"c:\Program Files\NIS-Elements\nis_ar.exe" -f "C:\Images\starting_im-
age.jp2"

Startup Switches

-? Displays a help screen with the description of switches (basically this page).

-c “Command” The application runs the specified macro Command.

-cam “Camera Name” The specified Camera will be used. When using this option you must also specify
the Grabber Name and the HW Unit Name. To find the camera name, search the application log file for
“Camera Name”. It is also possible to use only a part of the Camera Name, but the part of the name
must be unique among all the available cameras.

-cw “CommandWait” The application runs the specified macro command and waits until it is completed

-f “Filename” The application tries to open the image pointed to by the Filename parameter.

-g “Grabber Name” The image grabber (driver) of the specified Grabber Name will be used and no
camera-selection window will show at startup. Set the parameter value to “last” and the most recently
used grabber/camera will be loaded. As the grabber name, you must use internal name of the grabber,
not the one you see in the startup dialog window.

Either use one of the following names or search the application log file for the phrase “Grabber Name”
(see Fixed Grabber Startup [2]).

-gn No grabber (camera) driver will be loaded. Image acquisition will not be possible.

-h “HW Unit Name” The specified HW Unit will be used. When using this option you must also specify
the Grabber Name. Two HW Units (e.g. two DS-U2 cameras) can be run by one grabber/driver. The
available HW Units are listed in the Acquire > Select *camera name* window. Set the parameter
value to “select” and the selection box will be shown. When using this option you must also use the -g
switch. To find the HW Unit Name, please search through the application log file for “HW Unit Name”.

-i “Config Name” A user can specify the configuration to be used by NIS-Elements. The default config-
uration is saved in the “C:\ProgramData\Laboratory Imaging\Platform” folder. If you want to create a
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custom configuration, use the -i switch, e.g.: nis_ar.exe -i "My_Configuration". The config-
uration of this instance will be saved to the "C:\ProgramData\Laboratory Imaging\My_Con-
figuration" folder.

This is useful when using two cameras on one microscope for example. You can create a separate pro-
gram shortcut which uses the -i switch to load a different configuration.

-l “Language” The application will run in the specified language (if available). Use three-letter language
codes according to the ISO 639 [http://en.wikipedia.org/wiki/List_of_ISO_639-2_codes] standard.

-m “Macro File” The application will execute the macro file (*.mac) pointed to by the Macro File para-
meter.

-mw “Macro File” The application will execute the macro file (*.mac) pointed to by the Macro File
parameter and wait until it is completed.

-p “Command” [“Param”] The application window will be placed according to the Command. Possible
values are:

• left, right, top, bottom - the window is placed on the corresponding monitor screen.

• monitor N - the window is placed on the Nth monitor.

• rectangle (x0,y0,x1,y1) - the window is placed in the specified rectangle (in workspace coordinates).
The coordinates must be in parenthesis without any spaces.

-passive The application will not connect to any device on startup (NIS-Elements AR will start with blank
Device Manager). Camera selection is not affected by this option.

-q A new instance of the application will run. By default, only one instance of NIS-Elements is allowed
to run.

-s “Settings File” The application will use the specified Settings File to load and save its settings. The
settings file can be created from MS Windows Start menu by the NIS Settings Utility.

-var, -vbr, -vd, -vf For testing purposes, you can switch the application to run as if you have a different
version (AR/BR/D/Freeware) installed. However, you have to have the corresponding licence written in
your key (Even if you normally run NIS-AR, the -vd switch will not work to run NIS-D unless you have also
the NIS-D licence).

Note

Mind that the set of functions you will get once the software is run depends on the setup file used
for installation (for example, some functions of NIS-D are not included in the NIS-AR setup so these
will not appear in the software run by: nis_ar.exe -vd

Fixed Grabber Startup

Each time NIS-Elements AR is run or the grabber / camera / HW unit is changed, four parameter values
are written to the application log file (C:\ProgramData\Laboratory Imaging\Platform\Logfiles).:

• Grabber Name

• HW Unit Name
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• HW Unit Connection String

• Camera Name

Let's say we want to set the last used configuration for every NIS-Elements AR start:

1. Lookup the parameters in the most recent log file. E.g.:
Grabber Name CLxGrabberDriverSim

HW Unit Name SimGrabber

HW Unit Connection String (empty)

Camera Name Sim_Camera_Color

2. Modify the shortcut, E.g.:

"c:\Program Files\NIS-Elements\nis_ar.exe" -g CLxGrabberDriverSim -h
SimGrabber -cam Sim_Camera_Color

3. Double-click the shortcut. NIS-Elements will start without asking for grabber selection

3
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2. Installation and Settings

2.1. Installation and Updates

2.1.1. The Installation DVD-ROM Content

• NIS-Elements software setup file

• Drivers and utilities for the HASP Key

• Drivers for selected cameras

• User's Guide in the PDF file format

• Sample image database

• Sample ND2 image sequences

2.1.2. NIS-Elements Installation Steps

Caution

You have to possess the administrator rights to your computer to be able to install NIS-Elements
AR successfully.

Quick Guide

• Insert the installation DVD in the DVD-ROM drive. A window automatically appears.

• Install the selected NIS-Elements software version, additional modules and device drivers.

• Plug the provided HASP key into the USB port of your PC.

• Run NIS-Elements.

Step by Step

1) When the installation DVD is inserted, a selection window appears automatically.
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Select the software package to be installed. Select the one you have got the license for and
which is properly coded in your HASP key. The installation wizard welcome-window appears. Click
Next to continue.

2) Install Local Options

Figure 2.2. Local Options installation

Select whether to install Local Option or not. Define the folder where NIS-Elements AR should
be installed. We recommend to use the predefined directory. If you want to change the directory
anyway, press the Browse button and select a new one. Otherwise click Next.

Note

The Local Option installation provides some advanced features which did not pass the
quality assurance procedure yet. We recommend to wait until they are released officially.
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3)

Now, select the cameras which will be used with NIS-Elements AR.

4)

If your licence contains some additional modules besides the NIS-Elements AR core software,
please select them in this window.

Note

Any module selected will be installed along with NIS-Elements AR automatically. However,
you might not be licensed to use it. The module will run after you get the corresponding
code registered in your HASP key.
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5)

Select the devices which will be used with NIS-Elements AR. Finish the installation by clicking
the Install button.

Note

NIS-Elementsmay not be connected to devices after installation depending on the PC status
at installation. If so, execute the Modify installation command of the Windows Start menu
(see the next step) to perform Repair that corrects the previously installed status.

Warning

For Windows7 users: Some devices do not work correctly after recovery from Sleep mode.
Please turn off the Windows 7 Sleep Mode to prevent possible problems:

1. Run the Start > Control Panel command on the main Windows toolbar.

2. Make sure the control panel is displayed in the Category mode (View by in the top-right
corner).

3. Click Hardware and Sound

4. In the Power Options section, click Change when the computer sleeps

5. Set the Put the computer to sleep option to Never

6. Confirm the settings by the Save changes button and close the Control Panel window.
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6)

The setup creates a new program group in the Start menu containing the following items: NIS-
Elements AR application shortcut, the HASP key information shortcut, the Modify Installation
shortcut (for adding hardware drivers, modules, etc.), the Uninstall procedure, and the Send Info
Tool. A shortcut to NIS-Elements AR is created on the desktop too. These changes affect all user
profiles of your local Windows operating system.

Figure 2.7. Start menu

Note

Clicking the Uninstall command deletes all installed files from disk, and removes the NIS-
Elements AR program group from the Start menu as well as it removes the desktop icon.

2.1.3. Command Line Installation Options

See 1. Command Line Startup Options [1] for details about how to use command line switches. The
following switches are to be used with the NIS-Elements installation file to modify behavior of the install-
ation wizard.

-all This parameter unhides options in the setup which are hidden by default. It concerns mainly drivers
of devices which were formerly supported but are no longer available.

-new If this command line parameter is appended, the setup checks if any other setup has already been
installed. If so, the setup restarts and runs in an independent mode. The update mode is disabled. This
enables to install two or more builds together on one operating system.
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-xp This parameter enables the user to install NIS-Elements on Windows XP even though this operating
system is NOT supported officially.

2.1.4. Additional Module/Device Installation

You may need to install a device or an additional module after the NIS-Elements ARmain system install-
ation.

• Go to [Start menu > Programs > NIS-Elements AR] program group.

• Select the Modify Installation command.

• Follow the installation wizard instructions. Select the check-boxes by the items you would like to add.

• Finish the installation.

2.1.5. Sample Database Installation

If you chose to install the Sample Database, a new subdirectory “Databases” is created inside the NIS-
Elements AR installation directory (e.g. C:\Program files\NIS-Elements AR \Databases\...). The
“Sample_Database.mdb” file is copied to there along with database images (stored in subdirectories).
An administrator username/password to access this database is set to:

• Username: “sa”

• Password: “sa”

2.1.6. Software Copy Protection

The NIS-Elements AR software is delivered with a hardware key (also called HL = hardware licence).

Figure 2.8. Hardware key

The key contains information about the software licence and allows users to run the corresponding
software. A warning message is displayed when user starts NIS-Elements with incorrect HASP. Please
connect the USB HASP after the NIS-Elements AR installation is finished. The utility called HASPinfo is
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installed to the NIS-Elements AR directory. It enables the user to view information about the software
licence and is accessible via the Hasp Info menu command.

2.1.7. Device Updates

The main goal of the Device Updates setup is to add new devices/cameras or to fix problems that are
localized in the drivers only and do not affect any other NIS-Elements functionality.

Device Update setup requires installation of the correspondingNIS-Elements version. The setup contains
only .dll files supporting a new device or some corrections and upgrades of already existing drivers. This
update form keeps NIS-Elements stable and the update file size small.

Device Update numbering is consecutive and appropriate to its NIS-Elements version until a new full
setup of NIS-Elements is released (Major version, Service Pack or HotFix) - then the numbering starts
from the beginning.

Device Updates are cumulative and contain all the changes from the previous updates. Also full NIS-
Elements setups (Major versions, Service Packs and HotFixes) will contain all the changes from the
previously released Device Updates.

2.1.8. Fixes

Fixes represent driver changes which serve for testing purposes or for correcting problems occurring
only under special conditions. Fixes are packed into a zip file containing modified driver files. Fixes are
usually user requested, therefore they are not considered as Device Update candidates.

2.1.9. Installing the Database Module on 64-bit Systems

The NIS-Elements installation file contains 64bit MDB drivers which improve the speed of the database
module on 64bit systems. However, 32bit version of MS Office 2010 cannot be used along with these
64bit drivers. You can install these drivers, if:

• you run 64bit version of MS Office 2010

• you use other version of MS Office such as Office 2013

• you do not use MS Office at all

Find the drivers in the NIS-Elements folder, typically: “C:\Program Files\NIS-Elements\Drivers\Data-
base_MDB\”
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2.2. Additional Modules Available in NIS-Elements AR

2.2.1. Acquisition and Analysis Modules

3D Measurement If you have this module enabled in HASP, some extra commands and features for
analysis of multiple binary layers over Z become available in the Binary menu.

6D This module enables users to combine all 6 dimensions (X, Y, Z, time, wavelength, large image)
within a single ND acquisition experiment.

Advanced 2D Tracking This module extends the basic Object Tracking module by the ability to track
binary objects and by other features.

Bio Analysis This module enables to perform bio-analytical tasks. The Bio Analysis module measures
and analyses time-lapse and multipoint ND images (Z-stack data sets are not supported).

Note

This module requires a 64bit operating system.

CA FRET With this module, you can capture/create FRET images, measure Calcium ion concentration
or make automatic FRET calibrations.

Extended Depth of Focus The EDF module allows you to combine an existing Z-stack of images into
one focused image by picking the focused regions from each frame and the pieces together.

HC Template It is a simple-to-use acquisition and high content analysis module. Using a pre-defined
template, you can acquire image data-sets, perform high content analysis and browse the resulting
data.

High Dynamic Range This module brings the functionality of capturing and creating HDR images within
NIS-Elements AR.

Illumination Sequence This module provides an easy graphical user interface for setting and running
advanced real-time (triggered) acquisition experiments.

JOBS JOBS is an environment aiming at complex acquisition and data analysis with easy to use and
comprehensive user interface. JOBS is a “visual programming” tool enabling non-programmers to design
their own automated acquisition / analysis experiments. This module allows user to create, edit and
run JOBs.

JOBS Viewer This module enables user to browse the data acquired via JOBs.

ND Advanced Acquisition (requires: Local Option) This module enables users to perform complex
timelapse/multipoint ND acquisitions and also adds some other features. Please ask your local dealer
of NIS-Elements for details.

Object Classifier Provides the ability to classify binary objects.

Object Tracking Motion characteristics of objects such as living cells can be measured automatically
or manually using the Tracking module. Tracking is based on ROIs.

RT Acquisition This module user to perform fast hardware-driven (triggered) acquisition experiments.
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Signature (requires: Local Option) With this module, you can measure multiple features in the image
consecutively. First you define features to measure and in which

Single Particle Tracking Single Particle Tracking (SPT) is used to track single molecules and for analysing
parameters of these tracks.

TimeMeasurement The time measurement tool enables to record average pixel intensities within Regions
Of Interest (ROIs) during a time interval. Please see 8.4. Time Measurement [186].

2.2.2. Deconvolution Modules

2D Deconvolution Image deconvolution module suitable for standard 2D images. Apart from the 2D
deconvolution, it provides a Fast Deconvolution and Live De-Blur (applicable on live image).

3DDeconvolution Image deconvolution module suitable for image sequences containing a Z dimension.

Blind Deconvolution AutoQuant blind deconvolution module.

LIM Deconvolution (Legacy) A simplified predecessor of the new 2D/3D Deconvolution modules.

RT Deconvolution AutoQuant deconvolution module aimed at real-time deconvolution.

2.2.3. Industrial Modules

Filters Particle Analysis This industrial module is aimed at analysis of filters according to the ISO 16232
standard.

Metalo - Cast Iron Analysis After the module installation, a new item called Metallography appears in
the Applications menu. Select the Cast Iron command to display the cast iron measurement layout.

Metalo - Grain Size Analysis After the module installation, a new item called Metallography appears in
the Applications menu. Select the Grain Size command to display the grain size measurement layout.

2.2.4. Device Modules

Slide Loader This module enables NIS-Elements AR connect and control a slide loader

Stage This module enables to connect and control motorized XY stages.

Stage Incubator This module enables to connect and control gas and temperature-controlling chambers.

TTL/Analog IO This module enables NIS-Elements AR to send and receive TTL and analog signals via
a DAQ board.

Wavelength Switcher This module enablesNIS-Elements AR connect and control wavelength switchers.

Well Plate Loader This module enables NIS-Elements AR connect and control a well plate loader.

Z Drive This module enables connect and control motorized Z drives.
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See also 4.1.4. Connecting a Device to NIS-Elements [50].

2.2.5. Other

Database (DBASE) If the database module was installed, the system can create and control image
databases. A database can help you to efficiently organize your image archives and manage additional
information related to the images.

Local Option When Local Option is installed (see Step 2 [6]), NIS-Elements AR will provide some ad-
vanced features which did not pass the quality assurance procedure yet. We recommend to wait until
they are released officially.

2.3. User Rights
User management is very useful when a single workstation is shared by number of users. Some user
accounts may have administrator rights to NIS-Elements while other's privileges are quite restricted. A
per-person system may be established or user accounts may be shared. The following principles are
utilized within NIS-Elements AR:

MS Windows accounts support NIS-Elements AR can assign privileges to MS Windows accounts.
Whoever is logged in the operating system and runs NIS-Elements obtains a default set of privileges.
System administrator can then further restrict or extend the user's rights.

NIS-Elements AR password protection It may be not comfortable enough to log the current user off
from MS Windows when a user change is required in NIS-Elements. For such case a completely inde-
pendent list of user accounts, which is not connected with MS Windows users, can be created. Then
just restart of NIS-Elements is needed to switch the user.

Private vs. Shared storage Every user-created item (setting) important in the work-flow can be protected
from unwanted change in two levels. First, the creator of the item (optical configuration, layout, objective,
etc.) can save it as private. Unless its status is changed to shared, no other user will even see this item
within the lists throughout the application. The second level of protection concerning all shared items
is provided by assigning users to Groups and Privileges groups.

Groups Every user is a member of a group. The group enumerates shared items (optical configurations,
objectives, etc.) which will be visible for its members. NIS-Elements administrators can create any
number of groups and select the items to be visible.

Privileges There are basic groups of privileges which allows users or restrict them to perform certain
actions. This concerns for example modifying macros, reports, selecting cameras, etc. There are four
levels of privileges by default, but further can be created by an administrator:

• Admin

• Common

• Guest
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• Default

2.3.1. NIS-Elements authentication

If you have chosen “ NIS-Elements (Password protected)” user authentication method, a login dialog
window appears at every start-up of NIS-Elements. Enter a user name and a password for existing user
account. If the option Allow to Create a New User at Start-up is enabled, you can create a new user ac-
count without needing an administrator. This account is assigned to the Default group of users and
Default group of privileges automatically.

2.3.2. Creating a Shared Layout

Please read the following example on user management. Step by step, we describe the creation of a
shared layout which can not be modified by members of the Common and Guest groups.

1) Run the View > Layout Manager command. Set at least one of the defined layouts as Shared.
(see 3.3. Arranging User Interface [31])

2) In the left column of the window, select User Rights.

3) Make sure you are logged as a user with the Privilege to Modify user rights. If not, use the Log
As... button to log in under a different account which has the privilege.

4) Set layout visibility

Select the Groups tab. Here you can see at least one group of items called Default. Either select
one a group or create a new one by the New button and choose Layout within the list of items.
All layouts set as shared will be listed on the right side within the Accessible items field. Make
sure the check boxes next to the layouts which you allow to be used by the group are selected.

5) Disable layout modification

Select the Privileges tab. Select the group of privileges which should have not the permission to
modify the selected shared layouts. In the Privileges field on the right, make sure you de-select
the Modify Shared Layouts option.

6) Apply the new policies

Select the Users tab. In the list of users, select the ones which you would like to apply the policy
to (users can be selected one by one or by multi-selection with the Shift or Ctrl key
pressed). Then, assign the appropriate Group and Privileges by selecting them from a pull-down
menu on the right side of the window.

7) Confirm the changes by the Apply button.

15

Installation and Settings



2.3.3. Closing Another Instance of NIS-Elements

When more users want to work with NIS-Elements on the same computer and one of them did not close
his NIS-Elements running copy, other users cannot use the program, because only one NIS-Elements
copy can be running at a time. The possibility to close the running program started by a different user
during a new NIS-Elements launch is available in the following dialog window. This applies only if there
are no experiments running.

Figure 2.9. Another instance running

2.3.4. User Rights Options

User Authentication The Windows authentication utilizes Windows accounts to automatically log in to
NIS-Elements AR.

The NIS-Elements AR (Password protected) authentication utilizes application user accounts and
passwords at the start-up of NIS-Elements AR. Check the Allow to Create a New User at Start-up option
to enable creating of a new user in the Login dialog window.

Current user Displays currently logged in user.

Log As Opens the Login As dialog which enables you to login as a different user e.g. an administrator
with more user rights for the purpose of changing User rights settings.
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Figure 2.10. Login As

Select the user name you want to log-in as from the drop-down menu. Enter a valid password and press
OK. The new user identity is available only while the User manager is opened.

Statistics Edit path and file name of a database file for saving statistics.

Export/Import user rights These buttons enable anyone to save/load complete settings of user accounts
and their privileges to/from an external XML file. Standard Open and Save As windows appear. Having
the data exported may be useful when copying the settings to other computers.

2.3.5. Users Tab Options

New Enables to create new NIS-Elements AR user account. You have to posses the privilege Modify
User Rights.

Figure 2.11. Creating new user
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Enter a new user name, assign him to one of the existing Groups and group of Privileges and set the
password. Check the Enforce user to change his password at start-up option to make the user change
his password at his first login into the NIS-Elements AR.

User name and password properties

Length of the user name and password is limited to 50 characters. You can use any combination of
characters, symbols or numbers (except the Windows ones: :, *, ?, ", \, /, <, >, |).

Remove Removes selected user account. You can select multiple accounts and delete them at once.

Copy To Choose a user from the pull down menu whose group and group of privileges will be changed
according to settings of a selected user.

Duplicate You can easily create a new user by duplicating the existing. This preserves all account settings
under a different name. If you have selected to duplicate more then one user, enter a name prefix, which
is added in front of the original name for all selected duplicated accounts. User which was created as
a duplicate has an empty password and is forced to change his password at next application startup.

User Accounts List This table displays all existing user accounts. You can sort them according to any
of four columns. The first column displays type of the account. The second one shows user names. The
third one displays assigned group of users. The fourth one displays assigned group of privileges. Select
one or more users whose settings needs modification.

Set password To change password of a selectedNIS-Elements AR user account, press the Set password
button. You have to posses the Privilege Modify User Rights. Otherwise you can change only password
of the current user. Following window appears:

Figure 2.12. Reset of password

Name of the user is displayed. Enter and confirm new password. When done, press the Change button.

Enforce user to change his password at start-up Check this option to make the user change his
password at his first login into the NIS-Elements AR.

Enumerate All Windows Users This button starts copying MS Windows accounts to NIS-Elements AR.
The accounts are assigned to user groups (admin, common, guest) according to their Windows permission
settings.
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2.3.6. Groups Tab Options

Figure 2.13. Groups tab

New Enables to create new group of users. You have to posses the privilege Modify User Rights. Enter
a name of new group.

Remove Removes selected groups. You can select multiple groups and delete them at once.

Copy To Choose a group from the pull down menu which settings will be changed according to selected
group.

Duplicate You can easily create a new group of users by duplicating the existing. This preserves all
group settings under a different name.

List of Groups All defined groups are listed in this window. Each group contains subsets. If you click on
a subset, its items appear in the Accessible items list.

Accessible items This list shows items of a selected subset. Every item has its own check box. If the
check box is checked, all users assigned to the corresponding group will see the item. Otherwise they
will not see the item.

Optical Configuration Displays all shared optical configurations.

Objectives Displays all shared objectives.
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Cameras Displays all installed cameras. From the pull down menu below select a camera which
is used as default for users without the privilege Select Camera.

Devices Displays all installed devices.

Layouts Displays all shared layouts.

Macros Displays all shared macro commands. Check a macro to make the content of it visible to
this Group.

Reports Displays all shared reports and report templates.

2.3.7. Privileges Tab Options

Figure 2.14. Privileges tab

New Enables to create new group of privileges. You have to posses the privilege Modify User Rights.
Enter a name of new group.

Remove Removes selected groups. You can select multiple groups and delete them at once.

Copy To Choose a group from the pull down menu which settings will be changed according to selected
group.
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Duplicate You can easily create a new group of privileges by duplicating the existing. This preserves all
group settings under a different name. If you have selected to duplicate more then one group of privileges,
enter a name prefix, which is added in front of the original name for all selected duplicated accounts.

Groups of Privileges A list of all groups of privileges is displayed.

Privileges A list of privileges is displayed. Every item has its own check box. If the check box is checked,
it grants all users assigned to the corresponding group relevant privilege to access, change, modify, etc.

Note

Users that do not have the privilege “Modify Shared Optical Configuration” can temporarily change
the brightness settings (e.g. exposure time, gain, etc.) in a shared optical configuration and use
such adjusted optical configuration for example in Multichannel acquisition. But all such modific-
ations will not be stored and they will disappear when the application is restarted.

2.4. NIS-Elements Preferences

2.4.1. Adjusting Program Preferences

1) Run the Edit > General Options command. The Options dialog window appears.

2) Select a tab which contains requested options. Options are sorted into several groups:

General Options concerning basic image operations. See 2.4.2. General [22].

AppearanceOptions concerning the graphical user interface. See 3.9. Appearance Options [37].

Open Next Options concerning the File > Open/Save Next > Open Next menu command. See
6.1.1.3. Options for the Open Next Command [90].

Save Next See 6.1.2.4. Save Next Options [93] for more information.

Macro Configures key shortcuts to macros and sets macros to run automatically on startup See
10.5. Macro Preferences [225].

Measurement See 8.1.4. Measurement Options [171] for more information.

Data export See Data Export Options [177] for more information.

User rights See 2.3. User Rights [14] for more information.

Layout Manager See 3.5. Layout Manager [33] for more information.

3) Make any changes you need in preferences and use the following buttons to manage them:

Defaults for this Page Restores default settings of the currently displayed options tab.

OK Confirms and saves changes made to the preferences. The dialog window is closed afterwards.
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Cancel Cancels all changes made to the preferences. The dialog window is closed afterwards.

Apply Applies changes made in preferences but keeps the Options dialog window open. You can
apply changes individually on each tab.

Help Displays relevant help page.

2.4.2. General

Documents and History

(requires: Local Option)
Use fix path for images The defined directory is always used when using the File > Open or File
> Save As command.

Limit number of opened documents When this options is checked, the user is limited to a single
opened image at one time.

Capture always creates a new document If checked, every acquisition creates a new image.

Use last LUTs on image open When a new image is opened, this option turns the look up tables
automatically on, and copies the settings from the current or the last opened image. Some image
formats (jp2, ND2) can contain the LUTs settings. If such image is opened, the saved LUTs are
loaded instead of the most recently used.

Use AutoLUTs on image open for images without LUTs information This option keeps the
AutoLUTs feature of the File > Open window always ON, and it applies AutoLUTs to the image
after opening. This option is ignored if LUTs settings are saved in the image, or if the Use last LUTs
on image open option is applied.

Show mapping dialog in organizer after drag and drop Displays the Mapping window every time
an image is inserted to a database table. It enables you to check/modify mapping of the image
info values to the database table fields.

Enable saving ND experiment to TIFF series Displays the Save As TIFF Series option within the
ND Acquisition control panel. It enables you to save single frames of the ND experiment as tiff im-
ages. You can modify the order of the dimensions and the images format (mono, color, merged).
Also you choose to convert multichannel images to RGB, or to convert images to 16 bit.

Open new ND views to new window Displays each newly generated ND view in a separate window.

Show image info window on save Displays the File > Image Properties window every time an
image is saved via the Save As command.

Detect sequence on image openWhen you select to open an image that is a part of image sequence
such as 001.jp2, 002.jp2..., it is recognized automatically and you are offered to convert it to an
ND2 file.

Show binary layers' contours Check this item to display contours of binary layers.

Use zero based time scale for ND documents Select this option to ensure that the first frame of
a time sequence will always start at 0.0s.
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State of saturation indicator after start Select what to do with the saturation indicator settings
( ) after NIS-Elements AR is restarted. Turn it ON, OFF, or remember the last setting.

Rotation Flips and Shifts
Apply to overlaid binary layer If checked, in overlay mode both binary and color images are rotated,
shifted and flipped.

Optical Configuration
Save all camera settings to optical configuration automatically If the currently selected optical
configuration contains Camera Settings and this option is checked, any change of the settings is
written to the optical configuration immediately.

Save brightness to optical configuration automatically If the currently selected optical configur-
ation contains Camera Settings, the Brightness setting is being updated continuously according to
the current state. Also functionality of saving confocal brightness setting(laser power, detector gain
and scan frame rate) is contained in this option.

Select corresponding optical configurationwhen filter changed... (requires: Local Option) Enabled
if “Unselect” in the option below is chosen. AllowsNIS-Elements to automatically change the optical
configuration based on the filter selected on the microscope.

When Optical Configuration setting changed
Keep Selected The Opt. configuration name is marked by the “*” sign and the change is
offered to be saved.

Unselect Every change of Optical configuration setting results in its deselecting and switching
to user settings.

Save all changes All changes regarding the Opt. configuration settings are updated automat-
ically according to the current state.

Temp NIS-Elements AR uses the Temp directory for storing temporary data when there is not enough
RAM available. You can redirect the system to use a directory on another harddisk, which may speed
up the whole system.

Defaults for this Page Restores the default setting for General Options.
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3. User Interface
Figure 3.1. The NIS-Elements Main Window

3.1. Main Window Components

3.1.1. Main Menu

All basic NIS-Elements functions are accessible from the main menu at the top of the screen. Menu
commands are grouped according to their purpose.
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3.1.2. Toolbars

There is a default set of toolbars, each toolbar containing number of buttons. There is also one fully
customizable toolbar - the main left toolbar - to which any button can be added. Every button or whole
toolbar can be hidden by user. Please see 3.3. Arranging User Interface [31] for further details.

3.1.3. Status Bar

The status bar at the bottom of the screen displays the following information:

Figure 3.2. The application status bar

1. This part of the status bar displays available layouts.

Note

The layout Tabs may be hidden when the Show Layout Tabs option in the 3.3. Arranging User
Interface [31] window is deselected.

2. This status bar section displays the type of the currently selected camera.

3. Here you can get information about the most recently performed command. The FPS / Exposure /
Focus info is shown in case of live image. The black bar indicates the focus rate. Longer black bar
represents more of the image in focus.

4. This section show the name of the current objective.

5. Current coordinates of XY (Z) stage are shown in this part of the status bar.

3.1.4. Docking Panes

Docking panes are square spaces inside the application window, where you can place (dock) any of the
control panels. There is one docking pane available at the Right, Bottom, and Left side of the application
screen.

To Display a Docking Pane

1. Go to the View > Docking Panes sub-menu and select the pane you would like to display.
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Note

The Docking Panes sub-menu can be also displayed by right-clicking into the empty application
screen.

2. The docking pane appears, either empty or with some window(s) docked inside.

3. Repeat this procedure to display more docking panes.

Handling Control Panels

Various control panels can be displayed docked within the docking panes or they can be floating. See
the following picture:

Figure 3.4. The Docked Control Panel Caption

To handle the control panels (CPs), you can:

Open recently closed CP Locate the button on the main left toolbar. When you click it, the list of re-
cently closed CPs appears. Pick one to display it again.

Add CP to a docking pane Right click inside a docking pane (3) to display the context menu. Select the
control panel to be displayed. If the window is already opened somewhere else (in another docking pane
or floating), it closes and moves to the new destination.

Close CP Click the cross button (2) in the right top corner of the tab.

Drag CP Drag any CP by the tab and drop it somewhere. If you drop it by the edge of a docking pane, it
will create another column of this pane. If you drop it over the caption of another CP, it will be docked
in the same pane as a new tab. If dropped somewhere else, the CP will be floating.

A color frame appears when you place the mouse cursor dragging a CP over the edge of a docking pane
or a caption of another CP. It indicates that if you drop it, its placement will be handled automatically.

Minimize the docking pane Click the arrows in the top left corner. The pane minimizes to a stripe by
the edge of the screen. It can be restored to its original position by double clicking this stripe or by
clicking the arrows again.

Close the docking pane Click the cross button (4) in the docking pane caption. Or you can right click
the pane and unselect the Docking View option.

Dock/undock CP To dock (and undock) a CP, double click its tab.
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Display CP Another way to display a CP is to go to the View menu and select the desired control panel.
After that, the CP appears on the screen - floating or docked. Positions of the windows are being saved
by the system so that each control panel appears in the same position as it was before it being hidden.
The controls are sorted to several groups.

Shrink/Expand dockers Having more docking panes opened, a situation where there is not enough
room for the control panels can occur. In such case, the Shrink and Expand commands shall be used.

1. Right click the pane you would like to shrink/expand. A context menu appears.

2. Select the Expand/Shrink command. When one of the panes shrinks, the neighbouring pane expands
to the emptied corner and vice-versa.

3.2. Image Window
Tools affecting the appearance of the current image are gathered within the image window toolbars
(the top image toolbar and the right image toolbar) . There are the following buttons by default:
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Figure 3.7. Image Window

Enable LUTs Applies LUTs to the image. See 6.5. LUTs - Non-destructive Image Enhancement [125].

Keep Auto Scale LUTs Applies the AutoScale command to the image continuously.

Auto Scale Performs automatic setting of LUTs.

Reset LUTs Discards the LUTs settings.

Show LUTs window Opens the window with LUTs.

Pixel Saturation Indication Turns on / off pixel saturation indication without setting on / off LUTs.
Select the highlighting color from the nearby pull-down menu for Oversaturated and/or Undersaturated
pixels. See 6.2.3. Channel Coloring [97].

Open Attachment Opens a file previously attached and saved with the ND2 file. To attach any file
to an image, right-click inside the image, select Add Attachment and choose a file to be attached.
Maximum size of the attached file is 64 MB. Context menu over the image also enables to Open Attach-
ment... (same functionality as the button), Save Attachment As... (saves the attached file separately)
or Remove Attachment (attachment is removed from the ND2 file).
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Split Components Turns ON a special view, where color channels of the image are displayed separately
(tiled). This mode is also supported in 6.3.3. Volume Viewer [106].

Fit to screen Adjusts zoom to view the whole image within the NIS-Elements AR screen.

Best Fit Adjusts zoom to fit the image window in one direction and fill the available area with the
image.

1:1 Zoom Adjust zoom so that one pixel of the image matches one pixel of monitor.

Zoom In Increases magnification of the image.

Zoom Out Decreases magnification of the image.

Show Probe This button activates the probe. The probe affects histograms, auto exposure and auto
white balance functions.

Show Background Probe Activates the background probe. Some commands use the BG probe data
as reference.

Show Grid Displays the grid for rough measurements.

Show Scale Displays the image scale.

Show Frame Displays and applies the measurement frame.

Turn ROI On/Off Displays the Measurement Region Of Interest.

Show Profile Displays the Measure > Intensity Profile control panel. It allows you to specify a linear
section in the image of which the pixel intensities graph will be created.

View LUT Intensity Displays the scale of intensities used inside the image. It works on monochro-
matic images or a single image channel.

ShowAnnotations Displays the vector layer which typically consists of annotation objects (text labels,
arrows) and measurement objects.

View Binary Displays the binary layer of the image.

View Color Displays the color layer of the image.

View Overlay Displays the color layer and the binary layer in overlay.

Tip

Right click the icons to invoke a context menu where properties of each tool can be modified.
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Channel Tabs

Figure 3.8. Channel tabs of an RGB image

Channel tabs at the bottom left corner of the image window enable switching between image channels.
You can also edit their properties using commands available via a context-menu. See also 6.2. Image
Layers [95].

Status Bar

The status bar at the bottom of the image window displays the following information:

Figure 3.9. Status bar of the image window

1. The first field of the image window status bar Image displays the calibration. See also 8.1.1. Calibra-
tion [163] , 8.1.1.3. Units [164].

2. Image bit depth (8bit, 12bit, 16bit, etc.) followed by Image size. You can change the displayed units
from the context menu.

3. Pixel coordinates of the mouse cursor along with channel intensities, Binary layer value (0 or 1) and
the Color mode (RGB, Monochromatic, etc.).

3.3. Arranging User Interface
Having a well organized application layout can help you make the work with NIS-Elements AR very ef-
fective. There are the following options on customizing the appearance of NIS-Elements AR:

Custom window placement All control panels (Camera Settings, Measurement, Histogram, LUTs, etc.)
can be arranged inside or outside of the main application window.

Compact window or multiple windows The control panels as well as toolbars can be floating or docked
on sides of the application screen.

Multiplemonitor support TheNIS-Elements ARwindow can be stretched to occupy two monitors. When
you switch from different application, NIS-Elements AR will be activated on both monitors.

Customized toolbars Toolbar buttons may be added and removed from toolbars. See 3.6. Modifying
Toolbars [34].

Maximizing the Image Area You can hide some of the GUI elements which are displayed by default:
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• The channel tabs and the layout tabs may be hidden to save some screen-space. Display the 3.9.
Appearance Options [37] window and de-select the Show Channel Tabs and the Show Layout Tabs
options.

• Image controls and the image status bar may be hidden. Use the Auto hide bottom toolbar option of
the 3.9. Appearance Options [37] window.

• When an image is displayed in great magnification, scroll bars automatically appear by the sides of
the image window. You can hide them by de-selecting the Show Scrollbars context menu option.

3.4. Layouts
A layout in the context of NIS-Elements AR is a set of options describing the arrangement of control
panels, toolbars, and menu items. Blue tabs representing active layouts appear in the application status
bar. The following layouts are placed there by default:

• Full Screen

• Docked Controls

• Measurement

Other layouts can be added and managed via the Layout Manager. To hide/show the layout tabs within
the status bar, go for View > Layout Manager and (de)select the Show Layout Tabs option.

To Create a New Layout

Figure 3.10. Layout tabs

1. Modify the current layout so that it suits your concept of work.

2. An asterisk * appears next to the layout name (to indicate it has been modified).

3. Right click the layout tab and select the Save Current Layout As or Save As Default command. If you
do not need to create a new layout but would like to save the changes made, just right click the current
(asterisk-marked) tab and select the Save command from the menu.

4. Write the new layout name and confirm it by OK .

5. A new tab appears and the layout is saved to the list of layouts.

To Reload Previous Layout Settings

You may want to undo the changes made to the layout. Mostly, it can be done by the Reload command.
Or by selecting the Load Default command.
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• Right click the asterisk-marked (recently modified but not saved) tab and choose theReload command.
The application restores the last saved state of the layout.

• Right click the asterisk-marked tab and choose the Load Default command. The application loads
the previously saved default layout.

3.5. Layout Manager
Run View > Layout Manager to display the Layout Manager. The list of currently available layouts is
placed on the left side of the layout manager. Each layout may contain information about controls,
toolbars, menu, and commands to be performed when switching between layouts.

Figure 3.11. List of Layouts

Modifying the Layout Settings

1. Select items within the Global Layout list which you want to be shared by all layouts.

2. The check marks on the left of the layout names indicate the layout visibility. Select the ones you
want to display in the application status bar.

3. If an item within some particular layout is not selected, it means you do not want to customize it and
the global settings - if selected within the Global Layout - will be used. If the item is not selected
within the Global Layout either, the settings of the most recently active layout will be used.

4. Set whether the layout is Private or Shared. If set Private, it will not be visible for other users. See
2.3. User Rights [14].

5. Customize each item according to your needs (see below).

Layout Manager Tools

New Adds a new layout to the list of layouts.
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Remove Deletes the selected layout. The first two layouts cannot be deleted.

Activate Makes the selected layout active.

Load Default Loads original settings of the selected pre-defined layout (Full Screen,Docked Controls,
Measurement) so that it looks just like after the program installation.

Lock Layout Select a layout component and click this button to lock these elements so that they
cannot be moved or closed. To unlock these components, click the button again or right-click the locked
layout tab at the bottom and click Unlock Layout.

Apply to All Ensures that the executed changes will be applied to all layouts.

Import Enables to load a previously saved set of layouts from an XML file. When you try to import a
layout with already existing name, you will be prompted to choose whether: the imported layout replaces
the existing colliding layout, or is not imported, or is imported and renamed.

Export Layouts The settings of layouts can be saved to an external XML file. Use this Export button.
In the windows that appears, define the destination file name and check which layouts will be included
in the exported xml file.

3.6. Modifying Toolbars

Hiding Toolbar Buttons

1. Display Layout Manager by the View > Layout Manager command.

2. Select the Toolbars item within the list of layouts. The right-side part of the window changes.

3. Choose one of the toolbars which you would like to modify from the Toolbar pull-down menu.

4. If selected, de-select the Use Default option on the right.

5. Any button of the toolbar may be hidden by de-selecting it. No buttons can be added to any of the
toolbars except the Main Left Toolbar.

6. The whole toolbar can be hidden by de-selecting the Show Toolbar check box.

7. There are two sizes of buttons available. Select the Large Buttons option to use the larger one. This
setting is shared by all toolbars.
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Adding Buttons to the Left Toolbar

Custom user buttons can be added to the main left toolbar. You can define your own buttons which run
single macro functions or execute macros . Select the Main Left Toolbar from the pull-down menu.

Let's say that we very often use the Image > Contrast command. It is useful to add a shortcut button
to the toolbar.

1. Press the Add button, and choose Command from the pull-down menu:

2. A new command - Command0 - is added to the list.

3. Now, assign a macro command: Open the pull-down menu on the right side of the Command edit
box and click Command List.

4. A list of commands appears. Choose _Contrast().

5. Confirm the selection by OK.

Note

It is possible to assign a sequence of commands to a single button by repeating this procedure.

If you are not satisfied with the default icon, you can change it by pressing the Change... button. A
window for selecting the icon appears. You can select the image from the NIS-Elements AR icon set or
load some other from any file containing icons (ico, dll). You can define another icon for the command
in a disabled state, too.
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It is handy to define a tool-tip (a text that appears when the mouse cursor is placed over the icon) for
your command. Simply write the text into the Tooltip box. You can change the position of the command
in the toolbar using the arrow buttons. The Default button discards your changes and inserts the default
set of commands to the toolbar.

3.7. Modifying Menus
The Main Menu and some of the Context Menus within the application window may be modified. Items
of the context menus can be hidden by de-selecting them similarly to the toolbars. The main menu can
be modified as follows:

Modifying the Main Menu

1. Display Layout Manager by the View > Layout Manager command.

2. Select the Main Menu in the topmost pull-down menu.

3. Any item may be added to the main menu - a Separator, a Menu Command, a sub-menu (Menu
Popup), and even a new menu (Main Menu Popup) - by the Add button.

4. Select the existing menu item under which you would like to place the new item.

5. Click the Add button and select the item to be added from the pull-down menu.

6. Edit the Item Properties .
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Text This is the text which appears in the pull-down menu. You may add “&” before any letter -
such letter will be considered a keyboard shortcut when browsing the menu.

Hot key One or more hot key shortcuts may be assigned to the command. Just press the Add
button and press the key combination. Press Remove to remove the selected hot key.

Enabled/Disabled bitmap, Command These fields serve for assigning a bitmap image and a
macro function to the menu command. It works the same way as when modifying the Main Left
Toolbar (described above).

Note

TheDefault button discards all changes and loads themainmenu original configuration. The Remove
button deletes the selected item. The arrow buttons move the selected item up/down. The Use
Default check box, when selected, applies the default settings to the menu.

3.8. Running a Macro Upon Layout Change
A macro command or a macro can be run upon layout change.

1. Display the layout manager by the View > Layout Manager command.

2. Select the layout by displaying of which the macro function will run and select the Commands check
box.

3. The following box appears on the right side:

4. Select the timing. The “before” option will run the command when you click on the layout tab, but
before actually changing the layout. The “after” option runs the command right after the layout is
changed.

5. When the field is enabled, type the command or insert it via the pull-down menu.

3.9. Appearance Options
General appearance adjustments can be made in the Options window. Run the Edit > General Options
command and switch to the Appearance tab.

Background Background of the main screen may use default tiles or custom color.
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Color scheme There are the following color schemes predefined within the application: Light scheme,
Dark scheme, Black scheme.

Language Select the language to be used in GUI. The language pack is a part of the Local Option [14]
feature set.

Prompts on Image Save dialog Actual words used on buttons of the window which appears if an image
has been modified and is about to be closed.

The Z value displayed in statusbar Having two Z devices, select whether to display Z1, Z2 or both on
the main status bar.

Close ND Acquisition window after Run The View > Acquisition Controls > Capture Timelapse View
> Acquisition Controls > Capture Timelapse window will be closed automatically upon acquisition start.

Enable Z intensity control This option enables the View > Acquisition Controls > Z Intensity Correction
within NIS-Elements user interface.

Image window toolbars You can decide whether the top and side image toolbar is integrated into the
main toolbar (Common for all Images) or whether each image has its own set of toolbars (Visible for
each image). The most space-saving option is to use shared toolbars and hide the image status bar
and the ND2 control bar (6.3.1.1. Control Bar [100]) automatically (Common for all images, auto hide
bottom toolbar). It will show up only when the mouse cursor rolls over the bottom part of the image.

In the Right Toolbar section you can select the appearance of buttons having more sub-options. See
3.2. Image Window [28].

Auto hide bottom toolbar This option hides the image status bar and the ND2 control bar (6.3.1.1.
Control Bar [100]) automatically. It is displayed only when the mouse cursor rolls over the bottom part
of the image picture.

Show channel tabs Show channel names and colors in the image window status bar.

Show Layout tabs Show layout tabs in the main status bar.

Show Task Bar If unselected, the Windows taskbar will be hidden.

Default vertical docker on the (requires: Local Option)

Select the preferred side for the default vertical docking pane.

Keep text size while zooming When selected, text annotations will not be zoomed with the image. See
View > Analysis Controls > Annotations and Measurements .

Allow zoom factors lower than best fit When selected, the image can be resized to be smaller than
displayed using the View > Zoom > Fit to Screen command.

Lock camera magnification If you are used to switch between two camera modes (resolutions), this
option ensures that the scene observed does not change its size or position.

Keep picture window aspect If checked, the image window respects the image size while zooming.

Initial Zoom You can select the zoom factor of the newly opened images. The options are Best Fit, 200,
100, 50, 25%.

Initial zoom 100% for Live and Capture Whenever a new Live or Captured window is opened, the zoom
will be automatically set to 100%.
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Default Volume View Rendering Engine Switch between the Old/New engine used in the Volume
Viewer.
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4. Cameras & Devices

4.1. Basic Workflows

4.1.1. Camera Selection on Startup

Let's assume the camera works properly, is connected to the PC with proper system drivers installed
and running (if required by the camera).

Setting Up the Camera

1)
Select Camera Driver

You will be asked to select the camera driver every time you launch NIS-Elements AR. You can
change the driver later using the Acquire > Select Driver command. Choose the driver that
matches your camera:

Multiple Cameras

Two cameras can be connected to one system. If this is your case and you intend to use both
cameras, check the Enable Multi Camera option and select the Second driver from the list.

The following set of buttons appears in the top toolbar when multiple cameras are used:
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2)
Selecting a Camera

Color cameras can be used in a monochromatic mode. The actual camera type (color/mono)
can be selected by the Acquire > Select *camera name* command.

Note

The emulatedmonochromatic mode is optimized for use with fluorescence specimen where
often only a single-color signal is being captured. The following formula is used to compute
intensity of the emulated mono image:

I = (Ir * Wr) + (Ig * Wg) + (Ib *Wb)

Where: W is channel weight calculated from the channel histogram and I is channel intensity.
W ensures, that channels containing some signal are accentuated while channels without
signal are suppressed. As a result, depending on conditions, the brightness of amonochrome
image might not change even if the lamp light intensity is changed.

3)
Adjust the Camera Settings

Exposure time, camera resolution, and other camera-specific features are adjustable from the
Camera Settings window. To invoke it, use the Acquire > Camera Settings command.

4.1.2. Optical Configurations

4.1.2.1. Introduction to Optical Configurations

Typically, a laboratory computer image analysis system consists of a computer, a camera, and a micro-
scope equipped with certain accessories (objectives, filters, shutters, illumination, rotary changers, etc).
Most of the mentioned microscopic hardware can be motorized and therefore can be controlled via NIS-
Elements AR. In addition, it is possible to integrate single settings of all these devices into one compact
set called Optical Configuration. It is recommended to create several optical configurations containing
particular devices settings. Then a single click can completely change the current hardware configuration.

4.1.2.2. Creating New Optical Configuration

1) Please check that all the devices (microscopes, cameras, etc.) which you want to associate with
the new optical configuration are properly attached to the system and working.
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2) Choose the Calibration > New Optical Configuration command. In the window which appears,
adjust the settings of the devices to match the intended state which will be saved to the optical
configuration.

3) Type the name of the new optical configuration to the Name field. Use a short descriptive name,
the name is used on the button in the main toolbar when you select the Show on toolbar option.

4) In the left column, select which device settings to associate with the Optical configuration.

Camera setting A list of the current camera properties appears on the right. It is being updated
dynamically.

If you want to use stored ROIs for Camera ROI setting (turn ROI on/off and use the stored ROI
value), tick “Use Stored ROI” checkbox in the Camera features box.

Channel setup These settings determine how channels of newly captured images will be named
and what color will be assigned to them. The available properties depends on the current camera
setup (color/mono, triggered acquisition engaged or not, dual view engaged or not, etc.). In the
mono camera mode, you can either assign the name, the emission length and color to the
channelManually, or leave this task toNIS-Elements AR (the Automatically option). In such case,
information of the light path (emission wavelength) will be used to determine the channel name
and color.

Microscope setting If there is more than one shutter available and you would like to associate
a shutter with the optical configuration, select which one is the Active Shutter from the pull-down
menu. Select which parts of the microscope shall be included in the configuration by checking
them in the Used devices dialog box.

Note

Active shutters remember their aperture setting and display it in the Microscope setting
section.

Objective An objective mounted to a motorized nosepiece can be included in the configuration.
Select the objective from the pull-down menu. Objectives which are currently assigned to any
position of the nosepiece are listed. See 4.1.3. Objectives [45].

Note

The objective must be assigned to a nosepiece position via the microscope control pad or
the nosepiece control panel beforehand.

5) If some of the device settings still need to be adjusted, click the Camera & Devices Controls
button and select the appropriate control panel from the pull-down menu. Adjust the settings
within the control panel, the optical configuration will be updated automatically.

6) Click Finish to save the new optical configuration and to close the window.
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7) You can create more optical configurations by repeating the procedure. The optical configurations
are saved to registry immediately. A backup of optical configurations can be made by running
the Calibration > Optical Configurations command and clicking the Export button.

4.1.2.3. Managing Optical Configurations

To display the optical configurations manager window, run the Calibration > Optical Configurations
command. You can make the following actions from the window:

• Create, duplicate, rename, delete, copy settings and switch between optical configurations.

• Modify optical configuration properties.

• Import and export optical configurations to/from an XML file.

4.1.2.4. Operations with Optical Configurations

Once created, the configuration appears in the list and can be shared with other users by changing the
Private option to Shared (see 2.3. User Rights [14]). The following operations can be performed on the
selected configuration:

• It can be deleted by pressing the Remove button. A confirmation dialog box appears.

• Its name can be changed by the Rename button. A button with the configuration name appears in
the toolbar (if the Show on toolbar option is selected).

• The configuration settings may be transferred to another optical configuration by the Copy to button.
Press the button and select the optical configuration to be overwritten with the current one.

• A copy of the configuration can be made via the Duplicate button.

• The configuration can be applied to by the Set As Active button.

• The settings of all optical configurations can be exported to an external XML file using the Export
button.

• The previously exported optical configurations settings can be loaded from the XML file via the Import
button.

• The list of optical configurations can be ordered manually using the arrow-up and arrow-down buttons.

• Each configuration can be arbitrarily modified within the right-side portion of the window.

The optical configuration buttons are available in the main toolbar when Show on toolbar option was
selected during the setting process.
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4.1.2.5. Using Auto Exposure while Switching between Optical Configurations

You can use one optical configuration when working with live image and switch to another optical con-
figuration just for the image acquisition, very often, this is performed automatically i.e. by a macro
command. If the “on-acquisition” optical configuration has the Auto Exposure camera mode turned ON,
it may produce over- or under-saturated images.

Since the Auto Exposure algorithm estimates the optimal exposure time by analyzing several last frames,
it is not able to make the estimation correctly if the change of optical configurations would cause signi-
ficant change in image brightness. To prevent this, we recommend to use Manual Exposure mode in
the optical configuration used for capturing.

4.1.3. Objectives

If you want to perform measurements on captured images it is wise to calibrate all objectives used to
capture images. Whenever an image is captured through a calibrated objective, the image inherits its
calibration.

4.1.3.1. Managing Objectives

Run the Calibration > Explore Objectives command. The Objectives window appears:

A list of used objectives can be created within the Objectives window. For each objective, the objective
name, position in the changer, storage status and the calibration are displayed. A Calculator icon
next to the calibration value indicates that the calibration has been calculated from objective properties.
If the calculator icon is missing, the calibration has been performed manually. Use the buttons on the
right side to manage the objectives:
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Insert Click the button and select one of the objectives from the database (ordered by magnification).
Custom objectives can be added to the database via an INI file.

New Press this button to create a custom objective. The new objective will be added to the list. Then,
define the Main properties and the Physical properties of the objective.

Duplicate If zoom is used, the objective calibration must be re-calculated accordingly. Use this button
to make a copy of the objective and define the zoom factor in the window which opens.

Remove This button deletes the selected objective.

Recalibrate Starts the calibration of the selected objective. See 4.1.3.3. Objective Calibration [46].

Export Enables you to export the complete list of objectives to an XML file. The standard Save Aswindow
appears.

Import This button enables you to import a complete list of objectives from an external XML file previously
created by the Export button.

Current Unit This button invokes a pull-down menu where units for the whole application can be selected.

Help Displays a help page to the Calibration > Explore Objectives command.

Edit the properties of the selected objective in the bottom part of the window. Press the Close button
to finish this window.

4.1.3.2. Assigning Objective to a Nosepiece Position

1. To assign an objective to a position or to change an attached objective assignment, click the setup
button in the nosepiece section of the microscope control pad.

2. A window appears which enables you to select one of the available objectives to the corresponding
position.

3. Each objective has its specifications displayed in the table. These specifications are not editable.

4.1.3.3. Objective Calibration

After you press theRecalibrate button in theObjectiveswindow or when creating a new custom objective,
the following window appears:
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Select one of the calibration methods:

• TheManual calibration lets you draw a distance into a picture and assign real length to it (see below).

• If a motorized XY stage is available, the Auto and 4 points automatic methods appear.

Press OK to continue...

Manual Calibration

1) When performing a manual calibration, the live image starts automatically and the following
window appears:

2) Select one of the icons to draw a distance to the image. If you know the precise calibration value
(px/unit), press the Pixel Size button to enter the real size of one pixel:

Enter the calibration value, select units, and confirm the calibration by OK . If you do not know
the pixel size, you will have to continue with the calibration on live image:

3) Insert a calibration slide to the microscope stage.

4) The distance is defined by placing lines (Horizontal, Vertical, Parallel) to the image. Choose the
orientation of the lines by pressing the appropriate button.

Note

If you are sure the camera angle is 0, 90, 180, or 270º, it is recommended to select either
vertical or horizontal lines. Otherwise, select the parallel lines.

5) Click into the image to place the first line. Place the second line in the intended position by an-
other click.
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Note

You can modify the line position while holding the primary mouse button. After you release
the button no further changes can be made. When “Parallel lines” were selected, draw the
first line by clicking twice inside the image. The line can be moved and adjusted arbitrary
by mouse. When satisfied, finish the first line by right-click. The second line can be placed
by another click to the image, this time only to adjust the distance from the first line. The
process is completed by right-click.

6) The following dialog box appears:

7) Enter the distance between the two lines and select correct units.

8) Press OK. The objective is calibrated now.

Automatic Calibration

The automatic calibration requires a motorized stage. Select one of the following methods:

Auto The Auto method is fully automatic. Calibration is performed on a part of the live image marked
by red square that is shown before the calibration is launched. You can also choose the channel to be
used by auto-calibration.
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Figure 4.9. Auto-calibration window

NIS-Elements AR moves the motorized stage, acquires two images, and calculates the calibration from
the shift of the images. The auto-calibration performs an estimation of the real relay lens zoom factor.
If the estimation does not match the value specified within the Acquire > Capture Button Setup window,
a warning appears.

Figure 4.10. Example of the warning message

It is recommended to cancel the auto calibration (click No ), check the real zoom factor of your relay
lens and check and correct the relay lens settings within the Acquire > Capture Button Setup command
window.
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Note

The success of this method depends on the texture of the specimen, its contrast, illumination, etc.
If the combination of these factors is unsuitable, the auto calibration may fail. If it fails, try the fol-
lowing:

• Move the stage to another area of the specimen to get a better texture.

• Improve contrast by setting LUTs.

• Check focus, re-focus if needed.

• Turn on the Acquire > Shading Correction > Shading Correction command ON.

4 points If you select the 4 points method, the system draws four points on the screen (subsequently)
and asks user to move one significant part of the specimen to each position. After all four steps are
completed, the calibration is calculated from the moves of the stage.

Superresolution Calibration

This type of calibration is available after successful manual or automatic calibration. It triples the camera's
resolution and uses fine stage movements to improve the resulting objective calibration. Click the Run
SR Calibration button and wait till the objective calibrates.

Calibrate Using Objective

When you have an uncalibrated image, you can use an already calibrated objective to calibrate it. Right-
click the Uncalibrated field on the image status bar and choose one of the objectives from the Calibrate
using Objective sub-menu. Of course, the same objective which was used to capture the image shall be
selected.

4.1.4. Connecting a Device to NIS-Elements

Before you get to work with NIS-Elements AR, all hardware accessories should be connected properly
to the system. In most cases, the following basic procedure is sufficient to connect a device successfully:

1. Install NIS-Elements AR, and select the appropriate device(s) during the installation.

2. Connect the device to the PC and switch the device ON.

3. RunNIS-Elements AR, and run the Devices >Manage devices command to open the Device Manager.

4. Use the Add button to add the device to NIS-Elements AR.

5. Select the device from the list of installed devices and press the Connect button.

6. Select logical devices to be activated.

7. Configure device-specific settings using the Configure (physical) Device and the (logical) Device
Parameters buttons.

8. Close the Device Manager.
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Note

MULTIZOOMAZ100M, ECLIPSE LV series, ECLIPSEMA200, or ECLIPSE L200N/300Nmicroscopes
can not be connected from NIS-Elements AR while the setup tool of each microscope is active. To
connect any of these microscopes to NIS-Elements AR, exit the setup tool and then run the NIS-
Elements AR.

Renaming of devices

Either logical or physical device can be renamed by user. Just right-click the device name and select
the Rename Device command from the context menu. The user-defined names can be handy in
two cases:

• You are using two logical devices having matching names, but you need to uniquely identify
them (e.g. from macro).

• You are used to call a device with another name and would like to rename it in order not to be
confused by the predefined name any more.

4.1.5. What are “Logical Devices”?

NIS-Elements AR handles hardware accessories using the concept of logical devices. There are features
of different hardware devices which equal and therefore can be controlled equally. Such features are
called “logical devices”. A typical logical device is Stage XY. Different microscopes can be equipped with
different XY motorized stages, although - regarding the user interface - they behave equally. One phys-
ical device (a piece of hardware) can contain one or more logical devices the list of which appear in the
Device Manager after the connection is established.

Available Logical Devices

Analyzer The analyzer is a polarizing filter placed in the optical path between the specimen and the
lamp. The logical device offers two states: ON (inserted) and OFF (extracted).

Aperture This logical device is used for controlling apertures in the light path. It is used in complex mi-
croscopes rather than as a standalone device. Two parameters can be typically set for aperture devices,
the state (ON/OFF) and aperture size.

Condenser A condenser is a two-lens combination located next to the illumination source in the optical
path. Its purpose is to collect light and direct it to the specimen being examined. The corresponding lo-
gical device relates to a changer of different condensers.

Filter This logical device controls filter changer movements. There can be several filter changers con-
nected toNIS-Elements AR at a time. Each filter changer needs to be set up - filter types shall be assigned
to positions of the changer:

1. Display the filter changer control panel ( Devices > Filters and shutters or Devices > Microscope
Control Pad ).

2. Click the settings button , a window appears.

3. Select one of the available positions which the filter will be assigned to.
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4. Click the ... button, a list of available filters appears.

5. Select the filter name from the list and confirm it by OK .

6. The filters can be moved within the already defined positions using the Up/Down arrow buttons.

Note

When browsing the list of filters, details about the currently selected filter are displayed on the
right side of the window.

Illuminator This logical device is used for controlling the specimen illumination remotely. There is no
standard dialog box for the illuminator control. Each device handles this logical device via a user interface
specially designed for it - typically containing one button for switching it ON/OFF and a slider for regulating
intensity.

Light Path Some microscopes have more than one port where it is possible to attach a light source or
a camera. This logical device can switch the illumination between these ports.

Microscope This logical device is used to group standalone logical devices used in certain microscopes.
To control the logical devices of a microscope from one control panel, select the Devices > Microscope
Control Pad command.

Nosepiece This logical device serves for controlling microscope objective changers. There can be three
nosepiece types attached to a microscope:

• Manual - it can not be controlled via the software.

• Intelligent - the current nosepiece position is read by the application, but can not be controlled.

• Motorized - such nosepieces can be fully controlled via the Microscope Control Pad or the Nosepiece
control panel.

See 4.1.3.2. Assigning Objective to a Nosepiece Position [46] .

ND Filter A neutral-density filter is a light absorbing filter whose absorption spectrum is moderately flat.
It is used to reduce the illumination intensity within the optical path. The logical device offers two states:
ON (inserted) and OFF (extracted).

PFS Perfect Focus System - this logical device corresponds to the PFS physical device available with
Nikon TE2000/TI microscopes.

Shutter This logical device can control shutters installed in your system. This device is handled via the
Devices > Filters and shutters control panel or straight from the microscope control pad. You can select
the type and rename the shutter by running a contextual menu command either within the Filters &
Shutters control panel, Device Manager window, or in the main toolbar.

Note

There was a restricted number of shutters which could be connected to the system in previous
releases of NIS-Elements AR and they were identified by Type (DIA, EPI, Aux1, etc...). The current
version supports identification of shutters by custom Names, but the Type attribute can be still
found in some windows (or used in some macro functions). This is to ensure backward compatib-
ility.
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Zoom This logical device is used for controlling the zoom factor. Run the Devices > Zoom Configuration
command to adjust the zoom settings.

Stage XY Stage XY enables the movement of specimen within X and Y axes. The system offers user to
control stage movements.

Stage Z The Z Drive device enables movement throughout the Z axis direction.

TTL/Analog Input, Output There are six more logical devices available when the NIDAQ controller set
is installed:

TTL Input
TTL Output
Analog Input
Analog Output
Calibrated Analog Input and Calibrated Analog Output.
Each of these logical devices represents a connection to an external device which can receive (send)
signals from (to)NIS-Elements. The number of available connections depends on the actual NIDAQ card.

4.1.6. XY Stages and Z Drives Tips

Please read the following tips for using motorized XY Stages and Z Drives.

Motorized Stage Initialization

A motorized stage being initialized could strike the objective. Before initializing the stage, make sure
that the objective is away from the stage. If a motorized Z drive is available, use the Devices > Objective
Clearance command to prevent this.

Setting Software Limits to Stage Movement

Some microscopes enable you to reduce the range of movement of the motorized stage by setting limits
within the configuration window.

1) Display the configuration dialog window (within the Devices > Manage devices window).

2) Move the stage to the position where the limit shall be set.

3) Click the appropriate button.

4) Set all the limits by repeating this procedure.

Caution

This procedure can not be used if you already set some limits and would like to broaden
them at the same time. NIS-Elements AR will not allow you to move the stage to any out-of-
limits position. What you need to do is to reset the limits within the configuration window
beforehand.
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Using two independent Z Drive devices

Workstations can be equipped with two independent Z drive systems, one coarse (slow) and the other
fine (fast). Typically, the first one is used for specimen manipulation in Z axis, when changing objectives,
etc. , the second one is used for auto-focusing. The following text explains how NIS-Elements handle
the two Z drives.

Absolute Z The current positions of both Z drives (Z1, Z2) and the absolute Z position (sum of Z1 and
Z2) are displayed in the main status bar. If there is not enough space to display all these values, only
the absolute Z value is displayed (Z1 and Z2 still appear in a tool-tip). The absolute Z value appears in
the Z Series Setup.

Active Z

The concept of Active Z enables user to select the preferred Z drive:

• The active Z drive is used when performing auto-focus.

• The Devices > Enable Mouse Joystick Z in Live (*current value* µm) command applies to the active
Z.

You can select the Active Z device in the Devices > Mouse Joystick and Auto Focus Z: Ti Piezo ZDrive
> Ti ZDrive menu.

Regular Z drive + Piezo Z drive

If you have a regular Z drive and a Piezo Z drive installed, some functionality is added:

• The Move Piezo Z to button is added to the Z Series Setup window when Piezo Z is selected.

• The Devices > Keeps Z position and centers Piezo Z and the Devices > Move Piezo Z to Home
Position commands appear in the Devices menu

The button and the Devices > Keeps Z position and centers Piezo Z command provide corresponding
functionality. They move the Piezo Z device to its home position, and compensate this shift by moving
the second Z drive in order to maintain the absolute Z position.

4.1.7. Camera Settings

A digital camera mounted to a microscope port records images of the observed scene on a light-sensitive
sensor, and transfers them to a computer. NIS-Elements AR supports various cameras differing from
each other in resolution, frame-rate, sensor type, etc. Despite these differences, controlling different
cameras is similar. The following features are included in the View > Acquisition Controls > Mono Sim
Settings window depending on a particular camera type.

Note

The complete list of cameras and devices supported by NIS-Elements is available in a separate
document.

1 frame for Fast Timelapse The camera head is equipped with 4GB of memory available for fast cap-
turing. Use this button to run acquisition with maximum available frame rate. However, the size of image
sequence is limited to 4GB.
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Note

The actual frame rate depends on other settings (readout mode, sensor mode) and is limited by
the read-out speed of the camera sCMOS chip. Maximum frame rate can be achieved with the
combination of Rolling shutter and Overlap sensor mode.

Note

When using the Fast Timelapse acquisition, maximum number of frames which fit to PC memory
can be determined by the Max button. However, due to specifics of Andor NEO this number is
overestimated. The real number of frames is a sum of frames which fit to the 4GB memory plus
frames which are sent to the PC during the acquisition. It is impossible to predict this number
correctly.

AE Compensation In automatic exposure modes, the compensation affects how optimum exposure
settings (Exposure time and Gain) are calculated. The Compensation value is expressed in Exposure
Values (EV). Setting the compensation to + 1.0 EV makes the image twice brighter (e.g. doubles the
Exposure time or Gain).

AE Lock This option makes the automatic exposure mode to lock the current exposure settings (Exposure
time and Gain).

Analog Gain Controls the Gain (Sensitivity) of the camera and strength of the camera analog signal
before it is digitized. This setting affects image brightness.

Auto White Balance (AWB) This button performs an automatic white balancing. It calculates the right
values and then adjusts the red, green, and blue image components in order to get a neutral white
color. The Auto White gives the best results on color neutral (gray) scenes.

Averaging Averaging is a commonly used technique of decreasing noise in the image. In this method
2, 4, 8 or 16 consecutive frames are averaged together.

Binning The binning mode provides considerably enhanced camera chip sensitivity by integrating more
elements (pixels) together. E.g.: binning 4x4 integrates the signal from the area of 4x4 chip elements
to one pixel of the resulting image. Smaller resolutions and faster frame rates are achieved using the
binning modes.

Capture Bit Depth Channel Select per-channel bit depth used for capturing.

Clear Cycles This option enables you to decide, how many times the CCD chip should be cleared (reset).
The set Clear Mode determines how often it is performed.

Clear Mode Sets how often the CCD chip will be reset. Please, see the camera user manual for further
details. These options are available:

• Automatic

• Never

• Pre-exposure

• Pre-sequence

• Post-sequence
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• Pre and Post-sequence

• Pre-Exposure and Post-Sequence

Commands > ROI > Use Current ROI Turns the camera ROI ON/OFF. See 5.3. Camera ROI [65].

Contrast Affects dynamics of how the luminosity is rendered. There are several modes for different illu-
mination (contrast) scene situation.

Conversion Gain This is a hardware pre-amplifier gain.

Cooling The Qi1/Ri1 camera heads are equipped with a cooling system that enables to cool down the
CCD chip by -5° or -10° of the current room temperature.

Warning

When cooling by -10°, theremight be a risk of water condensing inside the camera head (depending
on humidity inside the room).

Desired Temperature Sets the target temperature of the CCD chip.

Detector Mode

Only in 12bit mode
Timed A common mode for capturing images.

Strobe If the camera controller is equipped with DS-RC switch, this mode needs to be selected to
use the switch for capturing images.

Dynamic Range Dynamic range of a camera sensor is defined by the largest possible signal that it can
generate divided by the smallest possible signal. Higher bit dynamic ranges bring wider ranges of grayscale
levels from each camera pixel.

EM Gain Multiplier EM gain allows weak signals to be multiplied before any readout noise is added by
the output amplifier, hence rendering the read noise negligible. There is a complex relationship (approx-
imated to an exponential) between the value set and the actual level of multiplication. Typically, optimal
signal-to-noise ratio and dynamic range is achieved between x1 to x300 EM Gain. When the setting ex-
ceeds the value of 300, the field gets highlighted red in order to notify you.

Exposure, Exposure Mode Exposure mode determines how the Exposure time is calculated. Usually,
the user can select between the automatic and the manual mode:

Auto Exposure Automatically calculates the exposure time in order to achieve optimal brightness
of the scene. Image quality is the priority, therefore longer exposure times are preferred.

Note

Depending on particular light conditions, the result of auto exposure may not be optimal for
image acquisition.

Warning

Under- over-saturation may occur when switching between optical configurations. Please see
4.1.2.5. Using Auto Exposure while Switching between Optical Configurations [44].
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Note

Available exposure time range depends on the selected Format and Readout Speed .

Manual Exposure User selects both Exposure time and Gain manually.

Continuous AEWhen selected, the automatic exposure time is calculated continuously. If brightness
of the scene changes, the exposure time is adjusted so that the live image is not over- or under-
saturated.

Exposure Time Exposure time is the time of charge accumulation in a camera chip between two adjacent
frames. Prolonging the exposure time increases brightness of the image as well as its quality (there will
be less noise).

Fast (Focus), Quality (Capture) The software enables to create two resolution presets - Fast used for
live image and Quality used for capturing. The formats then differ in image size, and consequently in
frame rate (number of frames per second - fps). The higher the resolution is, the lower frame rate can
be achieved. Available resolutions depend on the camera type.

Note

When switching between the formats while observing the live image, the size of the image on the
screen is maintained - the zoom setting is changed instead. Only in some special cases, the beha-
vior changes and the image size is changed instead of the zoom setting which is maintained.

Gain Controls the camera sensitivity. Increasing the gain increases brightness of the image, but decreases
quality (the more random noise, the more streaky noise and color unevenness), and increases the frame
rate indirectly by enabling shorter exposure times.

Gamma The gamma correction maps the intensity of live signal exponentially to the gamma parameter.
For gamma < 1, dark portions of the image are enhanced whereas for gamma > 1, image parts of
higher intensities are enhanced.

High Quality Capture When this option is checked, images are not processed by the camera control
unit, but are sent to the computer in a RAW format. The computer then processes the images into the
RGB format. This mode produces images with less noise and better color fidelity. Of course, transfer of
the RAW data is slower than the normal mode which causes a lower maximal frame-rate.

Hue Hue shifts image colors across the rainbow.

Internal Shutter This option sets behavior of the camera internal shutter.
Opened Internal shutter is opened upon NIS-Elements and stays opened through the whole session.
Only with one exception: if the Readout Mode is set to Normal 80kHz at 16bit, the shutter stays
closed and opens only for exposures.

Closed Internal shutter is closed upon NIS-Elements startup and gets opened only for exposures.

Automatic Shutter is closed when the NIS-Elements is running. It opens only for acquisition.

Isolated Crop Mode This option turns on the Isolated Crop Mode described within the Andor document-
ation. In this special mode, the size of chip is reduced and very high frame-rates can be achieved.

Keep Overlapped If checked. The Clear Mode and Sensor Mode boxes are set to Automatic and become
disabled. This mode produces maximal frame rate and decreases the list of exposure times (in the
camera settings window). Only the times of 1 frame and longer become available.
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LimitMax. FPS to Insert maximum frame rate (frames per second) you would like to use, this will prolong
the total duration of the time-sequence in exchange for the reduced frame rate. This option may be
useful especially when using the 1 frame for Fast Timelapse button with a small region of interest. Then
the frame rate could get unreasonably high.

Note

The Limit MAX FPS is possible only when camera is in Normal mode (not overlapped), themaximum
fps in normal mode is shown next to the edit box.

Live Acceleration If the exposure time is too long, Live Acceleration helps you to make it shorter. The
system automatically shortens the exposure time (so the frame rate rises), and the loss of intensity is
compensated by increasing the gain (software multiplication). This procedure is not used upon Capture.

Maintain Temperature on Camera Shutdown If this option is checked, the camera maintains its tem-
perature until the computer workstation shut down. The temperature will be maintained for example
during NIS-Elements restart or when another camera is selected.

Maximum Exposure This is a safeguard of the time of the Auto Exposure. For quick exposure, it is con-
venient not to set this value too high.

Metering Mode If this option is available, auto exposure can be calculated with an emphasis on over-
exposed peaks (Peak) or average pixel intensity (Average).

ModeDefines how the Auto Exposure is performed. Average is suitable for bright field and Peak is better
used for dark field.

Mode This option selects the mode of the camera. In the Extended NIR mode, the camera chip sensit-
ivity in the near-infrared region of spectra is raised.

Multiplier Controls on-chip multiplication gain. There is complex relationship (approximated to an expo-
nential) between the multiplier value and the level of multiplication - in other words, the value 2 does
not mean the signal is multiplied two times.

Noise Reduction If activated, it reduces noise generated by higher gain. NR works on interframe basis
so you may notice some shadows on moving objects.

Offset Sets the brightness of the image. It is a constant additive (positive or negative) changing all pixel
values of the image. With negative offset value the dark image areas become pure black. Considering
fluorescence microscopy, an appropriate offset setting can create continuous black background and
thus help to enhance (together with gain or illumination enhancement) the contrast.

Overillumination Tolerance Sets how many pixels should be white after the Auto exposure is performed.
Use lower values (0.01%) for very bright (shining) objects (fluorescence). For common bright field, even
1% may be a good value.

Readout Mode Within this option you can select a combination of these parameters - readout speed
and bit depth. The settings influences frame rate and image quality. Higher frequencies increase frame
rate, lower frequencies offer better image quality.

Readout Rate Select the readout speed 100 or 280 MHz. If speed is not crucial, leave 100 MHz.

Readout Speed The speed of digitization - influences frame rate and image quality. Higher frequencies
increase frame rate, lower frequencies provide better image quality.

Resolution
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Note

If the resolution of 4076x3116 is used for capture and the scale is burnt to the image, the scale
position is different from the Live image. This is a consequence. To keep the scale at the same
position as in the Live image, use other resolutions for capture.

Note

The High Quality Capture mode is also supported. If the Quality is 16bit or the resolution of pixel
shift mode is selected, you cannot uncheck the High Quality Capture check box.

Saturation The amount of saturation determines how colors are rendered. More saturation produces
richer colors. Less saturation makes the colors gray.

Scene Mode, Preset There are presets of camera settings optimized for the specific usage. You can
reset the settings by the Reset button.

Neutral Neutral preset.

Industrial microscopy:
W (Water/IC) Wafer IC-Chip.

M (Metal) Metal or ceramic.

C Circuit boards.

FPD Flat panel displays.

Bioscience/Biological microscopy:
DF/FL, F Dark-field fluorescence.

DIC/PH DIC or phase contrast.

LED-Bright Field, B LED illuminated bright field.

HAL-Bright Field Halogen illuminated bright field.

HAL-HE, H Halogen illuminated Hematoxylin and eosin stain.

HAL-ELA, E Halogen illuminated enzyme labeled antibody method.

Asbestos Asbestos.

Sensor Mode This option sets the method of reading the CCD chip.
Automatic This option makes the system to choose the best mode.

Normal A standard mode where the exposure phase is followed by the readout phase. Please, see
the camera user manual for further details.

Alternate Normal Please, see the camera user manual for further details.

Overlap This mode enables the camera to achieve higher frame rates by reducing the expos-
ure+readout time (the readout is performed simultaneously with the exposure of the next frame).
Please, see the camera user manual for further details.

Frame Transfer This mode enables the camera to achieve higher frame rates by reducing the ex-
posure+readout time (the readout is performed simultaneously with the exposure of the next frame).
Please, see the camera user manual for further details.
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Separate Channel Settings Having a color camera, influence of the settings described above on each
color channel can be adjusted. In such case, three edit boxes with the default values set to 1.0 are
displayed below the feature setting. These values determine the influence of the feature on each color
channel.

Sharpness Some camera settings provide the sharpness control which affects how sharp edges in the
image appear. Too much sharpness leads to over-saturated edges.

Speed up Triggered Acquisition + Different Exposures Connect the Arm and the Ext. Trig connectors
of the camera and enable this option. When you run triggered acquisition with theUse different exposures
option enabled, it will speed up the performance (the camera will not have to wait for software triggers
but will be controlled by the Arm triggering signal).

Spurious Noise Filter This option reduces spurious noise. Try whether it has desirable influence on
image quality.

TargetMaximum IntensityRestricts the maximum of image intensity after the auto exposure was applied.
The value represents a percentage of the whole camera dynamic range.

Trigger Mode Sets the exposure method.
Internal The exposure time and the beginning of each frame acquisition is controlled by the settings
the software.

Strobe In this mode, the beginning of each frame exposure is being controlled by external signal.

Bulb The exposure time and frames timing are controlled by external signal connected to the
camera.

Trigger Mode Sets the exposure method.
Internal The exposure time and the beginning of each frame acquisition is controlled by the NIS-
Elements AR settings.

Strobe In this mode, the beginning of each frame exposure is being controlled by external signal.

Bulb The exposure time and frames timing are controlled by external signal connected to the
camera.

Triggered bymaster cameraHaving a dual camera system (or a special triggering device connected
to the camera), you can use this mode. If the cameras Interval setting is set to No delay within an
experiment or if the Live mode is run, the slave camera will be triggered only once so that both
cameras will run simultaneously while single frames will not be synchronized. If the settings are
different, the trigger will be engaged once and all the subsequent frames will be controlled by the
NIS-Elements AR settings as in the Internal mode.

Use Current ROI The currently defined region of interest, set by the Define ROI command, can be
switched ON/OFF by checking this item.

Using Probe The probe enables you to determine a small image area that serves as the data source
area for LUTs, histogram etc. It also affects the AWB (auto white balance) and the AE (Auto Exposure)
features of the cameras which support it. When the probe functionality is not supported, the AWB and
AE algorithms are computed from the whole image.

Vertical Pixel Shift
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Shift Speed Please, see the camera user manual for further details

Vertical Clock Voltage Amplitude Please, see the camera user manual for further details

White Balance There are Red, Green and Blue Gain properties that control how colors are rendered. It
is used to eliminate a color cast from white areas.

4.1.8. Controlling Illumination Devices

The substance of an illumination device is the light source. The light emission is produced mainly by a
laser, diode or a light bulb.NIS-Elements AR does not distinguish between wavelength modules of these
light sources and all are controlled in a similar manner. Basically you select which wavelength(s) you
want to use for illumination and set its light intensity. The selected wavelength modules are turned off
until you activate the shutter button usually placed in the bottom left corner of the control panel.
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5. Image Acquisition

5.1. Introduction to Image Acquisition
Having NIS-Elements AR installed and all hardware accessories set up, you can start capturing images.
Let's begin with the simplest case.

How to capture a single image

1) Turn the connected camera and other devices ON and start NIS-Elements AR.

2) Run Acquire > Camera Settings to display the Camera Settings control panel.

3) Switch camera to the Live-Fast mode ( Acquire > Live - Fast )

4) Adjust resolution of the Live Fast mode to get a continuous Live image. It is recommended to
set a low resolution in order to achieve high frame rates. This is good when searching the specimen
or when focusing manually.

5) Adjust Exposure time to get a nice image of the scene.

6) Focus on the scene.

7) Optionally, turn on the camera ROI. The Define ROI button appears on the toolbar if the camera
ROI function is supported by your camera. See also 5.3. Camera ROI [65].

8) Capture the image by running the Acquire > Capture command

9) A new image is opened automatically and named “Captured”.

Tools for Handling the Live Image

Live - Quality, Ctrl + + If a high frame rate is not crucial or if you would like to view the live
image exactly as it will be captured, run the Acquire > Live - Quality command. It displays the live image
in the Quality (Capture) resolution. This resolution is used whenever an image is captured.

Capture, Ctrl + - When pressed, the camera exposure runs till the end of the current frame,
and the next frame is captured and displayed on the screen (it is the first frame with the complete ex-
posure after you have pressed the Capture button).

If you are using the Live-Fastmode and click Acquire > Capture ,NIS-Elementswill automatically switch
to the quality mode to capture the image. When the image is captured, it is opened on the screen in a
new image window.
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Freeze, - The Freeze button interrupts the camera exposure, and displays the very last complete
frame.

5.2. Shading Correction
Shading correction is a method which can correct illumination inhomogenities of the captured images.
How does this work? First of all, a “correction image” must be captured. It is an image which represents
illumination intensities within the field of view. Such image is created by capturing a blank scene and
can look like this:

Figure 5.1. Inhomogeneous illumination

As you see in the image, the illumination intensity is 100% in the center but gets darker near the edges.
This can be corrected by applying the shading correction which will - based on the correction image -
equalize intensities of the resulting image:

Figure 5.2. Image acquired without the shading correction
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Figure 5.3. Image acquired and corrected

The shading correction can minimize the illumination and background inhomogenities by subtracting a
blank scene from the current image.

How to setup a shading correction

1) Decide whether to use just a single shading correction image or different image for each optical
configuration. Make the selection via the Acquire > Shading Correction > Shading per Optical
Configuration commands.

2) Get the correction image. You can either acquire a new image by the Acquire > Shading Correc-
tion > Capture Correction Image command or use an existing one. To use some existing image,
open it and call the Acquire > Shading Correction > Use Current Image As Shading Correction
command. In both cases the correction image will be kept in memory. To view the correction
image, run Acquire > Shading Correction > Show Correction Image .

3) In case of “per optical configuration” shading correction, repeat this procedure for with each
optical configuration turned ON.

4) The Acquire > Shading Correction > Shading Correction command is enabled if only the correc-
tion image is available for the current acquisition settings. For example, if the Shading per Optical
Configuration is chosen but the correction image for the current OC has not been captured yet,
the Acquire > Shading Correction > Shading Correction stays disabled.

5.3. Camera ROI
You can specify a camera ROI on a live image by selecting the Acquire > Camera ROI > Define ROI
command. The live image is then restricted to the defined area whenever the ROI button is pressed.
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Figure 5.4. Turn Camera ROI ON/OFF

The camera ROI can be also saved to a file for later use. This can be done by the Acquire > Camera
ROI > Save ROI command. When the time comes, load the saved camera ROI by the Acquire > Camera
ROI > Load ROI command. The current ROI will be overwritten.

The same Define ROI button appears in the toolbar of a captured image too. It does not matter
whether you define the ROI on the captured or live image, the setting is shared.

Camera ROI Definition

1) Run Acquire > Camera ROI > Define ROI . The following window appears:

2) A ROI frame appears in the image at the same time. You can either change ROI dimensions
and/or position using a mouse cursor, or you can enter precise numerical values - position from
the Left and Top and dimensions of the ROI - Width and Height. Units selected from the combo
box on the right side of the dialog window (pixels, µm, mm) are automatically applied to the ROI
definition and preview image.

3) If you would like the ROI to be placed in the center of the camera chip, click Center ROI . The
ROI will move to the center of the live image.

4) Confirm the action by the OK button.

Note

NIS-Elements may adjust the ROI size automatically after the user sets it. Such automatic
adjustment is needed in order for the ROI to work in different resolutions of the Live Fast
and Quality Capture formats.
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Caution

Nikon DS cameras have fixed-sized camera ROI, therefore width and height of the ROI
cannot be changed. Only its position can be adjusted within this window.

Predefined Camera ROI

If you are using one of the following cameras, you can choose a predefined camera ROI from the pull-
down menu which offers several predefined frame sizes.

• Andor Neo

• Andor Zyla

• Hamamatsu ORCA Flash 2.8

• Hamamatsu ORCA Flash 4.0

5.4. About ND Acquisition
NIS-Elements AR being a multi-purpose imaging system can be used as a handy tool to study objects,
live organisms, processes, etc. The universal ND2(N-dimensional) file format is what makes this possible.
One ND2 file can contain multiple images organized according to what type of acquisition they came
from. There are the following acquisition types:

Note

Each acquisition type gives a name to the corresponding dimension of the resulting ND2 file. For
example, we can speak about two-dimensional TZ ND2 file, whichmeans the file contains the Time-
lapse dimension and the Z-series dimension.

Time-lapse - T A sequence of images can be captured over a period of time and create a time-lapse
image. See 5.5. Time-lapse Acquisition [69].

Multi-point - XY Images from different coordinates of the XY stage can be acquired. See 5.6. Multi-point
Acquisition [73].
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Z-series - Z Several techniques utilize Z-stacks of images. Such Z-stack can be for example converted
to a 3D model of the specimen. See 5.7. Z-series Acquisition [77].

Multi-channel - λ Fluorescence signals can be captured selectively using excitation an emission filters,
each of them creating a different color channel. See 5.8. Multi-channel Acquisition [79].

Large image - M (requires: 6D)

When the area of interest exceeds the camera field of view, you can capture a large image composed
of multiple image frames and let it be stitched by an automatic algorithm. See 5.9. Large-image Acquis-
ition [80].

An nd2 file can be created (captured) either containing one dimension or combining several of them.

• Single-dimensional documents can be created automatically (using motorized accessories) or
manually using commands from the Acquire menu.

• To create a multi-dimensional image, use the Applications > 6D > Define/Run ND Acquisition Ap-
plications > 6D > Define/Run ND Acquisition command (ND module required).

Common ND Experiment Options

The following options can be applied to all types of ND experiments:

Experiment You can enter a custom name of the experiment. Also name of the phase is editable.

Path Browse to a folder where your ND2 images will be stored.

Save to File Please see 5.11.2. Save to File [84].

Custom Metadata (requires: Local Option)

Check this option to add custom metadata. The created metadata can be changed after acquisition.
Display image properties ( File > Image Properties ), display the Custom Metadata tab and click the
Modify Description button.

Record Data Please see 5.11.3. Recorded Data [84].

Auto Focus Automatic focusing can be used during the experiment. You can select the auto-focus
method that best meets your needs. It can be determined whether the focusing shall be performed at
the beginning of the whole experiment or at the beginning of each phase. The Define button shows a
window where you can define parameters of the selected focusing method.

Note

If the auto-focus is set to be performed Before each Phase and the ND Experiment contains just
a single time phase, the automatic focus will not be performed. To run auto focus, use the At the
Beginning option.

Closing Shutter The active shutter can be closed between single image acquisitions. Just select the
Close active Shutter... option in the experiment window.

Running Macro Commands You can define a command (or a macro) to be run in various stages of the
experiment. Select the timing in the Advanced section of the experiment window and enter the command
to be run.
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In/Out signals (requires: 6D)

An ND2 experiment can control some accessory devices and can be controlled by another accessory
devices at the same time. This can be achieved by sending/receiving Analog/TTL signals through an
NIDAQ card. If the NIDAQ PCI card is installed, an extra tab called Inputs/Outputs appears within the
ND experiment window.

Load Use this button to for a configuration XML file to be loaded. The file with the current configuration
can be created by the Save button.

Save Click this button to save the current configuration of this dialog to an XML file. A standard Save
As window appears.

ND Sequence Options

The following options can be applied to time, multipoint and multichannel sequences in ND experiments:

New This button adds new step into the sequence.

Select All Use this button to select all steps in the sequence.

Clear Selection Use this button to clear all steps selection.

Move Up, Move Down These buttons moves the current step up/down in the sequence.

Remove Current This button removes current step from the sequence.

Remove All This button removes all steps from the sequence.

5.5. Time-lapse Acquisition
Detailed studying of long-lasting processes is enabled by the time lapse acquisition mode ofNIS-Elements
AR. The achievable experiment duration is limited by the hardware abilities of your PC only. Invoke the
Acquire > Capture Timelapse > Capture Automatically command to set the experiment up:

The Time schedule table enables you to define consecutive time phases where duration, interval between
single images, and number of images of the phase can be adjusted. The Interval, Duration, and Loops
settings are bound together, so you just need to set two of these parameters. The remaining parameter
is calculated automatically. Only the selected time phases will be captured.
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The flag mark indicates the Duration/Loops priority. For example: if the camera exposure time exceeds
the defined Interval between frames, than the experiment settings are not achievable - only the marked
column will be pushed to be correct. You can set the priority column by clicking on its caption.

Special Options

The following options can be used with this type of ND acquisition. Options common to all types are
described here.

Incubation (requires: Stage Incubator)

This option is available when an incubator is properly connected. Press the Add New Incubation
button to add incubation phase to the time schedule list. You can connect the incubation phase to the
previous time phase which makes the incubation run parallel with the selected time phase. To connect
an incubation phase, press the up arrow button that appears in the Phase column next to the phase
name. To cancel the connection, press the cross button that has replaced the arrow button.

Figure 5.8. Connected Incubation Phase

The Duration column displays value defined in the Incubation Phase Settings window that appears after
you press theDefine button. Incubator parameters (temperature and gas) can be set within this window.

Switch Transmitted Illuminator off When Idle If this option is selected, the lamp is turned off
whenever there is a long-enough gap between two acquisitions.

Warning

It takes a little time for some lamps to reach the set intensity. In such case, we recommend to use
the Wait(); macro function before the capture is performed.
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FRET Checking this item turns on the FRET View for nd2 file which will be acquired. You can open the
FRET View dialog by pressing the Define FRET button.

Use HWsequencer This option is available only for A1 confocal microscope. If checked, A1 HW sequencer
will be used for acquisition. It provides the ability to define two experimental setups for HW Sequencer
on and off.

Events Press the Events... button to display the following window:

Define user hot keys which run user events during time-lapse acquisition. Simply click inside the Hot
key field of the User events window and press any key combination you want to assign to the event.
Then you can enter the event description. A macro command can be specified which will be executed
when the event occurs (triggered by user). When the event occurs, the specified command is run and
a marker is placed to the image sequence.

Tip

• Check the Show on ND Control Panel option for any event to be displayed it in the View > Ac-
quisition Controls > ND Control Panel window.

• In the Selected User Event pull down menu at the bottom of this window, choose one of the
events which will be inserted to an ND2 image sequence every time the Insert Default User
Event button is pressed. See Event and Selection Controls [103].

Note

When the time measurement runs on live image, an ND acquisition is in progress, or the Time ND
document is active, the hot keys of the defined events take priority over all other hot keys.

Keep Object in View (requires: Local Option)

This function automatically finds the object of interest based on the correlation between the previous
and the next frame and always keeps it in the center of view using the microscope stage to compensate
the object's motion.

Start by checking the Keep Object in View check box and clicking Settings to specify the channel on
which the object of interest is visible and will be followed. Move your object into the center of your field
of view. Adjust your camera and illumination setting to highlight the object. High contrast and low noise
image bring the best results. Now you can run the ND Acquisition. The stage is automatically moved in
between capturing frames so that the object of interest is always centered.
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5.5.1. Timing Explanation

When performing fast Time-lapse acquisition (capturing images in short intervals), it is important to
understand how the acquisition with digital camera works.

Case #1: No delay If the interval in the experiment is set to No delay, the camera runs in “internal
hardware trigger mode” (i.e.: Timed mode, Streaming mode). The camera sends maximum frames to
the computer. This may result in a situation where the computer is not capable of receiving all the frames
the camera sends. If so, depending on the camera type, the overflowing frames may be omitted.

Case #2: Interval is too short The time needed to receive one frame consists of three phases: exposure
time, readout time and software overhead delay.

Legend:

1. exposure time

2. readout time

3. camera sends data to PC

4. software overhead time

5. specified interval

6. resulting interval

The camera runs in a “software triggered mode” where it gives the frames much slower than in No delay
because it is being synchronized with other events. In this case it is synchronized with timing of the time-
lapse acquisition. If the interval between frames is set to a shorter time than is the sum of the three
phases (e.g. 50 msec), some latency will occur. As a result, the interval in the image sequence is pro-
longed to (exposure time + readout time + SW overhead).
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Case#3: Interval is sufficient The camera runs in a “software triggered mode”. If the interval is sufficient,
the timing in the resulting image sequence will equal the timing specified within the acquisition window.

Legend:

1. exposure time

2. readout time

3. camera sends data to PC

4. software overhead time

5. specified interval

5.6. Multi-point Acquisition
This window serves for defining XY(Z) points to be scanned during the multipoint capture experiment.
This feature is available when a motorized stage XY(Z) is present in the system. Check the Include Z box
to display the Z column. The list of defined points can be saved (and loaded later) to an XML file by the
Save (Load) button. Run the Acquire > Capture Multipoint > Capture Automatically command.
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5.6.1. Point by Point (Manual) Multi-Point

1. Move the stage to the first position.

2. Press the Add New button. A new line containing current coordinates of the stage appears in the
list.

3. Move to the next position and repeat the steps until you have all the intended points defined.

5.6.2. Well Plate (Rectangular) Multi-Point

You can insert a pattern designed to cover a wellplate. Of course it can be used to create any rectangular
pattern.

1) Click the Custom button. The following window appears

2) Select Manual if you know the distances between wells. Otherwise select the Interactive and
continue.

Manual This method will create a pattern which will scan Rows x Columns fields. The Distance
X and Y parameters specify distances between two fields. The scanning will begin at the current
position.

Interactive The interactive method lets you specify the number of fields to be scanned and starts
a wizard where you will specify the top-left and the bottom-right corner of the well plate. The
distances between wells are calculated automatically.

3) Click Finish .

5.6.3. Large Image (Covering) Multi-Point

A Multi-point which will cover certain area can be created:

1) Click the Custom button and select the Large Image tab

2) Set the large image settings:

Scan Area Select whether to define the Scan Area by number of fields or the actual field size.

Camera Select the camera to be used. This field is enabled only if you have a dual-camera setup.

Objective Select the objective for which the multi-point will be calculated. The resulting number
of fields / area size changes depending on the selected objective magnification.

74



Overlap Overlap of neighboring images in %.

3) Click Finish .

5.6.4. Random Multi-Point

(requires: Local Option)

Specify the area where a random set of points will be generated.

1) Click the Custom button and select the Random tab.

2) Select shape of the area to be filled with random points

Rectangle The area will be defined by a rectangle. Define X and Y coordinates of left top corner
of the area, width and height of the area.

Radius The area will be defined by a circle. Define X and Y coordinates of center of the circle.

3) Specify Number of points in the multi-point set.

4) Click Finish .

5.6.5. To Change a Single Z Coordinate

1. Make sure theMove stage to selected point is pressed. This button ensures that the motorized stage
moves to the coordinates of the currently selected point.

2. Click inside the line you would like to change.

3. Move the Z drive to the new position.

4. Click the <- button.

Note

The XY coordinates of one point cannot be adjusted (unless you delete it and add a new point).

5.6.6. Special Options

Autofocus None, Steps in Range, Steps in Continuous.

Custom Displays a tool for creating predefined multi-point patterns.
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See 5.6.2. Well Plate (Rectangular) Multi-Point [74], 5.6.3. Large Image (Covering) Multi-Point [74],
5.6.4. Random Multi-Point [75].

Execute Command after Capture You can either Run Macro, or select a command from the Command
list. The command is executed after capturing.

Execute Command before Capture You can either Run Macro, or select a command from the Command
list. The command is executed before capturing.

Include Z If selected, also the Z coordinate will be taken into account during XY(Z) acquisition.

Note

This option is disabled if the Relative XY option is used.

Leave PFS offset ON between points Check this item to keep PFS on while moving between the points.

Move Stage to Selected Point This button ensures that the motorized stage moves to the coordinates
of the currently selected point.

Offset All

The offset all button can shift the XY coordinates of all points in the same way:

1. Make sure theMove stage to selected point is pressed. This button ensures that the motorized stage
moves to the coordinates of the currently selected point.

2. Select one point of the list.

3. Move the XY(Z) stage to a new position (define the offset).

4. Press the Offset All button.

5. The coordinates of all points change - the same shift which you made with the stage is applied to
them.

Optimize If the Optimize button is pressed, the system will re-order the defined points in order to min-
imize the XY stage trajectory.

Point name Displays the name of the point. You can change the name (default names are #1, #2 #3,
etc.).

Redefine reference Z after Auto Focus/PFS Check this option to redefine reference Z position after
performing autofocus or PFS (if AF or PFS is turned on).

Relative XY Check the Relative XY item to consider all coordinates as relative with respect to the current
stage position. Any of the points may be used as the reference point, just right-click it and select Set
this point as a reference position.

Split Multipoints Select this box to perform the File > Import/Export > Split Multipoints command
directly after the ND2 experiment. (requires: Local Option)

Note

When you apply the Split Multipoints command on ND acquisition that contains only the XY dimen-
sion, the information about the ND dimensions in the File > Open dialog becomes unavailable.

Use Focus Surface Uses Focus Surface for capturing.
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X, Y, Z Displays X, Y and Z coordinates of the point. The arrow buttons -> <- assign the current XYZ
position to the point. The Offset All X, Y, Z button shifts the XYZ coordinates of all points by the same
offset which is defined as a difference between the current stage coordinates and coordinates of the
selected point.

5.7. Z-series Acquisition
Automatic capturing of images from different focal planes using a motorized Z drive can be performed.
Run the Acquire > Capture Z-Series > Capture Automatically command to display the setup window.
There are three different approaches of how to set the experiment:

Top and Bottom, Step

1) Press the button, the cube turns blue.

2) Run the Live camera signal. In case you have two Z drives, select the Z device from the pull-down
menu.

3) Set the Z range: move the Z drive to the top position and press the Top button, move it to the
bottom position and press the Bottom button.

4) Define the Step size in µm or the number of steps to be captured.

Note

In this mode the Home position is assigned automatically to the middle step (e.g. the third
step out of the whole 5 steps). The Reset button discards the Top, Home, and Bottom pos-
itions settings.

Depending on the direction of Z-acquisition, the last Z position (top or bottom) may slightly
differ from the user setting. However, you can select which position will be preserved exactly.
Right-click one of the Top/Bottom buttons and select Keep exact Bottom/Top Position. The
setting is indicated by underlining the button text.

Home Position, Range

1) Press one of the following buttons, the cube turns yellow. The range is defined by the home-pos-
ition and the scanning range:

Symmetric mode Define the Range by inserting a value in µm.

Asymmetric mode The range is specified by two values, Below - the distance below the
home position, and Above - the distance above the home position.

The Relative button resets the Home position value and the Z range is calculated relatively.
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2) Run the Live camera signal. In case you have two Z drives, select the Z device from the pull-down
menu.

3) Move the Z drive to the position which you would like the Z drive to move around. Press the Home
button to define the home position.

4) Specify the scanning Range .

5) Define the Step size in µm or the number of steps to be captured.

Note

When you set the Home Position in the Top/Bottom or Symmetric mode, its value is kept
after switching to the Asymmetric mode.

Special Options

Defining TIRF position When the TIRF system is enabled, the TIRF option appears in the right portion
of the window. To set the TIRF position:

• Select the TIRF check box to enable TIRF.

• Move the Z drive to the correct TIRF Z position.

• Click the Set TIRF Pos... button.

Using TIRF

• Enable TIRF by selecting the TIRF check box within the Z-Series experiment settings

• At least one value of the Z Pos column of the Multi-channel acquisition setup has to be set to TIRF
(See 5.8. Multi-channel Acquisition [79].).

Piezo Z If a Piezo Z drive device is connected, the Piezo button appears in the panel. Use the pull-down
menu to select the action which will be performed upon pressing the button:

Keeps Z position and centers Piezo Z This option moves the Piezo Z drive to the home position,
but compensates the movement by the second Z drive in order to keep the original absolute Z po-
sition(sum of Z1 and Z2).

Move Piezo Z to Home position Moves the Piezo Z drive to the home position regardless of the
absolute Z drive position.

Direction You can define the Z-stack scanning direction - either from Top to Bottom, or vice versa (Bottom
to Top).

Two Z devices Two Z devices (Main Z + Piezo Z) can be used for Z-Series acquisition and Autofocus
task in Jobs. Z device combination is used automatically if AF/Z-Stack range exceeds the range of Piezo
Z. Combining two Z devices speeds up the Z stack acquisition, however the user can still decide
whether or not to use the Z device combination. Only the Main Z device is used if it is selected in the Z
device combo box. Only the Piezo Z device is used if it is selected in the Z device combo box and the
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defined Range is within the device range. Combination of both Main Z and Piezo Z is used if Piezo Z is
selected in the Z device combo box and the defined Range is bigger than the device range.

5.8. Multi-channel Acquisition
Fluorescence (multi-channel) pictures can be acquired. Run the Applications > 6D > Define/Run ND
Acquisition Applications > 6D > Define/Run ND Acquisition command and select the Lambda tab.
There you can set the multi-channel experiment.

Channels Setup

Specify how many channels are to be captured. Set a descriptive name of each channel and select the
optical configuration that is to be used for its acquisition. If no suitable configuration exists, you can
create a new one by selecting the <define new> option from the pull-down menu in the Optical Config-
uration column. The Comp. Color column specifies the color tone, in which the channel will be displayed.
The Focus Offset column enables parfocality adjustments for different filters (wavelengths).

Special Options

Camera When you are in a multi camera mode, you can select the camera to capture each channel.

T pos. If there are T dimensions engaged in the experiment, another column called T Phase appears in
the table. You can reduce the number of captured channels by selecting First or n-th (the channel is
included in the first or every n-th time phase only).
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Z Pos. If there is a Z dimension engaged in the experiment, another column called Z Pos. appears in
the table. You can reduce the number of captured channels by selecting the Home option - the channel
will be captured within the home position of each Z series only. Also, if a TIRF system is available, the
TIRF option appears as an option. If selected, the channel will be captured within the TIRF position of
each Z series only (the TIRF position can be set within the Z-Series acquisition setup window).

Merge Cameras Available only in multi camera mode. When using two cameras, two nd2 files will be
created by default. If the Merge Cameras option is selected, only one nd2 file is created. This nd2 file
contains the maximum parameters from the two cameras (width, height and bit depth per component).

Stretch Camera images to Same Size Available only for multi camera mode. When the two cameras
differ in resolution, the camera images will be stretched to the same size.

Note

The settings of the T phase and Z Pos. columns can be combined in any way, but at least one
channel must be included in every T or Z loop. In other words, the All option must be selected at
least once in each of the columns.

Advanced Options

Wait for user before changing to next channel The application waits for the user confirmation before
changing to next channel.

Advanced for Choose OC onto which the Advanced setting is applied. Apply to All button applies the
advanced setting to all OCs used in the Setup area.

Caution

If the experiment contains Lambda tab with just one OC (one channel) in combination with other
dimensions (e.g. T, XY, Z) the Advanced options are not applied because of optimization.

Manual Capture

The Acquire > Capture Multichannel Image > Capture Manually command runs the live image and
displays a new toolbar with the Capture button. After pressing the Capture button one channel is acquired.
The number of channels depends on the settings in the Acquire > Capture Multichannel Image >
Multichannel Setup window. After all channels are acquired, theRecapture button replaces the Capture
button. It enables you to capture the multichannel image again. All previously obtained multichannel
data will be lost. To recapture a single channel, select it by mouse and press the Recapture button.
When satisfied, press the Finish button.

Capture >> This command opens a new image window with the live image and the Capture button.
After pressing the Capture button one channel is captured. The number of channels depends on the
settings of the Acquire > Capture Multichannel Image > Multichannel Setup window.

Recapture After all channels are acquired, the Recapture button replaces the Capture button. It
enables you to capture the multichannel image again. All previously obtained multichannel data will be
lost. When a single channel is selected, it can be recaptured separately.

Finish Press the Finish button to complete the multichannel capturing.

80



5.9. Large-image Acquisition
There is a special option in the ND2 acquisition window, to capture a Large Image. A motorized XY stage
is required to have this option enabled. When set to work, it captures several frames within a defined
area and stitches them together, so you get an extra large image.

Note

When camera ROI on Live Image is on (see: 5.3. Camera ROI [65]), only its frame defining the
sensor area is used during the scanning.

Scan Area

The area can be defined in three ways:

Define by setting an array of frames Check the first radio button and define the number of rows and
columns of the scanning grid.

Set the Area Size Check the second radio button and define the size of the scanned area in millimeters.

Pattern Click the Browse button and select an XML file containing a large-image pattern. This XML can
be created using the Acquire > Grab Large Image Free Shape command.

Caution

Do not mistake it with similar XMLs created by other functions. For example the XML files saved
from the Acquire > Capture Multipoint > Capture Automatically command window would not
work.

Stitching

Define the stitching method:

Stitch The system automatically stitches the images together to form a large image using precise
stitching (Image Registration). If there are more channels available, select which one to use from the
pull down menu.
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Do not Stitch The system will stitch the images together without using the Image Registration algorithm.
Stitching can also be done manually after the acquisition finishes via the File > Sequences > Stitch
Large Image from Files command.

Use ... for Stitching Select which channel will be used for Large image stitching.

Overlap Enter the percentage of image overlapping which is used for image stitching.

Close Active shutter during stage movement Check this item to close the shutter during stage move-
ment.

Wait before each Capture This delay between captures can be used for sample stabilization, e.g. after
XY movement or autofocus.

5.10. Inputs/Outputs Control
This special option in ND acquisition enables to control the experiment from outside (section When
Device Changes Then Do Action) and also allows the experiment to give feedback (sectionOn Experiment
Event Set Device Output). A special device (NI DAQ controller set) is required to run this option.

Figure 5.16. Input/Output Example

An example of an input: When voltage in dev1/ai3 line of an analog input is higher than -10 V, then the
experiment starts.

An example of an output: When experiment starts, a high TTL type of signal which lasts 50 ms is given
through Dev1/port0/line0 line.
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5.11. Combined ND Acquisition
The dimensions can be combined together creating an N-dimensional image as the result:

1. Run the Applications > 6D > Define/Run ND Acquisition Applications > 6D > Define/Run ND Ac-
quisition command.

2. The following control panel appears:

3. Select one or more dimensions (tabs) which should be included in the resulting ND2 file. Above the
tabs, there is a preview of how the nd2 file structure will look like.

4. Press the Order of Experiment button and select the item which defines the desired order of loops
in the nd2 file.

5. Set the parameters of each dimension acquisition.

6. Select whether to save the nd2 file directly to a file or just to keep it in memory to be saved afterwards.
To do so, select the Save to File check-box. The path and the file name shall be defined if saving to
a file is preferred.

7. Click the Run now button to start the acquisition.

Note

When the experiment is finished, a windowmay appear saying “Please wait. Finishing ND exper-
iment, writing image data to the harddisk”. The Cancel button within this window enables you
to abort saving of the file. Only the data which has already been physically written to the resulting
ND2 file will be available (this also concerns the Recorded Data).
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5.11.1. Z Intensity Correction

The Run Z corr button works similar to the Run now button, but the acquisition uses Z intensity correc-
tion Defined within the View > Acquisition Controls > Z Intensity Correction window.

5.11.2. Save to File

An image can be captured and saved manually after the experiment is finished, or it can be saved to
harddisk “on the fly”:

• Check the Save to File box. The window reveals an extra section.

• Insert the Path or use the Browse button to define the destination folder.

• Specify the Filename.

5.11.3. Recorded Data

The nd2 file contains various Recorded Data which carry e.g. acquisition times of single frames. Some
of them can be recorded optionally:

• Press the Record Data button. The following window appears:

• Select whether to record the data for each frame (Per Frame) or with a certain Frequency or Time.
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• The data to be recorded shall be check-marked.

• To view the recorded data of an opened ND2 file, invoke the File > Image Properties command and
switch to the Recorded Data tab.

5.11.4. Experiment Timing

This button shows the window with expected acquisition duration, total number of frames and number
of timelapse frames.

Figure 5.19. Experiment Timing window

5.11.5. ND Experiment Progress

The following window appears while the experiment is running:

85

Image Acquisition



The window displays the experiment overall progress, time elapsed from start of the experiment, estimated
remaining time, remaining free space on the disk where the captured nd2 file is being saved, and detailed
messages about the experiment work-flow such as: “waiting for next loop”, “stage moving” etc.

You can control the running experiment by the following buttons:

Next Loop When the time interval of one time loop is long enough, the system captures all the included
dimensions and waits for the scheduled beginning of the next loop. In such case the Next Loop button
becomes enabled and you can click it to start the next time loop ahead of the schedule.

Next Phase After you press this button, the experiment jumps to the beginning of the next time Phase
after the current loop is finished.

Start Phase Use this button to start the time phase selected in the combo box. Select the phase first
and press the Start Phase button.

Pause/Continue The experiment can be paused by the Pause button. Let it go on by pressing the same
button.

Refocus If there is a need to focus manually, press the Refocus button. It pauses the ND experiment
and runs Live camera signal.

Finish This button stops the experiment and saves captured data.

Abort Use this button to stop the experiment without saving the captured data.
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Events If a remarkable event occurs during the experiment, the user can press a shortcut key and the
information will be saved to the resulting nd2 file. You can define the key-shortcuts after you press the
Events button.

See Special Options [70].

5.12. Capturing to Ring Buffer
The Capturing-to-RAM technique enables user to record sequences displaying very quick actions - lasting
tens of milliseconds. Make sure that the RAM Capturing buttons are displayed on theGrabber & Devices
ToolBar (see 3.3. Arranging User Interface [31]), or use the corresponding commands.

• Acquire > RAM Capture > Circular Buffer ON

• Acquire > RAM Capture > Circular Buffer OFF

• Acquire > RAM Capture > Capture

• Acquire > RAM Capture > Settings

The technique uses a ring buffer to store temporary data. The ring buffer is a part of virtual memory that
is being constantly (and repeatedly) filled with the live image data. Depending on how fast the action
to be captured is, you should set the ring buffer size (in seconds).

1. Run the Acquire > RAM Capture > Settings command. The following window appears:

2. Set the Time buffered before/after values. These values represent the time interval before and after
you run the Acquire > RAM Capture > Capture command. Image frames from this time interval
will be included in the resulting image sequence.

3. Confirm the settings by the OK button.
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Turn the Buffer ON

• Turn the circular buffer ON by the Acquire > RAM Capture > Circular Buffer ON command to enable
buffering of the Live image to RAM.

• The ring buffer functionality gets activated. The circular buffer button (if displayed on the toolbar)
indicates the buffer activity.

Capture the Image Sequence

• Press the RAM Capture button or run the Acquire > RAM Capture > Capture command.

• A new image window containing the captured image sequence opens.

Note

If you press the Ram Capture button while in the Frozenmode or with the circular buffer turned
OFF, only the frames of the Time buffered after interval will be captured.
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6. Displaying Images

6.1. Open, Save, Close Images

6.1.1. Opening Image Files

6.1.1.1. Different Ways to Open an Image File

NIS-Elements AR offers several ways to open an image file, using either:

The File > Open command To invoke the Open dialog box where you can select the file to be opened,
run the File > Open command. This command is also called when you click the Open button on the
main toolbar

Organizer An image can be opened by double clicking its filename within Organizer. Run the View >
Organizer Layout command F10 to switch to the Organizer. See the 6.6. Organizer [133].

Recent Files List You can quickly access the last opened images using the File > Recent Files menu.

Open next/previous/first/last Commands These commands enable you to continuously open the
subsequent images from a particular directory or a database table. The File > Open/Save Next > Open
Previous , File > Open/Save Next > Open Next , File > Open/Save Next > Open First , File > Open/Save
Next > Open Last commands may be used.

Auto Capture Folder The Auto Capture Folder is a control panel that can be displayed by calling the
View > Acquisition Controls > Auto Capture Folder command. It displays images within a selected folder.
To change the folder click the button in the top left corner of the control panel and browse for another
folder. Any image of this folder can be opened by a double-click.

Any File Manager During installation, NIS-Elements AR creates file associations to files that are con-
sidered its native format for storing images (JPEG2000 , ND2). The JPEG2000 (JP2) and ND2 image
files can be then opened in NIS-Elements AR just by double clicking their names within any file manager
or the desktop.

6.1.1.2. Switching Between Loaded Images

Commands for managing the opened images are grouped in the Window menu. The recently opened
files are listed in its bottom part. The currently displayed image is indicated by the selected radio button.
To change the current image, select it from the list or use the Next or the Previous commands (repres-
ented by Ctrl + Tab and Ctrl + Shift + Tab shortcuts).
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Image windows can be also arranged automatically using the Tile horizontally or Tile vertically commands.
This will change the size and position of the opened documents and they will be arranged next to each
other in the selected direction.

6.1.1.3. Options for the Open Next Command

This window enables you to configure the File > Open/Save Next > Open Next command properties.
Run the Edit > General Options command and switch to the Open Next tab.

Open from file
Directory Specifies the directory with files to open.

Files of Type Filters the files to open by the image format.

Order By This pull-down menu enables you to select one of the image properties as the ordering
criterion. The button toggles the alphabetical order.

Prefix Filters the files to open by prefix. You can click to show advanced filtering options window.
The button turns the advanced filter on/off.

Next file Defines the name of the file that will be automatically opened after pressing OK. You can
see its name on the right side of the box.

Open from Database These options equals the ones described above.

Limit Number of Image Limit the number of documents, which will be opened and accessible in the
Opened Images tab. The maximum is 24 opened documents.

Defaults for this Page Pressing this button restores the default settings of this window. All your changes
will be lost.
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6.1.1.4. Automatic Image Sequence Recognition

When you select to open an image that is a part of image sequence such as 001.jp2, 002.jp2..., it is
recognized automatically and you are offered to convert it to an ND2 file.

6.1.2. Saving Image Files

6.1.2.1. Basic Workflows

NIS-Elements AR offers several ways to save an image file, using either:

The File > Save command Saves changes in the current image. If the current image is new (was never
saved before), the command is redirected automatically and the File > Save As command is called
instead.

The File > Save As command The most common way of saving the current image. You can select image
format in the Save as type pull-down menu. See 6.1.2.3. File > Save As Options [91].

The File > Open/Save Next > Save Next command This command saves the current image (live or
static) automatically according to the settings defined within the general options window. See 6.1.2.4.
Save Next Options [93].

During image-capturing experiments Images and image sequences can be saved automatically during
experiments such as ND Acquisition (5.4. About ND Acquisition [67]) .

6.1.2.2. Saving Images with UAC

Because of the security enhancement with the UAC (user account control) ofWindows Vista andWindows
7, it is not possible to save images in those folders that require Windows administrator user rights.
Those folders are:

• C:\Windows and subsequent folders

• C:\Users and subsequent folders excluding C:\Users\[login-user-name]

• C:\Program Files and subsequent folders excluding C:\Program Files\NIS-Elements AR\Images

6.1.2.3. File > Save As Options

Save as Type Specifies the file type, in which the image will be saved. See 6.1.4. Supported Image
Formats [94].

Save Color Image Check this option to save the color image into the file.
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Save Binary Image Check this option to save the binary layer into the file. If the selected file format
does not support layers, the option turns in Burn Binary Image. The binary data are burned into the
color data before saving the file.

Save Annotations Check this option to save the annotation layer and the scale layer into the file. If the
selected file format does not support layers, the option turns in Burn Annotations. The currently displayed
annotation/scale data are burned into the color image before saving the file.

Compression Choose the image compression level (only some image formats support different com-
pression levels).

SaveWhen pushing the Save button, the Archive information dialog box appears (For LIM and JPEG2000
formats only). Confirm it to save the image.

TIF Compatibility OptionsWhen saving other than 8- or 16-bit tif file, you can choose to keep the original
bit depth of the new file, or to rescale it to 8- or 16-bits. For all new tif files you can also select the option
to convert a multichannel image to RGB.

Note

If you are saving 16bit tiff images, the Scale 16bit to 8bit option is available while the Scale 16bit
to 16bit option is not available. If you are saving 8bit tiff images, the Scale 8bit to 16bit and Scale
8bit to 8bit options are not available.

Saving to AVI/MOV files AVI and MOV movie files can be created from a nd2 file. When the *.avi/*.mov
format is selected in the Save As Type combo box, the following options appear:

Compression Select which video compression is applied on created movie files. See 11.4. About
Video Compression [229].

XY Points When the ND document contains XY points, you can decide how these are saved. Either
only the current point can be saved into the file, or all XY points can be saved in separate files
which are recognizable by “_number” suffix.

Output Timing Parameters Timing of frames of the resulting AVI movie may equal the Original Ac-
quisition Time. If this does not suit your needs, define a custom interval in ms .

Experiment Loop Select the dimension, frames of which will be used to create the AVI movie. The
dimension must be present in the ND2 file necessarily.

Use Time Loop The T dimension frames of the current Z stack position will be used.

Use Z-stack Loop The Z dimension frames of the current Time position will be used.
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Use Z-stack and Time Loop All frames of the ND2 file will be used in the AVI movie.

When the Multipoint dimension is present, only frames of the current Multipoint position are
used automatically.

6.1.2.4. Save Next Options

This window enables you to configure the File > Open/Save Next > Save Next command properties.
Run the Edit > General Options command and switch to the Save Next tab.

Save to File
Directory, Prefix, Digits, File Format, Compression Defines name of the file that will be automat-
ically generated. Let's assume, that you have selected - Directory: c:\images; Prefix: seq; Digits: 4;
File Format: JPEG2000. Then, by pressing Enter (calling the Save Next command), an automatic
file named “seq0001.jp2” is generated and saved to the “c:\images” directory. When pressing
Enter again, the file “seq0002.jp2” is saved to the same directory etc.

Define Image Info Displays a dialog box, where you can enter some description (jp2 meta-inform-
ation), that will be saved with every image:

Overwrite/Skip already existing files Allow or deny rewriting of the images already existing in the
default save directory.

Save to DatabaseWhen selected, images are being saved to a chosen database table, instead of saving
them directly onto disk.

Database If you are already connected to some database, select it from the pull-down menu. Else
a dialog window appears, which enables you to connect to any database.

Table Select the database table which the images will be stored to.

Autoincremental field Choose which field of the database will be used to store the generated image
descriptions.

The image descriptions are generated according to the Prefix, Digits, Number values. Let's assume,
that you define - Prefix: seq; Digits: 4; Number: 20. Then, by pressing Enter , the current image is
saved to the selected database table and the automatic image description is put into the Autoin-
cremental field of the table. Its name would be “seq0020” in our case. When pressing Enter again,
the second record signed “seq0021” is created.

External mapping You may create an external *.txt or *.ini file containing mappings that assign
table field names to some particular values. These values are automatically filled into the database
records when the Save Next command is called. Please, see the comments below for an example.

Note

External mapping example - The *.ini file content may be:

[Table 1]
Author=Jack Sparrow
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Experiment number=12
Sample=Malus silvestris

It means: When saving images to the database table named “Table 1”, the fields of Author,
Experiment number, and Sample will be filled with the specified values.

Options
Show grabbing dialog before saving Before an image is saved the Grabbing dialog box is shown.
Selecting this option enables you to define the way of grabbing (with/without a shading correction,
averaged etc).

When saving, display Image Info dialog box You can change the default image information (jp2
meta-information) right before saving.

Sound Alert If checked, a short tone from your PC speaker is played every time the Save Next
command is used.

Save with annotation and binary layers If checked, images are saved together with the binary and
annotation layer.

Change to live after saving an image After saving a single image, a Live image is displayed imme-
diately.

Defaults for this Page Pressing this button restores the default settings of this window. All your changes
will be lost.

6.1.3. Closing Images

• The currently displayed image can be quickly closed by pressing the cross button in the top-right
corner of the image window.

• The image can be also closed by invoking the File > Close File > Close command.

• If you want to close all images, use the File > Close All command.

• If you try to close an image that has been changed,NIS-Elements ARwill display a confirmation dialog
box, offering to save the changes.

• Use the Window > Close All but Current command to close all opened documents but keep the
current one opened.

6.1.4. Supported Image Formats

NIS-Elements AR supports a number of standard file formats. In addition,NIS-Elements AR uses its own
image file format (ND2) to fulfil specific application requirements.

JPEG2000 Format (JP2) An advanced format with optional compression rates. Image calibration, text
descriptions, and other meta-data can be saved together with the image in this format.
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ND2 Format (ND2) This is the special format for storing sequences of images acquired during ND exper-
iments. It contains various information about the hardware settings and the experiment conditions and
settings. It also maintains all image layers of course.

Joint Photo Expert Group Format (JFF, JPG, JTF) Standard JPEG files (JPEG File Interchange Format,
Progressive JPEG, JPEG Tagged Interchange Format) used in many image processing applications.

Tagged Image File Format (TIFF) This format can save the same amount of meta-data as JPEG2000.
TIFF files are larger than JPEG2000 files but are loaded faster. TIFF files have several ways to store
image data, therefore there are many versions of TIFF. NIS-Elements AR supports the most common
TIFF modalities. TIFF image format in NIS-Elements supports also floating point images.

CompuServe Graphic Interchange Format (GIF) This is a file format commonly used on the Internet.
It uses a lossless compression and stores images in 8-bit color scheme. GIF supports single-color
transparency and animation. GIF does not support layers or alpha channels.

Portable Network Graphics Format (PNG) This is a replacement for the GIF format. It is a full-featured
(non-LZW) compressed format intended for a widespread use without any legal restraints.NIS-Elements
AR does not support the interlaced version of this format.

Windows Bitmap (BMP) This is the standard Windows file format. This format does not include addi-
tional image description information such as author, sample, subject or calibration.

LIM Format (LIM) Developed for the needs of laboratory image analysis software. Nowadays, all its
features (and more) are provided by the JPEG 2000 format.

ICS/IDS image sequence ICS/IDS image sequences are generated by some microscopes and consist
of two files: the ICS file with information about the sequence; the IDS file containing the image data.
The ICS file must be stored in the same directory together with the IDS file.

Caution

ND Images containing multi-point XY dimension cannot be saved to a file in the ICS/IDS format.
See also 5.4. About ND Acquisition [67].

NanoZoomer files (NDPI, VMS) (requires: Local Option)

We can open these files produced by Hamamatsu devices and save the image information to an ND2
file.

ShuttlePix files (requires: Local Option)

Nikon ShuttlePix Digital Microscopes produce standard TIFF and JPEG files and save the calibration info
to a separate file. NIS-Elements recognizes the calibration file and loads it along with the image data.

6.2. Image Layers

6.2.1. Introduction to Image Layers

The following image layers can be saved within a NIS-Elements AR image.
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Annotation layer In this layer, vector objects are stored. The results of manual and automatic measure-
ments, text labels and other annotations can be included.

Binary layer(s) The binary layer is usually the result of thresholding. By thresholding, you distinguish
objects of interest from background. A picture of night sky can make a nice example - shining stars may
be “thresholded” and compose the binary layer. Then, by means of automatic measurement, you can
e.g. count them. More than one binary layer can be placed over one image.

ROI layer ROIs (regions of interest) is a strong tool for distinguishing objects from background similar
to the binary layer. The advantage over the binary layer is that ROIs are vector objects and therefore
provide different way of manipulation. See 7.4.1. Introduction [157].

Color layer The color layer contains the image data captured by a camera. It can handle images with
the depth of up to 16 bits per color component. The dimensions of this layer determines the dimensions
of the other layers.

Note

When saving an image, only some file formats are capable of saving all the layers. The other image
formats will save the content of the color layer only. See 6.1.4. Supported Image Formats [94].

6.2.2. Image Types

RGB Images

Images acquired by a color camera typically consist of three components that represent red, green and
blue channel intensities. You can display a single color channel using the tabs located in the bottom-
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left corner of the image window. Or, an arbitrary combination of them can be selected while holding the
Ctrl key down.

Multi-channel Images

These documents usually arise from fluorescence microscopy. Instead of 3 color components (RGB),
multichannel images can be composed of arbitrary number of user-definable color channels.

Note

If there is a image that contains more than 8 components, the tabs in the bottom left corner of
the image are replaced by the wavelength dimension, similarly to how other dimension loops of
nd2 files are displayed.

Click the Treat As Spectral button to use the current image as a spectral image and to reveal more
channel switching features in the bottom control bar.

ALL Selects the full spectrum of the image including spectral (FLUO) and transmitted detector (TD)
channels.

FLUO Selects only spectral channels. This button is useful for quick switching between FLUO and TD.

TD Displays only the transmitted detector (TD) image.

CUST. This button displays custom channels. To set a channel (multiple channels) as custom, make a
channel selection in the control bar, right-click over the selection and choose Set selected channels as
Custom.

ND2 (multi-dimensional) files / datasets

An nd2 file is usually a sequence of images. OneND2 file can contain multiple images organized according
to what type of acquisition they came from. There are the following acquisition types, also called dimen-
sions available: Time-lapse, Multi-point, Z-series, Multi-channel, Large-image. The dimensions can be
combined together.

Please see 6.3.1. Navigation in ND2 Files [100], 5.4. About ND Acquisition [67]

6.2.3. Channel Coloring

Single channels and monochromatic images can be visualized using a predefined color scale. Right-
click the “channel tab” in the bottom left corner of the image window and select a color scale from the

Channel Coloring... sub-menu.

97

Displaying Images



6.2.4. Assigning Colors to Channels

Despite the color in which a channel is displayed, other per-channel colors can be assigned to it. This
regards colors for:

• indication of oversaturated pixels

• indication of undersaturated pixels

• indication of binary pixels

In the context menu over a channel, select Colors for... and choose a color for oversaturated pixels,
undersaturated pixels (these colors are used globally for all images in NIS-Elements until next change)
and for binary pixels. Selected color for binary pixels is linked to the channel name and is shown in all
images having the same channel name.

Color of oversaturated and undersaturated pixels may also be selected from the pull down menu next
to the Pixel Saturation Indication button shown in the image toolbar.

Figure 6.8. Pixel Saturation Indication sub-menu
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None The pixel saturation will not be indicated.

Take color from channel tab Color which has been previously assigned to oversaturated and undersat-
urated pixels in the menu over the channel tab will be used. See 6.2.4. Assigning Colors to Channels [98].

Complementary color Colors complementary to the display color of each channel will be used in order
to ensure good visibility of the highlighted pixels.

6.2.5. Copying Channels by Drag and Drop

Drag one of the channel tabs and drop it:

• to another image, so it will become a multichannel image;

• inside the NIS-Elements AR application window in order to create a new image

Note

• Even the All and RGB tab can be copied.

• When extracting a channel from Live image, it does not freeze the camera signal.

• Any user events (6.3.1.2. Events [102]) present in the document are automatically transferred
during the channel extraction.

ND2 files

1) Drag one of the channel tabs and drop it by the primary mouse button. It behaves the same way
as if performed on a single image.

2) Drag one of the channel tabs by the secondary mouse button and drop it to the application
screen. A context menu appears that enables you to select whether to create the new image
from all frames or just a single frame.

3) Two nd2 files that have matching structure can bemerged into one easily. E.g. two single channel
Z stacks with the same number of Z positions can be merged into a single two component ND2
Z-stack by dragging one into the other.

4) Drag one of the channel tabs of a single image and drop it to an nd2 file. The channel will be
copied to every loop of the ND2 file.

Note

This behavior, too, takes place when copying channels that do not have matching structure
(just the current frame is copied to every position of the target ND2)
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6.2.6. Shifting Image Channels

The currently selected channel(s) can be shifted using the CTRL + SHIFT + Arrow keys. All
channels are visible during the operation so you can see the complete image.

The procedure also works on nd2 files equally to other image processing performed on ND2 files:

1. Select the image frame and the channels to be shifted.

2. Perform the shift using Ctrl+Shift+Arrows keys.

3. A standard ND2 image processing window appears (see 7.1.2.2. ND2 Files Processing [142]).

4. Select which part of the nd2 file to apply the shift to, and confirm it by OK .

6.3. ND Dimensions

6.3.1. Navigation in ND2 Files

6.3.1.1. Control Bar

When an ND2 file is opened, its structure is pictured at the bottom of the image window. There is a time
line with all captured images indicated by gray markers. The blue-highlighted marker indicates the cur-
rently observed image. Below the time line, loops of each dimension are indicated by rectangles. In case
the multi-channel dimension is included and the number of channels does not exceed 10, the channels
are indicated by the color tabs at the very bottom of the image window. Selection in the time line and
in the loops is highlighted green.

Browse the nd2 file by clicking inside the time line. You can also display a single loop by selecting the
corresponding blue rectangle. There are some examples, how the nd2 file control bar can look like in
different cases:

Figure 6.10. A T/Z/multi-channel image with some loops selected.
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Figure 6.11. A T/Z/multi-channel image containing 11 channels and the time line hidden

Figure 6.12. An HDR multi-exposure image

Playing Controls

Play Sequence Plays all images of the dimension at selected speed. If a selection is applied, only
the selected images will be included in the playback.

Stop Playing Stops playing the sequence at the last displayed frame.

Previous Position Displays the previous frame of the dimension.

Next Position Displays the next image of the dimension.

Decrease/Increase Playing Speed Changes the playback speed by one step down/up

Real Time Playing Speed Sets the playing speed to real-time (as the image was captured).

Maximum Playing Speed for Every Frame Sets the playing speed to maximum while the display of
every frame is guaranteed (when the speed is set to maximum by the + button, some frames are usually
omitted when playing the sequence depending on your graphic card).

Home Position Displays the frame of the Z dimension that was set as “home” during the acquisition.

Tips

• Right-click the selection to invoke a context menu. The selection can be adjusted, deleted, or the nd2
file can be cropped.

• Time Axis can be hidden by unchecking Show Time Axis in the context menu over a single dimension
frame.

• Detailed info about dimensions will be displayed after you click the leftmost button of the control bar
(T>, Z>, ...).

• Place the cursor over one of the dimensions. A tool-tip which displays statistics of the dimension ap-
pears.

Playing options

Right-click the speed bar to display the following context menu and select the playing mode.
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Backward/Forward/Back and Forth commands define the direction how the image sequence will be
played. When you check the Stop on Events option and then press the Play Sequence button, a dialog
window appears once the first user event is reached. The dialog window displays information about the
reached user event. Use the Continue button to continue playing to the next event, or press the Stop
button to stop the playback at the current frame. Within the window, you can also select the Do not ask
again in this session (Always stop) option. Playing will then stop automatically on every user event but
the window will not be shown. Repeat command sets the repetitive infinite playback. Fast Advance
command corresponds to the Maximum Playing Speed for Every Frame button described above. Real
Time command corresponds to the Real Time Playing Speed button described above.

6.3.1.2. Events

User events can be pinned to any of the frames of the image in order to highlight a remarkable scene
or action. There is number of event types. Some of them are inserted automatically while the ND exper-
iment is running, others must be defined by user (by the button). You can manage the events from
several context menus which appear when you right-click:

• The time axis

• The Insert Default User Event button

• One of the event markers

All the context menus contain the EventManager command. Open the EventManager to manage events
within the current nd2 file. The time can be put in, and the event type selected from a combo box. See
5.5. Time-lapse Acquisition [69].
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Event and Selection Controls

Insert Default User Event This button inserts an event marker to the current frame.

Move to Previous/Next User event Click these arrows to browse through the frames where user
events occur.

User Event Selection This button selects frames of the ND2 file according to the Event Playing
Range settings - right click this button and pick the Event Selection Range command from the context
menu to view/modify them. A simple window appears. Define the number of frames/seconds which will
be selected around each event.

Range Selection Clicking this button selects a user defined range of frames. The selection is done
by mouse. A range can also be selected by mouse while holding the Shift key down. Single frames
can be added/removed while holding the Ctrl key down. Right-click the navigation bar to invoke the
context menu. A single frame can be selected (Select Frame) or deleted (Delete Frame). Multiple selected
frames can be deleted (Delete Selected Frames) or extracted from the rest (Keep Selected Frames).

Note

ND2 files may contain extremely large number of frames so it may be helpful to omit some of the
frames from the selection. Right click the Range Selection button and a context menu appears. It
enables you to select every 2nd, 5th, 10th, 20th, 50th, 100th frame. The Select All Frames option
selects the whole range of frames as if you have selected the first and the last time phase with
the Shift key down, but preserves the Select Every... setting. Invert selection selects only the
frames that were not selected before executing this command.

Disable Selection Press this button to de-select all frames of the nd2 file.
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6.3.2. ND Views

There are several views which can display the nd2 files in various ways. Some views are available for
some dimensions only. If a view is available for two or three dimensions of the nd2 file, a pull-down
menu appears in the top image toolbar. There you can select the dimension to be displayed.

Note

When you switch the view, a new image window opens by default. This behavior can be changed
within the Edit > General Options command window so that only one view of an image will be
opened at a time.

Main View When you open an ND2 file, it opens in this view.

Maximum/Minimum Intensity Projection View These projections analyse all frames of one di-
mension and pick pixels with the maximum/minimum intensity values. These pixels are used in the
resulting image. (Requires Z or T dimension)

Slices View This view displays orthogonal XY, XZ, and YZ projections of the image sequence. (Requires
Z or T dimension).

Volume View This view creates a 3D model of the acquired object. (Requires Z dimension)

Tiled View This view displays frames of the selected dimension arranged one next to other. (Requires
Z, T or XY dimension)

One or two dimensions can be viewed at a time.

Figure 6.15. Main View, Max/Min Intensity Projection View
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Figure 6.16. Volume View

Figure 6.17. Slices View
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Figure 6.18. Tiled View

6.3.2.1. ND2 Information

Information about current frame of an ND2 document or live image can be displayed using the Show
ND Information command from the image contextual menu. It displays information about the current
frame of the ND2 document or live image. All possible information (metadata) are displayed by default.

You can edit which information is displayed in the Label Properties dialog window. Right click the ND2
information field and select ND Info Properties.... Select displayed features from the Available ND in-
formation area and use the ^ button to insert them into the ND information text scheme area which
defines the visible information. Use Format options tools to specify the data format (e.g. numeric precision,
date format, etc.) and adjust the text appearance in the Text Box tab. Always show Acq. Time forbids
removing the Acquisition Time information from the ND information text box.

6.3.3. Volume Viewer

6.3.3.1. Introduction

Run the View > Image > ND View > Volume View command to display the current Z-stack as a 3D
model using perspective projection. If your graphical card supports DirectX 10 or newer, the model
automatically opens in the New Engine. Otherwise the Old Engine is used.

6.3.3.2. New Engine

The New Engine (requires graphical card supporting DirectX 10 or newer) brings additional functionality
and better rendering performance than the Old Engine. To switch between the new/old engine, execute
the Edit > General Options command, click on the Appearance tab and use the combo box in the 3D
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rendering area (see: 3.9. Appearance Options [37]) or use the 3D Settings icon on the main toolbar
and the Renderer combo box.

Window Toolbar Options

Volume Options Displays the Volume Options panel containing more volume controls and features.
The most useful features are already listed in the main toolbar (see: Volume Options Tab [111]).

Free rotation control mode Click and drag over the model for free rotation.

X-axis rotation control mode Rotate the model only in the X axis.

Y-axis rotation control mode Rotate the model only in the Y axis.

Z-axis rotation control mode Rotate the model only in the Z axis.

View Plane Select which plane will be facing towards your perspective. TheDefault view is slightly rotated
so that the structure of the sample can be overviewed. The six other views display side views and hori-
zontal projections.

Blending Each blending mode mixes the Z slices together using different transparency and interpolation
patterns. Choose which one fits your sample the best.

Alpha (Alpha Blending) Uses the physical principles of light absorbing, so that the object surfaces
are accentuated.

MaxIP (Maximum Intensity Projection) Only the pixels with the highest intensity values of the Z-
sequence are displayed in the image.

MinIP (Minimum Intensity Projection) Only the pixels with the lowest intensity values of the Z-se-
quence are displayed in the image.

AccumulatedIP (Accumulated intensity projection) Sums up (accumulates) all pixel intensity
values of the Z-sequence. This blending mode can be fine tuned in the 3D Renderer Settings dialog
window (see: 3D Settings [108]).

Depth Coded Alpha (Depth Coded Alpha Blending) A color gradient perpendicular to the Z-stack
planes is applied to the volume. Lower part of the volume is colored with different colors than the
middle and upper section enabling to easily distinguish the position of examined objects.

Depth CodedMaxIP (Depth CodedMaximum Intensity Projection) Applies a color gradient to the
pixels with the highest intensity values of the Z-sequence.

Shaded (Shaded Volume) Uses the physical principles of light absorbing and reflectance. The object
surface becomes more distinguishable. The shading volume lightning type can be altered in the
3D Renderer Settings dialog window (see: 6.3.3.2. New Engine [106]).

Note

Depth Coded Alpha andDepth CodedMaxIP blendingmodes support Z coloring. Choose a predefined
Z color gradient by clicking on the gradient button. Four options at the bottom of the sub-menu
define the gradient color direction and value order (Low to High or High to Low). The same menu
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can be evoked when right-clicking over the gradient scale bar in the bottom left part of the image
window.

Show Box Displays a box bounding the 3D image.

Show/Hide Grid Enables to show or hide the graticule. Define visible graticule planes in the Grid &
Scale section of the Volume Options panel.

Show/Hide Scale Displays/hides a scale around the bounding box.

Show volume info This button displays/hides the navigation axis/cube and information about the
calibration and volume dimensions which are displayed at the bottom of the image window.

Note

To display ND information andmetadata, right-click into the image and select Show ND information.

Show Hi/Low Resolution Rendering Low resolution is recommended for basic volume previewing.
When precise static details are to be visualized, switch to High resolution. The most noticeable changes
between these two modes are observed in large images (beyond the graphic card capabilities).

If the image is fully loaded into the memory of the graphical card, High resolution is turned on, the
viewer shows the maximum quality and the button is automatically disabled. If the memory capabilities
are exceeded, two more modes appear -Highest Possible Resolution (optimized for the highest resolution
without downsampling; can be slower) and Balanced Resolution vs Speed (resolution can be lower;
speed performance should be sufficient).

3D Settings This button enables you to fine-tune the 3D renderer performance. The following window
appears:
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Renderer Enables to switch between the New Engine and the Old Engine.

Quality Settings
Still image / Interactive mode Still image settings will be used for static viewing (which
usually allows the highest quality) while the Interactive mode settings will be used when
moving with the 3D model.

Details Select the desired quality settings.

Resolution Select the resolution of the 3D scene. Available options express the ratio of the
current image window size. The Limited option actually equals 1/4 but differs when the image
window size is reduced so that the image would lack details in the 1/4 resolution.

Rendering Settings

Enables to set further settings for the rendering modes.
Shaded volume lighting Choose one of lighting modes.

Binary objects lighting Lighting presets are available in this combo box. Illumination is adapted
according to the selected binary surface.Balancedmode automatically balances light irrespect-
ive of the surface type.
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Accum. intensity projection Modifies (multiplies by a coefficient) the pixel intensity sums
created by the AccumulatedIP blending mode.

Colors Using these color combo boxes you can define the background color, bounding box color
and color of the labels.

Switch to full screen mode rendering This option switches the volume viewer to fullscreen mode.
You can abort this mode by pressing Esc . When using two monitors, the Volume Options window can
be controlled from one monitor and the 3D Volume can be in full screen on the other monitor.

Create Movie This button runs the Movie Maker application. It enables to create AVI movies of the
3D model. See 11.3. Creating a Movie [227] for further information.

Show Help Displays the help page.

Figure 6.20. Navigation axis and navigation cube

3D Navigation tools

Navigation in the 3D image can be facilitated by the navigation axis or navigation cube. Switching
between these two is done from the context menu over the axis/cube. The graphic not only shows you
the exact position of the 3D volume in xyz dimensions but it can be used to align the volume with one
of the axes (click on the desired axis in the axis mode), with a cube plane (click on the cube wall) or to
rotate to a node projection (click on the white ball of the cube). To reset the view into default, double-
click directly into the 3D image.
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Figure 6.21. Volume Options tab

Volume Options Tab

Z-zoom Adjusts the Z-step height of the image Z sequence.

The first frame is highest/lowest Use these two buttons to set the first frame as the
highest/lowest one in the sequence.

Toggle light visibility This option is supported with Alpha and Depth Coded Alpha blending. Press
the button to switch the light on. Move the light freely around using the left mouse button. Double-click
on the light to pin it to the Scene (stays in its place, 3D volume moves) or Volume (light moves together
with the 3D volume). Change the light intensity with the mouse wheel when the cursor is over the light.
Context menu over the light can be used to Reset Light Settings.
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Show smooth volume Click on this button to smooth the 3D volume.

Show non-interpolated volume Click on this button to display raw, non-interpolated 3D volume.

Anaglyph 3D stereo This button enables/disables the anaglyph 3D view. Press the arrow next to
the button to display the menu with possible color combinations (depends on the type of your anaglyph
glasses).

Open Z-LUTs for Volume View (requires: Local Option) Opens the Z-LUTs for Volume View panel.

Show/Hide Displays or hides any cropping and cutting made on the 3D image.

Reset AllRemoves any crop changes made on the image and returns the cut planes into their default
position.

Extract Extracts a new document from the current view limited by the crop/cut tools.

Ortho Orthogonal crop enabling to crop the 3D image perpendicularly. Hold down Ctrl and move
the desired plane with the left mouse button.

Arbitrary Arbitrary crop enabling to crop the 3D image freely. Hold down Ctrl and move the yellow
ball to position the center of the cropping plane and then move the yellow cone to tilt the plane which
is illustrated by the white circular grid.

Both Both orthogonal and arbitrary crops are enabled at the same time (see above).

Note

If you restrict the volume size using the cropping tools, you can shift the result inside the original
volume in all three directions. Press Ctrl + Shift and then click and drag over a plane determining
the shift direction. Color lines with crosses indicate the shift axis.

XY Plane delimited by x and y axis can be used for cutting through the 3D image. Hold down Ctrl
and drag the cutting plane in Z direction.

YZ Plane delimited by y and z axis can be used for cutting through the 3D image. Hold down Ctrl
and drag the cutting plane in X direction.

XZ Plane delimited by x and z axis can be used for cutting through the 3D image. Hold down Ctrl
and drag the cutting plane in Y direction.

Any Any plane can be used to cut through the 3D image. Hold down Ctrl and move the yellow ball
to position the center of the cutting plane and then move the yellow cone to tilt the plane.

Crop channels Select which channels will be cropped. This option is available only with Orthogonal
cropping.
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Threshold 3D Opens the 3D threshold window used for visualizing 3D binary objects.

Spot Detection 3D (requires: Local Option) Enables to detect bright/dark circular objects within a
3D space. Please see: 7.2.2. Spot Detection [146] for more information.

Colorize Binary by 3D Objects This function is used to distinguish between binary objects by color-
izing each 3D object with a different color. This function can be turned on/off in the context menu over
the 3D image where it is also possible to change the color of each binary 3D object (Change Binary 3D
Object Color).

Objects 3D Opens the 3D Object Measurement tab displaying values of measured features for each
3D object in the image.

View Binary Displays the binary layer of the 3D image. Use the key shortcut Ctrl + B .

View Color Displays the color layer of the 3D image. Use the key shortcut Ctrl + R .

View Overlay Displays the color layer and the binary layer of the 3D image at once. Use the key
shortcut Ctrl + V .

Show/hide centroids Displays/hides a centroid for each binary object in the 3D image. Adjust the
Centroid radius in the combo box below.

Measure 3D Enables to measure distances inside the 3D image. Annotations and Measurements
tab is opened where Length 3D is automatically selected and measurement results are shown in
the table below. When measuring centroids, the start/end of the measuring line automatically snaps
to the center of the closest centroid.

Note

To measure distances more precisely, switch to Slices View , make the measurement in the partic-
ular Z-plane and switch back to Volume View.

Grid & Scale This section enables to display additional grids and scales. Activate On Back Surface to
view a grid on the bottom and distant sides of your current volume rotation. Color of the grid can be
altered in the Line color combo box. Density of the grid can be adjusted manually in the Density edit
box or switched to Auto for automatic calculation of suitable spacing. Turn on Scales to show the grid
dimension - Density step shows the grid size over one square whereas Ruler marks each grid line with
its distance from 0. Which axes will be labeled is defined in the combo box (XYZ or Z). Direction of the
Z ruler can be inverted using the Inverted Z-Values check box. Color of the scale and its labels can be
changed in the Font color combo box.

Planes Inside enable to display/hide the XY, YZ and XZ planes (use the check boxes). Each plane is
carrying an automatic or manually defined grid. Hold down Shift to evoke a small cube. Drag the yellow
ball of the cube to alter the zero grid position. Drag the arrow ends to move the grid just in the selected
axis direction.
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Time volume projection

Timelapse images can be projected inside the volume viewer to illustrate any time displacements. If
more dimensions are available, select Time from the first drop-down menu and choose a suitable
blending type.

6.3.3.3. Old Engine

Window Toolbar Options

View Select one of the predefined views to display the model. The Default X, Y, Z view displays the
model in the most suitable perspective. The six other views display side views and horizontal projections.

Z-zoom Adjusts the Z-step height of the image Z sequence.

Blending Choose which of the following types of projection will be used:
Alpha Blending Uses the physical principles of light absorbing, so that the object surfaces are ac-
centuated.

Maximum IntensityOnly the pixels with the highest intensity values of the Z-sequence are displayed
in the image.

Minimum Intensity Only the pixels with the lowest intensity values of the Z-sequence are displayed
in the image.

Z Depth Coding Color is associated to Z depth.

Z Depth Coding (Shaded) Color is associated to Z depth with light and shade options.

Shaded Volume Uses the physical principles of light absorbing and reflectance. The object surfaces
are more distinguishable.

Accumulated intensity projection Accumulates all pixel intensity values of the Z-sequence. The
projection is similar to X-ray imaging technique.

Z-depth code This option appears when the Z Depth Coding method is selected. It opens a menu where
you can select Z Depth Coding color scheme from a list of predefined gradient color sets. Check the
Reversed Z-Depth Values option to reverse the association between Gradient color and Z depth. The
Show Depth Code Scale option shows/hides the Z Depth Code scale in the image window.

Show Box Toggles the model outlines visibility.

Show Axis Displays the XYZ axis model orientation.

Anaglyph 3D This button enables/disables Anaglyph 3D view. Press the arrow button to display the
menu with possible color combinations for Anaglyph 3D (depends on Anaglyph glasses type).

Graticules
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Figure 6.22. Graticule Visibility - Halved bounding box (on bottom)

Graticule/ Hide Graticule Enables to show or hide the graticule. Select visible graticule planes
from the pull-down menu.

Graticules pull down menu options
Planes Select which graticule planes will be visible. You can freely combine the first three of them
(the XY , YZ or XZ plane). The Bounding box option shows graticules on all sides of the box. The
Halved bounding box shows graticules on three sides of the box. How the graticules are displayed
depends also on additional settings.

Always on Top Adjust the graticule visibility with this button. The graticules are shown always on
the background unless you switch on this option.

Graticules Properties Displays a window with the graticules settings. The top part of the window
serves for faster visible plane definition. The color of the lines as well as their top/background ap-
pearing can be adjusted in the middle part of the window. Set the graticule Density in the bottom
part of the window or use Automatically adjust density.
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Figure 6.23. Graticule Properties Window

Type Select which planes will be visible. You can combine them with other planes. Check the
Bounding box options to show the graticules on all sides of the box. The Halved bounding box
displays graticules on three sides of the box.

Appearance Adjust the graticule visibility. The graticules can be shown on the top or on the
background.

Line colors Select a color for each axis individually.

Density Specify value and units of graticule density. Check the Automatically adjust density
option to let the system set the graticule density automatically.

Show Z Scale This button displays/hides Z scale in the image window. Press the arrow button to
open a menu with additional options: the Reversed Z values option reverses Z values. The Z Scale
Properties opens the Tick marks density dialog window:

Define density value of tick marks for Z scale or let the application automatically adjust by checking the
Automatically adjust density option.
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Show volume dimensions This button displays/hides information about the calibration and volume
dimensions which are displayed at the bottom of the image window.

The first frame is highest/lowest Use these two buttons to set the first frame as the
highest/lowest one in the sequence.

Calculate Additional Slices This button enables to enhance the quality of undersampled datasets
by calculating additional slices in the Z-axis.

Create Image Cache for Time Loop Use this button if your image sequence contains the time dimen-
sion and you would like to observe it. The visualization will be pre-loaded to memory and therefore
smooth and fast-enough.

Create Movie This button runs the Movie Maker application. It enables to create AVI movies of the
3D model. See 11.3. Creating a Movie [227] for further information.

Switch to fullscreen mode rendering This option switches the volume viewer to fullscreen mode.
You can abort it by pressing Esc .

Show Help Displays the help page.

3D Renderer Settings This button enables you to fine-tune the 3D renderer performance. The fol-
lowing window appears:
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Note

This button appears only if you have a high-performance graphic card with DirectX 9.0c support,
ShaderModel 3.0. Recommended cards are Nvidia GeForce 6800 and higher or ATI Radeon X1900
and higher.
Show detailed tooltips on toolbar buttons Check this item to display detailed tooltips.

Use advanced renderer If an advanced graphic card is detected in your computer, this options
becomes available. Choose it in order to make use of the capabilities of the card. The resulting
image will be nicer and the performance faster.

Note

When using the basic render, a stripe pattern may appear in the volume render. Selecting
this option will correct this behaviour.

Quality Settings
Still image / Interactive mode Still image settings will be used for static viewing (which
usually allows the highest quality) while the Interactive mode settings will be used when
moving with the 3D model.

Details Select the desired quality settings. You can opt between the Ultra High, High,Medium,
Low values.

Resolution Select the resolution of the 3D scene. Full, 2/3, 1/2, 1/4, Limited. These options
express the ratio of the current image window size. The Limited option actually equals 1/4
but differs when the image window size is reduced so that the image would lack details in the
1/4 resolution.

Rendering Settings

Enables to set further settings for rendering modes.
Shaded volume lighting Choose one of lighting modes: Balanced, Matt or Shiny.

Accum. intensity projection Select the intensity of accumulating the pixel values: High, Medium,
Low

Working with Objects

Rotating the 3D model Use the primary mouse button to freely rotate the image.

Or, hold down the A key. An axis system scheme appears. Move the mouse cursor near the chosen axis.
Press and hold the primary mouse button and rotate the model by moving the mouse in right-left direction.
Release the primary mouse button and choose another axis, if necessary. Release the A key to finish.
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Or you can use commands placed in the right vertical image toolbar. These commands enable primarily
to select an axis easily.

Rotation Controls

Rotation via screen axes Use this button to freely rotate the model.

Rotation via dataset axes Use one of these , , buttons to rotate the model according to
the selected axis.

Moving the 3D model Use the secondary mouse button to move the model.

Zooming the 3D model Use the mouse wheel to zoom the model.

Cropping the 3D model Press the Crop Control Mode button to switch to the Cropping Mode. We
recommend to have the Show Box option ON. Move the mouse cursor to the desired plane outline.
Outline of the selected plane becomes red highlighted. Now press and hold the primary mouse button
and move the mouse. The cropping plane will move accordingly. Release the mouse button when you
are satisfied with the result. Select another cropping plane and continue cropping.

Or you can press and hold the Ctrl key during the whole cropping procedure. After you release the
Ctrl key cropping is finished.
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Note

The cropping planes form a box. If you need to move the whole box, instead of moving a single
plane, press and hold the secondary mouse button. Now simply move the box to a new location.

Or you can enable the arbitrary cropping plane mode. Switch on the arbitrary cropping plane by the
Arbitrary Cropping Plane button in the right image toolbar. Hold down Shift and click the primary mouse
button to move the cropping plane, or hold hold down Shift and use the secondary mouse button to
rotate the plane. Note that this mode will crop all channels and a binary layer together.

You can also use the 3D Crop button: current image is cropped according to current bounding box
and a new image containing the 3D crop is created.

Shortcuts in Cropping Plane Mode
Primary mouse button Moves orthogonal cropping plane.

Primary mouse button + Shift Enables to move the graticules (only if the Automatically adjust
density option in the Graticules properties window is unchecked).

Primary mouse button + A Rotates the 3D model around a selected axis.

Secondary mouse button Move parallel orthogonal cropping planes in Crop Control Mode. Rotate
orthogonal cropping plane in Arbitrary Cropping Plane Mode.

Mouse wheel Zooms the 3D model.

Scaling the graticule Run the Graticules Properties... window and set the graticule Density value or
switch Automatically adjust density off, confirm it by clicking OK and hold down the Shift key and
move the mouse wheel to scale the graticules. The information about the current graticule size is displayed
in the bottom right corner of the image window.

Moving the graticule To move the graticule freely, hold down the Shift key, grab the graticule and
drag it to new position. If you need to adjust the graticule position only in some directions, hold down
the Shift key. An axis system scheme appears. Move the mouse cursor near to one of the axes or
planes you want to fix. The selected plane (or axis) becomes highlighted. Now hold the primary mouse
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button and move the mouse cursor. The graticule will move accordingly in the selected plane or axis
direction.

Figure 6.28. The XY plane is selected so the graticules will move only in the X and Y axis direction

Shortcuts
Primary mouse button + Shift Enables to move the graticules.

Subvolume Settings You can crop the whole model or you can select one or more channels to crop.
Any combination of channels can be cropped. Select the corresponding subvolume buttons holding the
Ctrl key.

Subvolume on All Channels Applies the subvolume (crop) settings on all channels of the image.

Subvolume on a Channel Applies the subvolume (crop) settings on the selected channel.

Reset Crop Discards the subvolume cropping.

Note

This selection is ignored when cropping in Arbitrary Cropping PlaneMode (i.e. when the Arbitrary
Cropping Plane button is pushed).

Light This option is supported in binary isosurface view or in Shaded volume lighting Mode (Advanced
Renderer). Press the Toggle Light Visibility button to switch the light on. If rendering mode supports
light then a light object is shown. Pick the light with primary mouse button and move it freely around.
Light can be fixed to dataset or camera. Double click on light object to toggle fixation mode. Change
light intensity with mouse wheel when cursor is over the light object.

Time volume projection

Timelapse images can be projected inside the volume viewer to illustrate any time displacements. If
more dimensions are available, select Time from the first drop-down menu and choose a suitable
blending type.
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6.3.4. Synchronizer

Synchronizer enables to compare (run and view) two or more nd2 files at the same time. It automatically
synchronizes view of all documents added to the list. Run View > Visualization Controls > Synchronizer
:

• Open at least two nd2 files you would like to observe.

• Use the Add All Views button to add them to the synchronizer table. In case there are more images
opened which you do not want to add, use the Add Current View button on each of the images.
You can also select the Add New Views Automatically button to have all newly opened ND2 files
synchronized.

• The names of all added images appear in the Synchronizer window.

All documents added to the Synchronizer are automatically being synchronized.

• Set one of the selected images active.

• Any action regarding the view (Z position, displayed frame, etc.) is performed on the synchronized
images as well as on the active one.

• Besides synchronization of dimensions, you can also synchronize LUTs settings of the images by
checking the LUT check box. LUTs synchronization works only between LUT-compatible images (images
must have the same number of channels etc.). If the images are not LUT compatible, only the Keep
AutoScale and AutoScale actions are synchronized.

You can select the Enable LUT synchronization by default button. All newly added documents
will have the option to synchronize LUTs selected by default.

• To remove an image from synchronizer, click the reset button placed before its name. To remove
all images from synchronizer, press the Remove All Views button.
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6.4. Large Images

6.4.1. Opening Files in Progressive Mode

If a single image (or one ND2 frame) is too big and it can not be loaded to RAM in one piece - you will
be asked whether to open it in a Progressive Mode. This means that only a thumbnail of the image will
be loaded to the RAM. When zooming-in to view image details, the image data of the particular portion
of the image will be loaded to RAM progressively (piece by piece).

Many image processing functions and commands are disabled in this mode. This problem usually occurs
with Large Images created by stitching several frames together. In case you need to process such an
image, a smooth solution is to split it into tiles and create a multi-point ND2 file out of it. Please see
6.4.2. Splitting Large Images [123].

6.4.2. Splitting Large Images

You can split an existing large image to tiles easily.

1) Open the large image to be split.

2) Run the Image > Split Image command. A dialog window appears.

3) Set split options:

Split to separate files - output format Select the output format (ND2 or TIFF). A separate file
will be saved for each tile. Define Output folder and Prefix where the files will be saved.

Create multipoint ND Document Only one multi-point ND2 file will be created and opened after
the split.

Set measurement frame after splitting The measurement frame will be turned ON after the
split in order to exclude overlapping areas. This is to prevent distortion of data in case of meas-
urement.

Tile Size, Number of tiles Define width and height of a single tile in pixels or set the number of
columns and rows to which to split.

Overlap Set overlap value of neighboring tiles either in % or the current calibration units (presum-
ably µm). Overlap up to 50% of the tile size is allowed, higher values are reduced to the maximum
.

Fill background Select a color to fill empty spaces which will appear the total area of tiles ex-
ceeds the image. Use Optimize to prevent the empty spaces.

4) If you do not require the tiles to have exact size, click Optimize . The system will arrange/resize
the tiles automatically so that the whole image is covered precisely.
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5) Click OK .

6.4.3. Locating XY Positions Between Images

If two images have matching XY coordinates you can locate the exact position in one image inside the
other. This would be the case especially after using the Image > Split Image command. Right click the
location within the first (multi-point) image and select Find this Point in Paired Document from the
context menu.

If you do this right after splitting the large image (the two images are “paired”), the system displays it
and highlights the XY position by a flashing cross. If it is not clear to the system which images shall be
paired (e.g. three or more images with matching coordinates are open), the user will be prompted to
select the second image to the pair.

6.4.4. Methods Used for Stitching Large Images

Some NIS-Elements functions for creating large images by stitching multiple image frames enables the
user to select a stitching method. Select the one you serves better your purpose:

Blending Overlapping image parts will be blended.

Figure 6.30. Stitching via "Blending" (pixel intensity is changed in the overlapped region)

Optimal Path A contour where two overlapping images are least different will be computed. The images
will be stitched copying this contour.
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Figure 6.31. Stitching via "Optimal path" (pixel intensity is preserved)

6.5. LUTs - Non-destructive Image Enhancement

6.5.1. Introduction to Look-Up Tables (LUTs)

LUTs is a useful tool for image color and brightness modifications. You can use LUTs to enhance images
for observation purposes so the color modifications will be non-destructive to the image data. LUTs
settings are saved along with the image file. If required, the LUTs settings can be applied to the image
data by pressing the button. Use the Show LUTs window button in the image toolbar to display
the LUTs window.

The following actions are available within the LUTs window:

• Adjusting the Gamma parameter. The gamma curve is drawn in gray over each graph. You can drag
the middle point and move it up or down, or enter an exact value to the G: field at the top of the graph
area.

• Adjusting the input intensity range. The input intensity range can be restricted by moving the black
and white triangular sliders to the center. All pixels with values outside of the modified input range
will be set to maximum/minimum values and the remaining pixels will be approximated in order to
fill the output (full) range.

Note

This is the way how images can be equalized. For example, if the image is very dark and most
of the histogram is located to the left while the right part of it is flat, you may move the white
slider(s) to the position where the histogram line starts to rise. This will incredibly brighten the
image and reveal details which were previously hidden in a dark.
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• You can adjust the histograms height non-proportionally by moving the slider on the left side of the
window up and down.

Tips

• Right-click the graph area and (de)selectDraw trend style. When ON, the LUTs curves will be smoothed
to display the data trends rather then represent the actual image data values.

• The position of the black, white and Gamma sliders can be reset by a double click.

Different controls will be available when applying LUTs to monochromatic, RGB, multi-channel or spectral
image. When LUTs are active, the LUTs button in the top-left corner of the image window is highlighted
red.

6.5.2. LUTs on RGB Images

There are 3 separate windows for each of the RGB channels. All channels are controlled at the same
time by default. To control each channel separately, press and hold the Shift key while you drag the
sliders or adjust Gamma.

LUTs Tools

Enable/Disable LUTs This button applies LUTs to the current image.

Keep Auto Scale Press this button to run the auto scale procedure permanently (on the live image).
When you turn this button OFF, the settings remain as if the Auto Scale button was pressed only once.
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Auto Scale This button adjusts the white slider position of all channels automatically with the purpose
to enhance the image reasonably. If you have selected the Use Black Level option from the Settings
pull-down menu, the black slider will be affected too.

Reset All Components Discard all LUTs settings and turn LUTs OFF by pressing this button.

Settings Display the pull down menu and select one of the following commands:

• Brightfield Opacity - You can change opacity of a brightfield channel. Define the opacity in the
Brightfield Opacity dialog window that appears after you run this command.

• Use Black Level - Check this item to ensure that the black slider will be affected by the auto scale
functions .

• Settings - opens the Auto Scale Settings window. See Auto Scale Settings [128].

Keep Auto White Balance Check Box Check this option to switch the Auto White Balance functionality
permanently (on the live image).

AWB Press this button to perform the Auto White Balance operation once.

Auto White Balance Color (...) This button Opens the AWB Color window and enables you to select a
color shade which the system shall eliminate (make white). See AWB [128].

Reset AWB Discard all AWB settings with this button.

Color Oversaturation Switch this button ON and the system highlights all pixels with values reaching
maximal values. Select colors to highlight the pixels with in the pull-down menu. See also 6.2.3. Channel
Coloring [97].

These buttons arrange histograms of single channels next to each other horizontally or vertically.

This button arranges histograms of single channels overlapped. Use sliders at the bottom of the
graph window to amplify or reduce the green/red/blue component display in the view.

Save/Load LUTs This pull-down menu enables user to handle LUTs settings in various ways. They
can be saved to a *.lut file and loaded later. Or, LUTs settings saved along with an image can be loaded
directly from this image by the Reuse LUTs from File command. Or you can copy/paste the settings
within the documents opened in NIS-Elements AR.

Modify Image Through LUTs Press this button to apply the LUTs settings to the image data - the
original image will be overwritten. Until you press this button, no changes are made to the image data.

Reset Zoom Zooms the histogram to fit the preview window.

Auto Range zooms the histogram so that the “high” and “low” limits are distinguishable. For example,
if a small intensity range is defined on a 16bit image the low and high lines are displayed as one-pixel
line. Pressing this button will stretch the histogram in order to display the lines separately.
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Auto Scale Settings

Press the arrow next to the Reset LUTs button and a pull-down menu appears. Invoke the Settings
command.

The Low and High fields determine how many of all pixels of the picture are left outside the sliders when
Auto Scale is applied (0-10%).

AWB

White color in some images may suffer from having a color tint. The AWB (Auto White Balance) mode
adjusts the image to get pure white instead of this tint. Similarly to LUTs auto scale, the AWB function
can be used once, or permanently on the live image. If you know the tint your “white” color has, you can
select this color by the color picker that appears after pressing the ... button:

Choose the color by mouse. You can also enter the RGB values to the fields below. A preview of the
chosen color appears in the rightmost rectangle.
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6.5.3. LUTs on Monochromatic Images

All features mentioned above are also valid for monochromatic images, except that the AWB function
is not available. There are some other features added when in “mono” mode.

Gradient Mapping monochromatic images to pseudo-color gradients is often used to enhance details
in the image which would otherwise not be obvious. This button indicates the currently selected gradient.
When pressed, a pull-down menu appears where you can select the color scheme you would like to use.
Try a few of the schemes to see which one suits best.

129

Displaying Images



Manage Custom LUTs (requires: Local Option)

The Manage Custom LUTs command in the pull down menu enables to define a custom LUTs gradient.
Use the tools available in the dialog window to define your custom gradients. They then appear in the
pull down menu ready to be applied. Please see View > Image > LUTs > Create Custom LUTs for details
about the custom LUTs definition.

6.5.4. LUTs on Multichannel Images

Figure 6.37. LUTs window on two-channel image

Most of features mentioned above are also valid for multi-channel images. There are some other features
added when in “multi-channel” mode. Each channel is controlled separately by default. To control all
channels at the same time, press and hold the Shift key while you drag the sliders or adjust Gamma.

When the image contains up to three channels, all channels can be visible at one time and you can
handle them similarly to the RGB mode. When there are more than three channels, only one channel
is displayed at one time. A pull-down menu in the toolbar enables you to select the channel to be dis-
played.

Next to the channel selection pull-down menu, there is this Auto Scale button. By pressing it, the
system will automatically adjust only the current channel settings.
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6.5.5. LUTs on Spectral Images

When observing a spectral image, the graph inside the LUTs window does not show the image histo-
gram(s), but reveals another information about the image. Intensity values are on the Y axis and spectra
is on the X. There are two curves in the graph. The top (white) curve displays the maximal intensity and
the color curve displays the mean intensity of each channel.

Note

Spectral image consists of many channels, each representing a single wavelength.

The LUTs behavior depends on the selected displaying mode. There are four displaying modes. You can
select the mode either by a pull-down menu in the LUTs toolbar, or within the image top toolbar.

• True Color

• Custom Color

• Grouped

• Gray Scale

In the bottom part of the LUTs window, Gain and Black Level settings can be adjusted either for all
channels together or for each group separately - depending on the displaying mode. Gain brightens the
image and the Black Level works just like the left (black) on RGB/mono images.

Note

Each slider (gain or black level) offers a range of values to be set by moving it, but any higher value
can be entered in the field next of the sliders.

TD channel

A spectral image can contain additional TD (transmitted detector) channel. Its basically a standard
monochromatic image. LUTs settings of this channel appear on the right edge of the LUTs window.

True Color Displaying Mode

You can switch to this displaying mode by clicking the button located in the image toolbar.
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Custom Color Displaying Mode

You can switch to this displaying mode by clicking the button located in the image toolbar. You can
assign custom colors to sections of the spectrum. Sections (colors) can be added/removed by clicking
the + and - buttons placed below the spectral graph. To change the section color, click the button located
in the color stripe. A window appears where you can select the color from a palette or define it by Hue
or Wavelength settings.

132



Grouped Displaying Mode

You can switch to this displaying mode by clicking the button located in the image toolbar. This view
enables you to reduce the number of channels multiple-times. You can adjust the number of groups by
the + and - buttons and also change each channel width by moving the white horizontal dividers. Gain
and Black Level for each group can be adjusted.

Gray Scale Displaying Mode

You can switch to this displaying mode by clicking the button located in the image toolbar. The image
is displayed in gray scale, but various color gradients can be applied to it.
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6.6. Organizer

6.6.1. About Organizer

Apart from the main application layout used for capturing and image analysis,NIS-Elements AR provides
an extra layout called Organizer. Organizer makes the work with image files and databases as easy as
possible. To activate it, run the View > Organizer Layout command or click the button located
in the top right corner of the application window. The screen opens divided into two identical panes. To
switch from one pane to the other, use the View > Next Pane (F6) command. To copy files between the
panes, simply drag the images from one side to the other side.

Figure 6.42. The organizer layout.

• This button toggles the display of the directory tree. You can switch it off to get additional space
to display images.

• In the nearby pull-down menu, it is possible to set the file type and only the one will be displayed. Or,
All Images can be displayed.

• If the Subfolders check-box is selected, all images from included sub-folders are displayed.

6.6.2. Image Filter

You can define a filter which enables you to display only images which fit the defined conditions. One
or two conditions may be applied.
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• Pressing this button invokes the filter setup window.

• This button activates the filter.

Basic Mode

This mode enables you to filter files according to one condition.

Advanced Mode

This mode enables you to define two conditions with a relationship between them. Either select OR to
display files matching at least one condition, or select AND to display files which match both conditions.

1. Search in field - select the field where NIS-Elements AR should search for a given expression.

2. If the selected field is of a numerical type (e.g. Size, Calibration, File date etc.) you can specify,
whether you want to find the exact value or a value in a given range. This is selected by the Condition
type radio button.

3. If the field type is Text , the Occurrence setting determines the way of evaluating the expression:

• Anywhere - If the given sequence of characters is found anywhere in the field, the system will
evaluate it as a match. For example: you have entered “set” to the Values field. The filter will select
records with the following field values: “set”, “reset”, “settings”, “preset”, etc.

• Exact - If the given sequence of characters exactly equals to the content of the field, it is evaluated
as a match. Fields containing the “set” value only will match.

• Start - If the entered string is found at the beginning of a field, it passes the condition. For example:
fields containing “set”, “settings”, “setup” will match.
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• All letter strings - It is possible to search for more expressions. These should be entered separated
by commas. If you want to enter an expression with a space, insert it quoted. If this option is selec-
ted, only records where all of those expressions appear (anywhere) will match.

• Any letter string - This option is for entering multiple expressions as above, but this time every field
with an occurrence of at least one from the given expressions is matched.

6.6.3. Operations with Images within Organizer

• To open an image double click its thumbnail. NIS-Elements AR will close Organizer and display it in
the main window.

• To select multiple images, either click on the first and the last image holding the Shift key (con-
tinuous group selection) or click individual images with the Ctrl key down.

• You can copy one or more images from one folder to another by “drag and drop”.

• To delete selected images press the Delete key.

All these operations and some other can be invoked also from the context menu, which appears after
you right-click on the image thumbnail:

Thumbnail Displaying Options

You can adjust the way images are shown in the organizer.

Thumbnail View Press this button and select the size of displayed image thumbnails. Selecting the
Details with preview option will display images below each other with all available information aside.

Rotating Images There is a possibility to rotate images from within the organizer. It affects not
only the image thumbnails, but the image data too. Press the corresponding buttons.

Autocontrast Press this button to turn the Apply autocontrast to thumbnails option ON. It enhances
the image thumbnails automatically. Dark images gain details.

136



Sorting of Images

To order displayed images, right click anywhere in the pane - a context menu will appear. Move to the
Sort by sub-menu which offers several ordering criteria. If the ordering is turned ON already, the icon is
displayed on the left side of the applied criterion.

Grouping of Images

To arrange the view of images efficiently, you can use the capability of grouping of images. Drag the
column caption to the grouping bar right above the table. All files with matching field values of the se-
lected column will be grouped together. This can be undone by dragging the column caption back to
the others. See Figure 6.42, “The organizer layout.” [134] (the Calibration column is grouped).

Note

If you have the Databasemodule installed, the Organizer becomes switchable between twomodes:
the Files View and the Database View.

6.6.4. Resizing the Organizer Panes

The pane size is adjustable. To resize it, you can either:

• Place the mouse cursor over the dividing line in the middle.1.

2. The cursor becomes an arrow with two tips.

3. Drag it left or right to the new position.

• Resizes the panes to achieve the same size for both of them.

• Resizes the pane to its maximal/minimal size (one pane is then displayed on the whole screen).
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7. Image Analysis

7.1. Preparation

7.1.1. Histogram

A histogram is a graphical representation of pixel intensity distribution in the image. It is a basic tool
which is used during all phases of an experiment to assess the image information. It is especially useful
to make sure there are not too many over- or under-saturated (overrun) pixels. Run the View > Visual-
ization Controls > Histogram command to display the histogram control panel:

7.1.1.1. Source Data

Source data of the histogram can be viewed if you swap to the Data tab in the bottom-left corner of the
window. The area from where the histogram is calculated can be restricted according to the selected
histogram mode:

The data are obtained from the whole image.

The data are obtained from within the probe.
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The data are obtained from within the current ROI.

The data are obtained from the image parts under the binary layer.

7.1.1.2. Export

The source data or the histogram image can be exported to an external file. Display the Export pull-
down menu and select a suitable destination. Click the button to perform the export. The Export ND
histogram button enables to export histogram data of all frames of the current nd2 file. The same
destination which is selected in the Export pull-down menu is applied.

Note

Please, see the 8.1.7. Exporting Results [176] chapter for further details.

7.1.1.3. Histogram Scaling

The histogram can be zoomed in and out using the zoom buttons on sides of the window. There are
also other options to adjust the graph appearance:

Left slider There is a slider along the Frequency axis. Drag it in order to stretch the view of either lower
or upper values of the axis.

Auto Scale Vertical Zooms the graph of each channel separately to fit the available area. When this
function is ON, the histogram is not proportional.

Auto Scale Horizontal Zooms the graph so that the marginal zero frequencies, if there are some,
are excluded from display.

Graph Linear Displays the linear scale on the Y axis.

Graph Logarithmic Displays logarithmic scale on the Y axis.

Show Grid Turns ON/OFF the grid in the background.

7.1.1.4. Overrun Indication

If certain amount of pixels with maximum/minimum intensity values (black/white pixels) are spotted in
the image, color dots appear above the graph. The color indicates which channel is affected. When you
place the mouse cursor over the dots, a tool tip message appears with details about the percentage of
under/overexposed pixels. The percentage limit setting is loaded from the LUTs settings (the color dots
do not appear unless the set percentage of black/white pixels is exceeded). If the overrun concerns
more than three channels (considering multi-channel images), only one white dot is displayed instead
of many color dots.
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Note

Intensity ranges of all components present in the image are displayed in the Histogram status bar
at the bottom of the window.

7.1.1.5. Graph Memorizing

You can save the current graph to memory and display it later for comparison with another graph.

Displays memorized graph.

Memorizes the current graph. Only one graph can be memorized at a time. If any graph has already
been memorized before, it will be overwritten by the current graph.

Clears the memory.

7.1.1.6. Histogram Options

Drawing Style

There are two ways the histogram can be drawn:

• Raw Data - tries to draw the source data precisely to the graph

• Trend Style - interpolates the data so that the histogram lines appear smoother.

Histogram Options Window

The graph appearance can be modified. Press the Options button - a window appears where the
following settings can be adjusted:

Colors Graph background and axes colors can be selected.

Pen Width Set the width of the histogram(s) line to 1, 2, or 3 pixels.

Fill Graph Area The area below the histogram line can be filled with the channel color.

Graph Area Opacity Select the opacity of the Graph Area color in %.

Vertical/Horizontal AutoScale, Show Grid These options equals the corresponding buttons of the his-
togram toolbar.

Interpolation method Select the way of drawing the graph line. The Linear (smooth) and Quick (precise)
options are available.

Show grid Shows the grid of the graph.

AntiAlias Smooths the edges of the graph line.

Horizontal axis always visible If checked, the axis does not leave the graph area while zooming in the
graph.
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7.1.2. Image processing

7.1.2.1. Processing On: Intensity/RGB/Channels

If you work with RGB images, you can decide whether to perform the processing on single RGB channels
of the image, or on the intensity component. The RGB/Intensity setting is global so it is applied to all
the other processing commands automatically. When processing a multichannel image, this option is
disabled - the operation is applied to channels automatically.

Note

In case the command does not open a window where it would be possible to make the choice, the
setting from the last performed processing command (the global setting) is applied.

7.1.2.2. ND2 Files Processing

Most of the image processing and binary image processing commands can be applied to one frame, all
frames, or selected dimension of the nd2 file. When you use such command with an ND2 file, the fol-
lowing options are added to the command dialog window:

Current Frame The operation will be performed on the current frame of the nd2 file.

All Frames The operation will be performed on all frames of the current nd2 file.

Selection The operation will be performed on all frames of the selected dimension. If you selected some
of the frames/loops of the nd2 file by mouse, the Selection option appears in the pull-down menu. Opt
for it to process only these selected (green highlighted) frames/loops.

When you process an image containing T and Z dimensions, selecting the Z-Series dimension performs
the operation on all Z frames of the current T loop.

7.1.2.3. RGB/Mono/Multichannel Image Processing

Options of some of the image processing commands may vary slightly depending upon the type of image
being processed. See 6.2.2. Image Types [96] for the more detailed explanation of the image types.
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RGB

• When the image processing function works with the image components, you can select whether the
Red, Green, or Blue component is used.

Mono

• You cannot select which component is used, because the image contains only one component, which
is then selected automatically.

Multichannel images

• When the image processing function works with the image components, you can select which com-
ponent is used from the pull down menu or other selection tool.

7.2. Image Segmentation

7.2.1. Thresholding

7.2.1.1. Basic Way to Threshold an Image

Specifying correct threshold limits is a crucial procedure of the automated image analysis. The point is
to determine which pixels will and which will not be included in the binary layer and thereby distinguish
objects to be analyzed from background. Thresholding can be performed in the following modes:

1) Open or capture the image to be thresholded.

2) Run the View > Analysis Controls > Thresholding command to display the Thresholding panel:
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Figure 7.3. Thresholding panel

3) In the top tool bar, select the color mode which will be used for thresholding. According to the
type of image opened, the following modes could be available: RGB, HSI, Intensity and MCH.
See 7.2.1.2. Color Modes [144].

4) Select one of the pixel-picking tools (e.g. ) and start clicking on objects in the image you want
to detect. Color values of each of the clicked pixel(s) are used to adjust the low and the high
threshold values so that the clicked pixel would stay inside the thresholded interval.

Apart from this “clicking” method, the thresholds can be adjusted directly within the histogram
by dragging the vertical lines which highlight the thresholded interval.

5) All pixels having their numeric values inside the thresholded interval become a part of the resulting
binary layer.

6) Very often, also other binary objects appear in the image which you did not intend to detect, for
example dust particles with intensity similar to the specimen, etc. To eliminate these mis-detected
object, use one or more tools available at the bottom of the panel. You can either apply some
morphology functions to the binary layer or apply size or circularity restrictions to detected objects.
See 7.2.1.3. Tips and Tricks [145].
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7.2.1.2. Color Modes

RGBMode The RGB thresholding mode is available only if an RGB image is opened. There are two ways
how to define the threshold limits, by choosing reference points within the image, or by defining the
limit values for each color channel.

HSI Mode The HSI thresholding mode is available only if an RGB image is opened. The thresholding
procedure works the same way as in the RGB mode except that the pixel values are displayed in the
HSI (Hue, Saturation, Intensity) color space and that the Saturation and Intensity channels can be
switched OFF. Therefore you can threshold over the H, HS, or HI channels only. Switch the channel off
by de-selecting the check box in the top-left corner of the channel histogram.

Intensity Mode The thresholding procedure works the same way as in the RGB mode except that it is
performed on the intensity pixel values.

MCHMode TheMCHmode is not available when working with a monochromatic (single channel) image.
This mode is dedicated to perform threshold on multichannel images, but can be applied to RGB images
as well.

• If there are many channels, only one channel histogram is displayed. Switch between the channels
by selecting their names from the bottom pull-down menu.

• The binary layer(s) can be displayed in two modes:

1. Each channel can create its own binary layer

2. One layer can be created as an intersection of all channels binaries.

7.2.1.3. Tips and Tricks

Threshold Adjustments

Thresholding parameters can be adjusted very precisely in the following way:

• Threshold limits of each channel can be adjusted by rewriting the values in the top-left/top-right corner
of each channel histogram.

• Threshold range of each channel (the colored stripe) can be shifted by mouse. Place the cursor in
the middle of the range (a circle appears) and drag it left or right.

• Threshold limits of each channel can be adjusted by mouse. Place the cursor on the edge of the
thresholding range and drag it left or right.

The two last behaviors can be further modified by pressing additional keys:

• Move the threshold using the right mouse button - the binary layer in the image is not updated con-
tinuously, but is updated only once after the mouse button is released. Such operation saves some
computing and therefore is quicker.
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• Hold Shift while moving the threshold limits - the threshold adjustment is performed on all channels
together (RGB images only).

• Hold Ctrl while moving the threshold limits - both the low and the high threshold limits move in
opposite directions.

Binary Operations

Four basic operations can be performed on the binary layer before it is displayed on screen. To turn the
operation on, click on the up arrow button in order to define the number of its iterations:

Clean Removes small objects from binary image.

Smooth Smooths the binary image contours.

Fill Holes Fills holes within binary objects.

Separate Separates objects.

Restrictions

Size Define size range using min/max value in the edit boxes or using the slider.

Circularity Define circularity range using min/max value in the edit boxes or using the slider.

Thresholding Large Images

If thresholding images larger than 5000 x 5000 pixels, a new check box called Preview on selected area
only is displayed. This feature enables to display the threshold preview just on a limited area to speed
up the thresholding adjustment.

Changing Appearance of the Binary Layer

To change the color or transparency of the layer, right-click the Overlay button in the right image tool
bar. A contextual menu appears, where you can select one of the predefined transparency levels, or run
the Colorize Binary Objects command. This command displays the binary objects in several different
colors. The algorithm ensures that two neighboring objects are never colored by similar colors.

See 7.3.4. Mathematical Morphology Basics [153].

7.2.2. Spot Detection

This function opens the Spot Detection dialog window. It is used mainly for detecting circular objects
with similar sizes. Bright spot and dark spot detection methods are split into individual dialog windows.
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Figure 7.4. A typical, suitable sample for Spot Detection.

Channel Select a channel on which you want to detect objects. If multichannel file is opened, spectral
group selection is available.

Method For Bright Spots detection choose Bright, Clustered detection method if you want to
detect clustered bright objects on a dark background or Bright, Different Sizes for detecting
differently sized bright objects on a dark background.

For Dark Spots detection choose Dark, Clustered detection method if your clustered objects
are dark and their background is light or Dark, Different Sizes method if your objects have dif-
ferent sizes and your background is light.

Output Binary output defines in which form the detected objects will be saved. Circular Area saves one
circle for each detected spot whereas Spot saves a center point with a defined pixel size. Growing check
box can be used to save grown regions with borders between adjacent spots. The function itself finds
local threshold values for each of the spots detected. Therefore it matches the exact shape of the object.
The numeric value represents image intensity degrees. Pick intensity function can be used to get a
reference pixel intensity from the picture by a single mouse click. Use the slider to adjust the Growing
value.

Typical Diameter Adjust the typical size of your objects using the slider or edit box.

Contrast Adjust the contrast value of your spots using the slider or edit box.

Object symmetry: detect ... objects. Can be used to add yet undetected/remove already detected spots
based on their symmetry.

Remove Dark Objects Check this option and adjust the position of the slider to exclude dark objects.
The more left you move the slider, the more objects appear.

Apply to Selects where on your actual image the detection settings should be applied. Depending on
your actual ND2 file, you can choose from the following options: Current Frame, All Frames, Selection,
Time (Timelapse), XY (multipoints) or Z (Z-stack).

OK Uses the actual settings for performing Spot Detection.
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Close Closes the Spot Detection window.

Reset Resets all settings to default.

Help Opens this help file.

Preview Shows the changes directly on the actual frame of your opened image. Previewing progress is
shown below this check box.

How to detect Circular Areas

1) Start by opening your image for the Circular Area detection. Select the proper detection method.
For bright spots on a dark background choose Bright Spots. For dark spots on a bright background
choose Dark Spots.

2) If you can't see any detected objects in your image yet, and your Preview button is checked, you
should press the Reset button.

3) Now choose the Bright / Dark vs. Clustered / Different Sizes detection Method based on your
image. Continue by adjusting the Typical Diameter values to fit our objects tightly inside the
circles. Now adjust the Contrast slider to remove unwanted spots. Optionally adjust the Remove
Dark Objects slider to remove undesirable dark spots.

4) If you are satisfied with the object detection, choose where to apply the current settings (Current
Frame, All Frames or a Selection) and click OK. Now you can save the new binary layer together
with your file.

Note

Circular areas detected close to each other are automatically separated.

Figure 7.5. Circular Area output
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Note

To see the binary layers as shown in the image above, right-click the View Overlay icon
on the Image window toolbar and select Transparency 100% or use Ctrl +up/down arrow
keys.

How to detect Spots

1) Do steps 1-3 from the How to detect Circular Areas [148] procedure.

2) Switch the radio button from Circular Area to Spot and adjust the pixel size of the spots.

3) Choose where to apply the current settings (Current Frame, All Frames or a Selection) and click
OK.

How to detect Growing

1) Do steps 1-3 from the How to detect Circular Areas [148] procedure.

2) Check the Growing check box.

3) Adjust the slider position to augment/diminish the regions. Optionally use the Pick intensity
feature to grab the pixel intensity threshold directly from your image.

4) Choose where to apply the current settings (Current Frame, All Frames or a Selection) and click
OK.

7.3. Binary Layers

7.3.1. Introduction to Binary Layers

7.3.1.1. How Do I Get a Binary Layer?

Commands for creating and editing binary layers are placed in the Binary menu. Basic methods of binary
layer creation are:

Thresholding This is the most common way of creating a binary layer for image analysis purposes. Use
the View > Analysis Controls > Thresholding command to specify threshold limits, a binary layer will
be created automatically. See 7.2.1. Thresholding [143].

Drawing Manually in Binary Editor A binary layer can be edited or even created manually using the
built-in binary layer editor. To enter it, click Binary > Binary Editor . See 7.3.3. Binary Editor [152].
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Spot Detection Spot detection is a dedicated segmentation method designed to detect circular objects
and can be started by the Binary > Spot Detection > Bright Spots command. See 7.2.2. Spot Detec-
tion [146].

7.3.1.2. How Do I Display the Binary Layer?

There are the following buttons at the bottom of the right image toolbar.

View Binary This button displays the binary layer only of the image.

View Overlay Binary layers can be displayed together with the color layer using an overlay mode.

View Color This button switches to view the color image (only).

To manage display of multiple binary layers, use the View > Analysis Controls > Binary Layers control
panel. See 7.3.2. Managing Binary Layers [150].

7.3.2. Managing Binary Layers

7.3.2.1. Binary Layers Control Panel

Run the View > Analysis Controls > Binary Layers command to display the following panel.

Each time you create a new binary layer, it is automatically placed into the Working Layers area of the
Layer List. Working Layers may be overwritten by the application each time a new binary process is
performed. Therefore once you are satisfied with the layer content it is highly recommended to move it
into the Stored Layers section using the Store Selected Working Layers.
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7.3.2.2. Operations with Binary Layers

Change color Color of a binary layer can be changed using the color pull down menu. It offers a list of
predefined colors. Besides the list of predefined colors it is possible to create a custom color (More...)
or to colorize objects in a single layer using multiple colors (By Object/By 3D Object).

Change order Use the arrow buttons ( ) to change the order of the layers in the list.

Combine Layers using Binary Operations If you drag-drop a binary layer name over another binary
layer name, the Binary operationswindow appears. The same window can be displayed by the Binary
Operations Dialog button.

Note

If multiple layers are selected in the layer list and drag-dropped over another layer, the Binary Op-
eration dialog calculates with multiple (more than two) layers. Available functions are dependent
on the number of selected layers.

See Binary > Binary Operations Binary > Binary Operations .

Create 3D Binary Objects To create 3D objects in the selected binary layer, click Connect objects
to 3D. If the binary layers are not defined for all frames of the ND document having more than one frame
(e.g. only the current frame contains binary information), you can use Fill missing binary frames to
copy the binary from the current frame to all frames where the binary layer is missing.

Duplicate To duplicate one or more binary layers, select them by mouse and drag-drop them to the
empty area below the layer list, or click the button.

Note

If you drag and drop a binary layer to some already existing reference layer, content of the dragged
layer is copied to it.

Make Selection Binary layers can be selected by mouse (pick more layers holding Ctrl or select a
range holding Shift ) or you can select all layers by clicking Select All Layers.

Remove Select the binary layers to be removed and click the button.

Rename Double click a layer name to rename it. Only name of the Reference Layers can not be edited.

7.3.2.3. Attaching Binary Layers to Channels

1) If a binary layer is created by thresholding in the Per channel mode, such binary layer is auto-
matically attached to the channel on which it has been created. Other binary layers can be at-
tached to a channel manually:

1. Right-click a binary layer in the Binary Layers panel.
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2. Select the Attach to Component sub-menu and select to which channel/component, the layer
should be attached.

2) Visibility of binary layers attached to channels can be synchronized with channels. Turn ON the
Synchronize binaries with channels button. Now if a single channel is selected for display,

only binary layers attached to it are displayed and vice versa.

3) To make an attached binary layer global again, right click the binary layer name or thumbnail
and select Detach from Component.

7.3.3. Binary Editor

The binary layer, as a result of thresholding, can be modified by hand using the binary layer editor. It is
a built-in application providing various drawing tools and morphology commands. Go for the Binary >
Binary Editor command or press Tab. New buttons appear on the toolbars:

7.3.3.1. Drawing tools

The binary image can be modified using various drawing tools. Although the way of use of some tools
differs, there are some general principles:

• Make sure you are in the right drawing mode (drawing background /foreground )

• Drawing of any object which has not been completed yet can be canceled by pressing Esc .

• The polygon-like shapes are drawn by clicks of the primary mouse button. The right button finishes
the shape.

• The automatic drawing tools (threshold, auto detect) have a changeable parameter. It can be modified
by + and - keys or by mouse wheel.

• The scene can be magnified by the UP/DOWN arrows when mouse wheel serves another purposes.

• You can drag a magnified image by secondary mouse button.

• A line width can be set in the top toolbar.

• Hints are displayed in the second top toolbar.

Binary Layer Color and Transparency

When in overlay mode:

• The Insert key switches between predefined overlay colors.

• Ctrl + Up/Down increases/decreases the binary layer transparency.
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Erasing Single objects

Single binary objects can be erased in the following way:

• Run View > Analysis Controls > Binary Toolbar .

• Select the Delete Object tool from the toolbar.

• Click inside the objects to be erased.

Multiple Binary Layers

An arbitrary number of binary layers can be created within one image. Click this Create New Binary
Layer button in the image toolbar to add a new binary layer. The binary layer that you are currently
editing can be selected in the nearby pull-down menu. Binary layers can be managed from the View >
Analysis Controls > Binary Layers control panel.

7.3.4. Mathematical Morphology Basics

The binary image as a result of thresholding often needs to be modified before a measurement is per-
formed. Edges of the objects can be smoothed, holes in the objects filled etc. by using the mathematical
morphology commands.

Note

“Image Analysis and Mathematical Morphology” by J. Serra (Academic Press, London, 1982) was
used as a reference publication for the following overview.

The basic processes of mathematical morphology are: erosion, dilation, open, close and homotopic
transformations.

Erosion After performing erosion, the objects shrink. Marginal pixels of the objects are subtracted.
If an object or a narrow shape is thinner than the border to be subtracted, they disappear from the image.

Dilation After performing dilation, the objects enlarge. Pixels are added around the objects. If the
distance between two objects is shorter than twice the thickness of the border to be added, these objects
will be merged. If a hole is smaller than twice the thickness of the border, it disappears from the image.

Open Open is erosion followed by dilation so the size of the objects is not significantly affected.
Contours are smoothed, small objects are suppressed and gently connected, particles are disconnected.

Close Closing is a dilation followed by erosion so the size of objects is not significantly affected.
Contours are smoothed, small holes and small depressions are suppressed. Very close objects may be
connected together.

Clean This transformation is also called geodesic opening. The image is eroded first so small objects
disappear. Then, the remaining eroded objects are reconstructed to their original size and shape. The
advantage of this algorithm is that small objects disappear but the rest of the image is not affected.
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Fill Holes Fills the holes inside objects. This transformation is handy when objects have a rich inner
structure with intensities typical for background. After applying the Fill Holes transformation, objects
become homogeneous.

Contour This transformation converts objects into their contours.

Smooth Smooth affects rough edges of the objects makes them smooth.

Morpho Separate Objects This transformation detects standalone objects that are connected to-
gether and isolates them.

7.3.4.1. Homotopic Transformations

Homotopic transformations preserve topological relations between objects and holes inside them. Using
a homotopic transformation, an object with 5 holes will be transformed to another object with 5 holes.
Two objects without any holes, even if they are very near each other, will become again two objects
without holes, but likely with a different shape and size. Opening, Closing, Erosion and Dilation are not
homotopic transformations. Typical homotopic transformations inNIS-Elements are: Skeletonize,Homo-
topic Marking and Thickening.

7.3.4.2. Connectivity

Applying the above mentioned transformations has some limitations due to digital images rasterization.

When speaking about binary image processing, a binary image is a set of pixels where values 1 represent
objects and values 0 represent background. In the square grid of the image, two possible connectivities
can be used for processing - the 8-connectivity or the 4-connectivity. Look at the picture below. If the 8-
connectivity is used, the two pixels represent one object. If the 4-connectivity is applied, there are two
objects in the picture. NIS-Elements AR works with the 8-connectivity model, so all pixels neighboring
by the corner belong to one object.

7.3.4.3. Structuring Element = Kernel = Matrix

When applying Erosion, Dilation, Opening or Closing, one of the parameters which determines the
transformation result is the selection of kernel (structuring element, matrix) type. There are the following
kernels used in NIS-Elements AR:
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The bright pixel in the center or near the center of the kernel represents its “midpoint”.

Example 7.2. Erosion

Let's assume 1 and 0 represent object(1) and background(0) pixels of the binary layer. You can imagine
the erosion as the following algorithm:

Move the midpoint of the kernel to every point of the image. Each time, look at the neighboring pixels
of the kernel and make the following decision:

• If there are object(1) pixels in all the positions of the kernel, set the midpoint to object(1).

• If there is at least one background(0) pixel in the kernel, set the midpoint to background(0).

Example 7.3. Dilation

You can imagine the dilation as the following algorithm:

Move the midpoint of the kernel to every point of the image. Each time, look at the neighboring pixels
of the kernel and make the following decision:

• If there is at least one object(1) pixel in any position of the kernel, set the midpoint to object(1).

• If there are background(0) pixels in all the positions of the kernel, set the midpoint to background(0).

Example 7.4. Open and Close

Open is performed by eroding the image and then applying a dilation to the eroded image. On the contrary,
Closing is performed as a dilation followed by erosion.

Repetition issues

If the midpoint is not in the center, applying erosions or dilations by odd number of iterations causes
image to shift by 1 pixel. Normally, the total image shift would be determined by the number of Iterations
(in pixels). NIS-Elements AR eliminates this shift: it changes the position of the midpoint 1 pixel down-
rightwards within the kernel for even operations. For opening and closing it is possible to eliminate this
shift totally. However, if you run the erode or dilate processes again and again using the kernel with
even dimensions and odd number of iterations, then the shift becomes significant.

7.3.4.4. Mathematical Morphology Examples

Please see the following examples of some of the binary functions applied to an image. In the following
sequence of images, the functions were applied subsequently:
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Example 7.5. Functions applied subsequently

Example 7.6. Single function applied to the original

The following examples were created by calling each of the functions separately:
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Example 7.7. Other functions applied subsequently

7.4. Regions of Interest - ROIs

7.4.1. Introduction

In laboratory imaging experiments, users are often interested in just a part of the image. To define such
an interesting part of the image we use one or more Regions of Interest (ROIs). These regions are used
later in analysis and measurements.

Note

Do not confuse image ROIs with Camera ROI which is used to reduce the active area to just a part
of the camera sensor (CCD or CMOS). Such reduction usually results in higher frame rate. See 5.3.
Camera ROI [65].

7.4.1.1. Creating and editing ROIs

ROIs can be created and edited using commands gathered in the ROI menu. ROIs can be also created
from binary objects, graticules (for equally spaced shapes) and from binary layers created by tracking.
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Figure 7.12. Available ROI tools

1. Global ROI

2. Turn ROI On

3. Background ROI

4. Turn Background ROI On

5. Moving ROI

7.4.1.2. Types of ROI

Individual ROIs (ROI objects) are 2D objects. They can have different shape: rectangular, elliptical poly-
gonal or bezier. One shape can be created with one or more tools. For instance polygon ROI can be
defined using both “Draw Polygonal ROI” and “Autodetect ROI”.

In case of an ND file which has time axis (e.g. time-lapse) individual ROI objects can be defined as
“Global ” or as “Changing over time”. Global objects do not change any of their characteristics over time.
Objects that are defined as changing over time can change their position and shape in time (however
objects cannot change their shape - e.g. from ellipse to polygon). This feature is useful for track moving
or warping objects.
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To track moving objects use the “Edit ROIs in Time” editor or just change any global ROI into changing
over time from the objects' context menu and move it or change its' shape (see interactive edit) on two
or more frames. Such frames are called “key-frames” (2 shows trajectories with little boxes representing
the key-frames). All frames in between key-frames are interpolated from these two key-frames. Frames
before and after first and last frame respectively are taken from that first or last frame. Therefore it is
not necessary to reposition or redraw the ROI on every frame.

In case of Multi Point nd2 file there is one more option: ROI can be defined per Multi Point (which is the
default). It means that ROIs from one point are completely independent of ROIs defined on the other
point (even if they have the same number). This applies also to ROIs defined as “Changing over Time”
(in case the image has time axis too). On the other hand if the ROI is changed to a “Global” it will be
shared among all points of the Multi Point set.

Depending on the application purposes ROI objects can have different usage. NIS can handle “Background
ROIs”, “Reference ROIs”, “Stimulation ROIs” and “Standard ROIs”.

7.4.1.3. Interaction with ROIs

ROIs can be manipulated anytime directly in the image window. Many of the following techniques work
in ROI editors too. Objects cannot be moved or resized when they are Locked (some analysis tools or
users may lock them to prevent accidental modification). They must be unlocked (from the ROIs' context
menu) before any manipulation. Note that the mouse cursor changes over the ROI to indicate which
action will be started after mouse button is pressed (it changes when modification keys like Alt and Ctrl
are pressed).

Selection ROI objects can be selected by clicking on an unselected object (other previously selected
are unselected). Clicking on a ROI object with Ctrl key pressed results in altering the selection state.
More than one object can be selected in this way. Double-clicking on any object results in only that object
being selected. All objects can be selected by pressing Ctrl+A or by choosing “Select All ROIs” from the
menu over any ROI. Alternatively, it is also possible to select a set of objects by dragging a rectangle
around them with Ctrl key being pressed.

Moving Objects are moved by simply dragging them (cursor indicates that). When more objects are se-
lected, only the one below the cursor position is moved by default. This can be changed by pressing the
Alt key and move all selected objects. When object is changing over time, any moving results in a new
key-frame. Individual dots representing the key-frames can be moved too. It is possible to duplicate
existing objects by Shift dragging. It works on selected objects. In case of a key-framed object, object is
duplicated with all its' key-frames unless Alt is pressed.

Resizing Resizing a ROI is done by dragging its' contour (the cursor changes accordingly). Note that the
hot-zone (the area where mouse cursor changes into different tool) for resizing is outside of the object
contour while the hot-zone for moving is inside. Resizing always affects only one object (selection is not
taken into account). The behavior slightly varies depending on the object shape. By default resize does
not hold aspect of the object - width and height can be changed independently. By holding Shift key
aspect is maintained (useful for circles) and the center is not moved. Rectangle can be also rotated by
using Alt key while dragging.

Exact values can be entered in “ROI Properties” dialog which is accessible from the ROI context menu.
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7.4.1.4. Simple ROI Editor

When creating more than one ROI, the Simple ROI editor is the tool of choice. With this tool it is possible
to make all possible shapes with different methods. All interaction techniques work here as well.

Figure 7.13. Simple ROI Editor toolbar

Note that many actions have a hot-key (P for Pointing tool, R for Rectangle, E for ellipse, L for Polygon,
B for Bezier , A for Auto detection, H for drawing holes and others) to speed up the process of interaction.

7.4.1.5. Auto-Detect Tool

Auto-detect tool is available from ROI menu, Simple ROI editor, Edit ROIs in time editor and some other
places. It produces a Polygon ROI. Using the tool is two step process: The first click on an image structure
results in preliminary object contour, that is drawn on the screen. After that, user can further tweak the
object contour and then finish whole auto-detect by confirming with secondary mouse button. User can
always cancel auto-detect by pressing Esc key.

The very first click is important, because these pixels under the cursor determine intensities from which
the algorithm guesses the whole object. As a general rule it is better to choose brightest pixels in the
bright objects (fluorescence) and dimmest in the dark object. It is also good to click near the center of
the object.

After the click the algorithm presents its guess of the object contour and goes into the interactive phase.
In this phase it is possible to:

Redefine the first point by clicking again in the image

Cancel auto-detect by pressing Esc key

Grow or shrink the object area (changes the intensity range of pixels making the object) by scrolling
mouse wheel or pressing PageUp/PageDown (for finer steps use Ctrl + mouse wheel)

Erode or Dilate morphologically the object by 'E'/'D' or Down/Up keys

Open or Close morphologically the object by 'O'/'C' keys

Morpho-separate portions of the object by 'S' or 'P' key (if it is not possible to separate the key does
nothing)

7.4.1.6. Using ROIs for analysis

ROIs are used mainly in Time Measurement to measure varying image intensity inside the ROIs, Auto-
mated Measurement to measure ROIs features or number of binary objects inside each ROI , Object
Count to restrict binary objects to areas of interest only, ROI statistics to measure intensities interactively.
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In all these cases ROI selection is taken into account as well as intersection options in Measurement
Options.

Additionally the Time measurement interprets the ROI usage type. Background ROIs are used for offset
subtraction and Reference ROIs can be used for bleaching correction.

7.4.2. ROIs in Time - Moving ROIs

7.4.2.1. Introduction to Moving ROIs

To define a moving ROI:

1. Open or capture a time-lapse nd2 file.

2. Display the first frame of the image and open the vector ROI editor by the ROI > Simple ROI Editor
command.

3. With one of the editor tools, draw the ROI around an object. Close the ROI editor.

4. Right-click the ROI and select ROI Changes Over Time from the context menu.

5. Play the image sequence and if the object of interest starts to move out of the ROI, pause the replay.

6. Now it is possible to drag the ROI to the new position. If the ROI is created by the vector editor, its
size and rotation can be also modified.

7. Play the sequence further and drag the ROI to a new position each time the object in the image
moves.

Note

ROI positions between two user-defined frames are interpolated. If the object of interest was
moving at constant speed with a linear trajectory, then it would be sufficient to define the ROI po-
sitions only in the first and the last frame of the image sequence.

Tips on Moving ROI

ROI Tracking Motion characteristics of a manually defined moving ROI can be measured using the
View > Analysis Controls > Tracking control panel. Just click the Add Moving ROIs button to add the
current ROIs to the table of objects.

Automatic ROI Definition Automatic Tracking features may be utilized to define moving ROIs. Already
tracked objects may be converted to moving ROIs by clicking the Binary to ROI button.

ROI Multiple Selection Use the Ctrl key to select/unselect more than one ROI. When you have selected
more ROIs, press and hold the Alt key while dragging a single ROI. Other selected ROIs will not be
moved but remain selected.
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8. Measurement

8.1. Basic Workflows

8.1.1. Calibration

8.1.1.1. Introduction

Calibration of the image is of crucial importance to measurement. On calibrated images, realistic
measurements can be performed and objects of different images could be compared to each other. A
correct calibration has to be made before you begin to measure.

There are two ways how to obtain a calibrated image:

• To capture images with a calibrated system (objective). Please see the 4.1.3.3. Objective Calibra-
tion [46] chapter which explains how to calibrate the NIS-Elements AR system.

• To calibrate an uncalibrated image manually:

8.1.1.2. Calibrating an Uncalibrated Image

1) Run the Calibration > Recalibrate Document command.

2)

3)

a) If you know the size of one pixel, click the Pixel size... button.

b) If you do not know the pixel size, draw a distance to the image and set its real length. For
this purpose, you should use an image of a calibration slide or a ruler captured with your
system.
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There are three modes: horizontal, vertical and parallel lines, select one of them. Click
into image to place first line, then second line appears on your mouse cursor. Place this
line and the following dialog box appears.

4)

Figure 8.2. Pixel Size Calibration

Figure 8.3. Line-length Calibration

5) Click OK to finish the calibration.

8.1.1.3. Units

NIS-Elements AR supports the following units:

pixels
nanometers
micrometers
millimeters
centimeters
decimeters
meters
kilometers
inches
mils

If the image is uncalibrated, pixels are the only units available. In case of a calibrated image, it is possible
to select other units which are then used to display all values (e.g. measured length/area). There are
two ways of how to select the desired units:

• Right click the image status bar where the calibration is displayed. Select the units and precision
from the context menu.
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• Or, click the Current unit button located in the Calibration > Explore Objectives command window
and select the units.

8.1.2. Rough Measurement

Quick and approximate measurements can be performed utilizing graticules. They behave like adjustable
floating rulers. User can simply align a graticule with the measured object and read the distance value
(e.g. the diameter). To activate the graticule, press the Graticules button.

1) Select Graticule Type

The type of the graticule ruler is indicated by a picture on the Graticules button placed on the
right image toolbar. To change the graticule type, click on the graticules button with the secondary
mouse button and select the appropriate item from the context menu:

Rectangular Grid
Circle
Simple Circle
Cross
Industrial Cross
Simple Cross
Vertical Ruler
Horizontal Ruler

2) Define Graticule Properties

Right click the Graticules button and select the Graticules properties command from the pull-
down menu. A window appears where display parameters (shape, color, line width, density of
lines) of all graticules can be adjusted.

Graticules Density

The density value - the closest distance between two line intersections of the graticule - can be
set, or you can let NIS-Elements AR adjust it automatically according to the current zoom factor.
The units selection depends on the image calibration (calibrated/uncalibrated).

Note

Concerning the Cross graticule. The distance defined by Density is divided into smaller
sections automatically. However, for odd density values greater than 10, themarkings remain
hidden because it is not possible to display them accurately.

3) Measure the Image

The graticule measurement provides the following options:

• The graticule can be moved by mouse arbitrary.
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• The graticule position can be reset by using the Move Graticules to Center command from the
context menu.

• A binary layer can be created from the current graticule using the Copy Graticules to Binary
command.

• A Graticule Mask can be created from the current binary layer using the Copy/Add Binary to
Graticule Mask command.

• A Graticule Mask can be stored/loaded to/from an external file via the Save Graticule Mask
As and Open Graticule Mask commands.

• A new image containing graticules can be created by the Edit > Create Full View Snapshot
(8bit RGB) command.

8.1.3. Object Count

The Object Count tool is designed for automated object detection and counting. It enables users to
threshold the image, automatically measure the binary objects, and export the measured data to a file
in a straightforward way. Object count can be performed even on Live image. Run the View > Analysis
Controls > Object Count command to display the control panel.

The recommended workflow through the dialog is to move from left to right, starting with thresholding,
then using restrictions and finally reviewing the result and export out of NIS-Elements AR to a text file
or an MS Excel spreadsheet.
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8.1.3.1. Thresholding the Image

The threshold limits shall be defined by picking object-typical colors from the image. Select one of the
following tools:

• 1 point threshold tool

• 3 points circle threshold tool

• 6 points circle threshold tool

Click inside the image to define typical object areas. The system will detect similar parts of the image
and highlight it by color. The threshold limits are indicated in the histogram and can be further modified
by dragging the limit lines by mouse.

Please, refer to the 7.2.1. Thresholding [143] chapter for further details on thresholding.

8.1.3.2. Applying Restrictions

The number of objects that are included in the results table can be restricted by defining limits. Objects
which do not fit these limits will be left out of the result table.

167

Measurement



1. Right click to the restrictions field to select one or more of the available measurement features.

2. Select the restriction feature you would like to define.

3. Move sliders below the histogram to set the limits. The limit values are indicated next to the feature
name, and can be modified by double clicking the indicated value.

4. Decide whether the defined interval will be excluded or included - this is done by setting the Inside/Out-
side option next to the feature name.

5. The nearby check box indicates whether the restriction is currently being applied or not. If applied,
the histogram below is color, otherwise it is gray.

Note

Infinitude can be defined by entering “oo” or “inf”.

Reset The Reset button on the right side discards restriction settings of all features.

Bins This setting determines the number of columns in the histogram.

Restrictions from the Image

A reference object can be picked from the image and used to set the limit values.

• Select the restriction feature you would like to set by mouse. Let's assume you have selected Circu-
larity.
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• Right click the thresholded object which is going to be used as source. A context menu appears.

• Select whether to INCLUDE or EXCLUDE the selected object and all others with higher/lower circularity.

• The restriction will be applied and indicated by colors within the image.

8.1.3.3. Results

The following results appear in the results table:

• Total Area is the area of the ROI. It is shown in square pixels or square calibration units.

• Measured Area is the area of the binaries inside the ROI.

• Number of objects - number of objects after applying restrictions.

• Table of results - measurement results for each object are displayed in this table. Select the columns
to display/hide from the context menu which appears when you right-click one of the column captions.

• # - number of selected objects is displayed in the left part of the toolbar. One or more objects can be
selected by mouse while holding the Ctrl or the Shift key.
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Toolbar

There is a toolbar above the results table which contains the following buttons:

Delete selected objects Removes the selected objects. The objects can be selected by mouse while
holding Ctrl .

Invert selection Deselects objects selected by mouse and vice versa.

Generate binary Erases binary objects which do not meet the restrictions settings.

Show Object Calatog Opens the Object Catalog control panel with data source automatically set to
“Object Count”.

Export The measured data can be exported to clipboard or a file using the Export button. Please refer
to the 8.1.7. Exporting Results [176] chapter for further details.

Export ND data When an ND2 file is opened, the thresholding, measurement, and restrictions are
applied to a single frame. Pressing this button will apply it to all frames of the ND2 document and export
the results to a file or clipboard according to the current export settings.

Save/Load Object Count configuration Invokes a pull-down menu which enables you to load/save
the current object count settings from/to an external file (*.counting).

Use Standard EqDia Check this option to enable counting of objects using standard EqDiameter [?].
Value of the standard EqDiameter [?] parameter can be edited in the field nearby.

Note

Please be aware that the number of objects calculated by this function is only an approximation
and not an accurate count of objects.

Keep updating count Refreshes the measured results each time the binary layer changes (e.g. when
the threshold is modified).

8.1.3.4. Object Count Procedure Example

1. Open the Object Count control panel. See 8.1.3. Object Count [166].

2. Threshold the image. Use the thresholding picking tools and click on the image to sample areas of
interest. These pixels selected will determine what intensity/ part of histogram is considered accepted.
The threshold will detect several specs or smaller objects such as noise or background. If desired,
the Clean and Smooth filters will exclude smaller objects.

3. You can also measure using the defined region of interest (the button) or measurement frame (
the button). Check the options are properly set in the Measure > Measurement Options dialog
window.
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4. Apply restrictions. Select Area from the list of available restriction features. Use the sliders in the
histogram to specify the lower limit and the upper limit. The lower and upper limit will update in the
display.

The green area of the histogram represents the accepted range areas. Any object with an area in the
green range will be considered an object. Alternatively, any object with an area in the red ranges will
not be considered an object.

The outlines of objects on the image differ according to whether the object is restricted or accepted.
In this case, accepted objects have a green outline and restricted objects have a blue outline.

To ensure that that count is updating with any change, click the icon:

5. Remove any unwanted object from the object count by selecting the Delete Selected Objects
icon from the Result section. The object will lose its thresholded overlay and will be excluded from
the measurement.

Warning

You cannot Undo this action. To restore an object repeat the original threshold procedure or
load a saved Object Count configuration.

6. View the result data and export them to a file or spreadsheet application. See 8.1.7. Exporting Res-
ults [176] for further information.

8.1.4. Measurement Options

Run the Edit > General Options command and select the Measurement tab.
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Rules for Excluding Objects This section regards automatic measurement. Select the options how to
treat the objects touching the area borders when you are performing the automatic measurement:

Using Measurement Frame Pick up the option how to treat the object touching the measurement
frame. Run the automatic measurement by the Measure > Use Measurement Frame command.

Using ROI Pick up the option how to treat the object touching the ROI frame. Run the automatic
measurement by the View > Layers > ROI View > Layers > ROI command.

Without Measurement Frame and ROI Pick up the option how to treat the object touching the
image border. Turn off the measurement frame and ROI and run the automatic measurement.

These options do not affect the field measurement results (field measurement is always applied inside
the defined area without exceptions).

Object Colors After the automatic measurement is performed, all measured objects are highlighted by
color borders. Here you can select colors for the objects excluded from measurement according to the
ROI/measurement frame settings. The Out of limits color will be used to highlight objects which do not
fit the applied restrictions ( View > Analysis Controls > Automated Measurement ).

Manual Measurement
Automatically zoom in Length manual measurements This option zooms the image while placing
the measurement points to the image. Only the indicated measurement tools are affected.

Copy manual measurement objects from live image to captured NIS-Elements AR enables to
measure manually on live camera signal ( View > Analysis Controls > Annotations and Measure-
ments ). After the Acquire > Capture command is used, the measurement objects in the image
are copied (or not) to the captured image according to this setting.

Label The manual measurement objects can be labeled. Select what information will be attached
to every manual measurement object in an image.
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8.1.5. Measurement on Graph

The following interactive measurements can be performed within graphs.

Vertical, Horizontal Pick this tool to measure distances within the graph.

Angle This tool enables selecting an angle and its both line lengths. The resulting number represents
a ratio between the projection of the y arrow on y axis and projection of the x arrow on x axis. The resulting
number is a dimensionless value. This tool does not allow adjusting the x line length.

Free Angle This tool measures the same features as the previous angle tool but allows to adjust all
of the angle's anchor points.

Area of Graph This tool enables you to draw a rectangle in the graph. Area will be measured of inter-
section of the rectangle with the area below the graph curve.

FWHM This tool measures the Full Width at Half Maximum value on the given graph range.

Clear Measurement Objects Deletes all the measured objects in the graph.

Reset Data Clears the table with the measurement results.

8.1.6. Pixel Classifier

A typical task for Pixel Classifier may be counting the area of a cross-section of a blood vessel. Since
there are at least three different types of tissue whose area should be calculated while background
should not be counted at all.
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1. Eliminate the background. You can:

• define a region of interest. See 7.4.1. Introduction [157] for more information.

• use the method of accepted region. Run the Edit > Region Settings command first. Choose color
of the background in the Region Settings dialog that appears. You can fill in the value 0, which is
easy to threshold. Next run the Edit > Region > Accepted Region command. Draw the boundary
around the area to keep.

Finish drawing with a right click. The image is cropped according to the boundary. Area of image
which remained outside the border is deleted and filled with the set background color.
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2. Run View > Analysis Controls > Pixel Classifier to display the classifier panel. Press the Define
button and edit all phases you want to detect separately. Use the and buttons and commands
in the contextual menu to Add, Rename or Delete any class.

If you choose the Manual method of classifying, you can manually choose the intensity ranges of all
phases.
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Alternatively, you can sample areas and train the other algorithms to find phase boundaries.

3. Once all phases have been defined properly, the settings can be re-used to classify another images.

8.1.7. Exporting Results

Some image analysis data and measurement results can be transferred out of NIS-Elements AR so they
could be used further. There is a standard Export pull-down menu in some of the control panels (intensity
profile, histogram, measurement, etc...) which enables the export.

The set of commands of the menu differs according to the type of data (tables or graphs) which can be
exported. Click the arrow button to display the pull-down menu. When you select the destination, the
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pull down menu hides and the icon of the selected export type appears on the Export button. The export
action is performed after the button is pressed once more.

Export Destinations

It is possible to export tabular data or a graph:

To MS Excel Tabular data can be exported to MS Excel. A new XLS sheet opens and the table is copied
to it automatically.

To File Tabular data can be exported to an MS Excel sheet (xls) or a text file (tab delimited txt).

To Clipboard Data tables and graphs can be exported (copied) to MS Windows clipboard. Then the data
or the image can be inserted into any appropriate application (text editor, spreadsheet processor,
graphics editor) typically by the Paste command.

To Report Tabular data and graphs can be exported to NIS-Elements AR report. If a report is already
opened for editing, the data/graph will be appended to it. Otherwise, a new report will be created and
the exported data inserted to it.

To Web Browser, To HTML Clipboard Some tabular data can be exported as a HTML table. It can be
displayed in a default Internet browser (the Web Browser option), or the HTML code can be copied to
Windows clipboard - ready to be inserted to any HTML/text editor.

To Printer Tabular data can be printed directly. This option opens a standard Print dialog window where
it is possible to select a printer and print the data.

Data Export Options

Run the Options command and switch to the Data export tab or press the Settings button within the
export pull-down menu. There are two tabs available:

Global Settings Options

Export into Microsoft Excel application Select this option if you want to export the data to MS Excel
application. You can choose if the data will be exported into currently opened file or a new file will be
created. Or you can set to export the data to a specific file. If this file does not exist, it will be created.
Choose the path and name of the file to be created/opened.

Set the Start at column values (column and row indexes). These values mark the first cell in the MS
Excel application which will hold the exported data.

Export text files into folder Select this item if you prefer to export the data to a text file. Press the ...
button and specify the target folder and the file name.

Data delimiter Pick up the type (tabulator, space, semicolon) of data delimiter which will be used when
exporting data to MS Excel or clipboard.

Append exported data after previous exports If you check this item the existing data will not be over-
written by the new data.

Export also column headers if not appending Include the titles of columns in the files which are being
created or overwritten. If the Append exported data after previous exports is selected, no headers will
be included in the export.
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Activate target application after export If you check this item the exported file is opened in the default
application (MS Excel or the default text editor) automatically.

Insert empty lines Check this item to allow insertion of empty lines in the exported data.

Export ROI data per channel If this function is checked, ROI data are exported for each channel separ-
ately.

Data export Options

You can modify the amount of data included in each export type.The control panels which contain the
Export to file functionality are listed in the top pull-down menu. Select the control panel of which the
export shall be modified.

Export Name A control panel such as View > Analysis Controls > Annotations and Measurements
stores information about the measurement in multiple tables according to the measurement type (area,
length, etc.). In this column, you can select the table you would like to modify.

Sheet name In this column you can define an arbitrary name which will be used to name a sheet or a
txt file to which the data will be exported.

Options for: This section of the window enables you to select the items to be included/excluded from
the selected table during export.
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8.2. Manual Measurement

8.2.1. Introduction

Length, area, angles, taxonomy, counts, circle radius, and ellipse semiaxes can be measured manually
over an image. The results are being recorded to a simple statistics table, which can be exported to a
file or clipboard. Also, the data can be presented as a graph.

1. Run the View > Analysis Controls > Annotations and Measurements command. The manual
measurement control panel appears.

2. Select a tool corresponding to the feature you are going to measure. There are several tools for
measuring each feature.

3. Measure the objects in the image using mouse.

4. Select where to export results in the Export pull-down menu.

5. Export the results using the Export button.
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Measurement of the image of a grain:

1) Select the Vertical parallel lines tool.

2) Place the first line on the top edge of the crystal by clicking into the image. The position of the
line can be adjusted while you hold the primary mouse button down. After you release it, the line
is positioned.

3) Repeat this to place the second line on the bottom edge of the crystal.

4) When finished, an arrow is drawn between the lines, and the result of the measurement is at-
tached. A record with the measurement type and the measured value is added to the results
table.

8.2.2. Working with the Measurement and Annotation Objects

There are two types of vector objects which can be placed over the image: annotation objects and
measurement objects.

This button of the right image toolbar turns the visibility of annotation layer ON/OFF. Right-clicking
the button displays a context menu with the following options:

• Clear All Objects will delete annotation and measurement objects.

• Clear Annotation Objects will delete all annotation objects.

• Clear Measurement Objects will delete all measurement objects.

• Select Annotation Objects will select all objects that are not the measurement ones.

• Select Measurement Objects will select all measurement objects.

• Select All Objects and Deselect will select/deselect all annotation and measurement objects.

Visibility of annotation/measurement objects In an ND document that contains a time dimension,
you can set visibility of any annotation object. Right-click on an object and select Object Visibility.... In
the opened dialog, you can choose that the Object is Always Visible in Time or that the Object is Visible
in a Time Range specified in the edit boxes below. Current/First/ Last buttons fill in the current/first/last
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value automatically. If you have already made a frame selection in the time line, use Get Range Selection .
If you are working with a multi point document, you can also Limit Object Visibility to the Current Multi
Point Frame.

8.2.3. Measurement Tools

8.2.3.1. Angle

Measure Free Angle Place the first line in the image, adjust its position, and finish it by right-click.
Place the second line anywhere in the image, adjust its position, and finish it by right-click. The two lines
connects to make the measured angle.

Measure 2 lines Draw the first line and then draw the second line. These lines do not need to visibly
intersect. You can adjust their mutual position, then confirm the measurement by right-click.

Measure via Reference Angle Use the Define Reference Angle tool first. Then, select this tool, and
define a line in the image. The angle between this line and the reference angle will be measured.

Define Reference Angle Draw a line in the image or put the precise value in degrees. Finish the
definition by OK or the right-click.

8.2.3.2. Area

Polygon Draw a polygon by clicking the mouse inside the image, the secondary mouse button will
place the last node of the polygon and finish the measurement.

Rectangle Draw a rectangle holding the primary mouse button down.

Ellipse The first step is to draw a circle holding the primary mouse button down. The second step
is to stretch it to the shape of ellipse.

5-point ellipse - The system draws an ellipse interpolating five points defined by mouse.

4-point ellipse Draws an ellipse interpolating four points defined by mouse.

Auto Detect The system detects a homogeneous area around the clicked point. Tolerance (size of
the area) can be adjusted by rolling the mouse wheel or the PgDown/PgUp keys.

Select binary Makes new interactive measurement object according to selected binary object.
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8.2.3.3. Length

2 Points Distance between two points. Use the primary mouse button to define the start and the
end point.

Simple Line The line length. Use the primary mouse button to draw the line to be measured.

Horizontal The distance between two vertical lines. Use the primary mouse button to insert the line
markers for the start and the end of the measured distance.

Vertical The distance between two horizontal lines. Use the primary mouse button to insert the line
markers for the start and for the end of the measured distance.

Parallel Lines The distance between two parallel lines. Use the primary mouse button to draw the
first marker. Adjust its position by mouse and click the right mouse button. Place the second line using
the primary mouse button again. Press the right mouse button to complete the measurement.

Polyline The polyline length. A polyline consists of several line segments. Use the primary mouse
button to draw the line segments. Each mouse-click creates a new node. Complete the total length
definition by the right mouse button.

Crosses The distance between two crosses. The cross-like cursor helps to position the start and
the end points of the measured distance.

Auto Default The distance between two points estimated by computer. The system detects two
sharpest changes of the pixel intensities and places the points in there.

Auto Outer The distance between two points estimated by computer. The system detects several
sharp changes of the pixel intensities and selects the first and the last one as the measurement points.

Auto Inner The distance between two points estimated by computer. The system detects several
sharp changes of pixel intensities and selects the second and the next to the last one as the measurement
points.

8.2.3.4. Length 3D

Length 3D This tool enables to perform interactive 3D measurement on nd2 files that include the
Z dimension.

Measurement on Slices View

1. Open an nd2 file containing a Z dimension

2. Run the View > Image > ND View > Slices View command to display the image in Slices View .

182



3. Select the Length 3D tool, the cursor gets changed.

4. Select the Z position where the first point lies, place the crosshair, and click the right mouse button.

5. When the crosshair color changes, select the Z position of the second point and place the cursor
there.

6. Confirm the measurement by right click. The measured value is written to the control window results
table.

Measurement on focused Image and Surface View

(requires: Extended Depth of Focus)

1. Open an nd2 file containing a Z dimension and run the Applications > EDF > Create Focused Image
command.

2. You may switch to Surface View or stay in the Focused Image view that appears automatically. The
3D Measurement works the same way in both of them.

3. Invoke the 3D Measurement command. The rest of the procedure equals the interactive 2D meas-
urement:

4. Define both points by mouse and the measurement is performed automatically using the EDF 3D
surface model.

8.2.3.5. Radius

Circle Click into the image to define the center and define the perimeter holding the primary mouse
button down. Adjust the size and finish the measurement by right-click.

3-points circle The circle is defined by three points inserted to the image by mouse.

N-points circle This tool creates the circle by interpolating any number of defined points. Finish the
points definition by right-click.

8.2.3.6. Semiaxes

Ellipse The first step is to draw a circle holding the primary mouse button down. The second step
is to stretch it to the shape of ellipse.

5-points ellipse The system draws an ellipse interpolating five points defined by mouse.

Free Rectangle Draw the rectangle in the image. If you would like to rotate it, select [Pointing Tool],
and drag the green point above the top of the rectangle.
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8.2.3.7. Count and Taxonomy

Count Click inside the image several times. The positions and the number of clicked points is recorded
and you see the actual count in the tooltip. Finish the measurement by right-click. The counted points
are marked by colour in the image.

Taxonomy This tool enables to manually count objects of up to 70 classes.

1. Click the icon.

2. Right-click to the results table and select Taxonomy Options . A window appears.

3. In the window, define the number of classes (from 2 to 70) and the way of inserting markers:
On left button down Inserts a marker to the current cursor position after a mouse click. If this
option is selected, the function keys enable to switch between the classes. In this mode, the Fn
keys works for switching between classes.

On Fn key at cursor position After the Fn key is pressed, the count is performed and the corres-
ponding marker is placed to the current cursor position.

On Fn key at screen center After the Fn key is pressed, the count is performed and the corres-
ponding marker is placed to the center of the image view.

On Fn key at cursor position, no marker inserted After the Fn key is pressed, the count is per-
formed and no marker is placed.

4. Start the count according to the Taxonomy Options setting.

Note

The keyboard function keys F1 - F10 can be used as a shortcut for classification/class selection.
Since there are 70 classes available, certain key combinations must be pressed in order to se-
lect/classify the right class:

Class NumberKey Combination
nFn
10 + nCtrl + Fn
20 + nAlt + Fn
30 + nShift + Fn
40 + nCtrl + Alt + Fn
50 + nCtrl + Shift + Fn
60 + nShift + Alt + Fn

5. Perform the measurement until all classes are counted.

8.3. Automated Measurement
Automated measurement is the most powerful of image analysis features. In combination with user
macros, NIS-Elements AR can become a semi- or fully-automatic image analysis tool. There are several
key procedures which a proper automated measurement should involve:
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1. Optical system calibration (see the 4.1.2. Optical Configurations [42] chapter)

2. Image acquisition (see the 5. Image Acquisition [63] chapter)

3. Defining threshold, creating the binary layer (see the 7.2.1. Thresholding [143] chapter)

4. Selection of measured features. Viz 8.5. Measurement Features [191].

5. Performing the automated measurement

6. Results presentation

Image Layers Involved in Measurement

The binary layer and also the color image can get involved in the automated measurement:

• Binary layer - is typically used for shape and size measurements (area, perimeter, surface fraction).

• Color layer - intensity or hue measurements are carried out on this layer. The area covered with the
binary layer is used as the source data.

Object/Field Measurement

NIS-Elements AR distinguishes two types of automated measurements: object and field.

Object Measurement Groups of neighbouring pixels of the binary layer are called objects. Results of
the object measurement are usually the object data such as Length, Area, CentreX/Y (the X,Y position
of the central pixel of an object), etc.

Field Measurement Field measurements produce information regarding the whole measurement area
(measurement frame, ROI). Such information can be Area Fraction, Mean Brightness, Density Variation,
etc.

Please see the complete list of measurement features in the 8.5. Measurement Features [191] chapter.

Restricting the Area of Measurement

The area of measurement can be restricted by the measurement frame or by a user defined region of
interest (ROI).

Region of Interest - ROI ROI is a user defined area of the image. Whenever the ROI is displayed (by the
View > Layers > ROI View > Layers > ROI command), it is also applied to restrict the area of measure-
ment.

Measurement Frame The measurement frame is a re-sizable rectangular frame which serves for
bounding the area accepted for measurement. Turn the measurement frame ON via the Measure >
Use Measurement Frame command.

Binary objects touching edges of ROI or the measurement frame can be treated differently (excluded
from the measurement or included). This behavior can be specified within the Measure >Measurement
Options window.
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Statistics and Data Presentation

NIS-Elements AR calculates basic statistics - mean value, standard deviation and distribution of all
measured features. The features to be measured can be selected in the Measure > Object Features
and the Measure > Field and ROI Features windows. Results of all automated measurements are
presented and can be exported from the View > Analysis Controls > Automated Measurement Results
control panel.

8.4. Time Measurement
The time measurement tool enables to record average pixel intensities within Regions Of Interest (ROIs)
during a time interval. The measurement can be performed on Live camera signal or on a saved nd2
file. Before the measurement is started, regions of interest shall be defined and turned ON. When no
ROI is defined, Time Measurement is performed on the whole image automatically.

Note

Time measurement is not supported for multichannel ND documents containing a brightfield
channel.

Run the View > Analysis Controls > Time Measurement command to open the Time Measurement
control panel.

Figure 8.17. Time measurement window

The control panel consists of three parts: measurement tools, ROI definition tools and data display.

8.4.1. Quick Guide

• Enable the Measurement ROI by the View > Layers > ROI View > Layers > ROI command.

• Run the Acquire > Live - Fast command to display the live camera signal.
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• Define ROI(s) within the image. Time measurement will be performed under the ROI areas. Use the
ROI > Simple ROI Editor command or the Define toolbar button to open the vector ROI editor and
use the ROI > Raster ROI Editor command to display the raster ROI editor. See 7.4.1. Introduc-
tion [157].

• Once the ROIs are defined, press the Measure button - the measurement will start.

• When the current ND document contains combination of time dimension with Z dimension or multi-
points, press the Measure All button to measure all frames across all multipoints and/or Z stacks
at once.

• Press the Stop button to finish the measurement.

• Export the results via the Export button. See 8.1.7. Exporting Results [176] for further details.

• A snapshot of the graph will be created if you press the Create Snapshot button.

Note

If there are toomany ROIs defined and the graph gets confusing, a single ROI (and the corresponding
graph) can be highlighted. Right click the ROI name and select Bookmark this ROI from the context
menu.

Click >> next to Color to reveal Mean and Maximal Intensity columns which are useful for filtering
out ROIs/objects with insufficient intensity.

8.4.2. Options

Click the Options button. A dialog appears where you can specify the time measurement details:
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General Options tab

Graph Choose background, axes and grid colors from the palette. Check theGraph Title option to display
a title, whose text you can enter in the adjacent field. Then check the Show ... Grid items if you want to
make them visible in the graph. If .. Axis Always Visible item is checked, the axes do not leave the graph
area while zooming in the graph.

Data Lines Select interpolation method or drawing the graph lines by pressing the relevant button. You
can choose Steps (rough), Linear (smoother), or Bicubic (really smooth) interpolation method.

Logarithmic Check to use logarithmic scale in the graph.

Graph points Check this item to display data points. Small dots indicating the actual data values
position can be displayed on the graph line. The points appear only if the distance between them
is big enough for them to be recognized (they usually appear when you zoom in the graph).

Anti Alias Turning this option ON will make the graph lines look smooth.

Fill Graph Area Check this item to fill in the area under the line chart with a color. Select the amount
of opacity used from the list of predefined values.
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Show point coordinates Check this item to display or hide X, Y coordinates of pixels in the Data
tab of the Intensity Profile control panel.

Display During Measurement Select one of two options:
Fit graph to measured data If you select this option, displayed area of graph during measurement
is fit to measured data.

Fixed time range If you select this option, displayed area of graph during measurement is fixed to
defined values. Then define time range of displayed area of graph.

Use Zero Based Timescale Select this option to ensure that the first frame of a time sequence will always
start at 0.0s.

Data decimals Define decimal precision of the results in the data table.

For ratio, calcium titration and FRET Define decimal precision of data in data table for ratio, calcium
titration and FRET.

X axis

Graph Range The Auto option enables that the range values are set automatically. On the contrary the
range values can be set on Fixed values also. The range values can be set for minimum of X axis, max-
imum of X axis, major and minor grid of X axis.

Zoom If you select the Best Fit option, zoom of the X axis will be set to best fit. Otherwise you can set
the Fixed range.
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Y axis left/right

The Graph Range and Zoom options are described above.

Left/Right Data line pen Set the line appearance - line color (in case color of image component is not
set), thickness and style (solid, dot, dashed, dash-dot).

Define Events

This tab enables to define user hot keys which run special user events during time measurement. Simply
click inside the Hot key field of the User event and press any key combination you want to assign to the
event. Then you can arbitrary enter an event description. Finally select or enter command or macro
which should be executed when you press the set hot key.
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When these events are performed on a document, they are also displayed in the graph. These events
are marked on the time axis and identified by their name. For more information see Special Options [70].

8.5. Measurement Features
The following list describes all the features that can be measured withinNIS-Elements ARMeasurements.
There are the following. Different measurement tools measure different features.

Object features - measured under binary objects (layers)

ROI features - measured within ROIs

Field features - measured over the whole image area

Features available in manual measurement

EDF features - can be measured only after EDF focused Image was created.

3D features - measured on 3D binary objects (a thresholded Z-series data set is needed)

Tracking features - measured on tracked binary objects or ROIs.

Complete list Regardless of measurement type.

Accel.N
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Normal acceleration is the part of acceleration vector that is perpendicular to the velocity vector incoming
to the current object position.

Accel.T

Tangential acceleration having the same direction as the velocity vector.

Acceleration

Total force that is acting on an object calculated using speed difference between the next and the current
segment.

AcqTime , ,

Calling the Grab Sequence command, the AcqTime is set to zero at the beginning. Then, NIS-Elements
AR assigns the AcqTime to every newly grabbed image file header, which denotes time elapsed from
the beginning of the grabbing. If the Grab Sequence command is not called, than the AcqTime is the
time elapsed since the start of NIS-Elements AR .

Angle

Angle between two user-defined lines.

Area , ,

Area is a principal size criterion. In a non-calibrated system, it expresses the number of pixels; in a cal-
ibrated one, it expresses the real area.

Figure 8.23. Area

For tracking: (requires: Advanced 2D Tracking).

Axis A, Axis B, Axis A/B

Lengths of the major (A) and minor (B) axes of an ellipse and their ratio.

BinaryArea

Sum of areas of all binary objects.

BinaryAreaFraction

BinID

Binary layer identifier.

192



Blue

Arithmetic mean of pixel intensities of the blue component.

BoundsAbsLeft, BoundsAbsRight, BoundsAbsTop, BoundsAbsBottom

These are absolute distances (X or Y coordinates) of the left, right, top, and bottom edge of the object
bounding rectangle within a motorized stage range. This feature can be measured only when a motorized
stage is connected.

Figure 8.24. BoundsAbs

BoundsLeft, BoundsRight, BoundsTop, BoundsBottom

These are distances (X or Y coordinates) of the left, right, top, and bottom edge of the object bounding
rectangle measured in the current calibration units. If the image is not calibrated, the coordinates are
in pixels.

Figure 8.25. Bounds

BoundsPxLeft, BoundsPxRight, BoundsPxTop, BoundsPxBottom

These are distances (X or Y coordinates) of the left, right, top, and bottom edge of the object bounding
rectangle measured in pixels.

BrightVariation , ,

It is the usual standard deviation of brightness values.

CentreX, CentreY , , ,

Coordinates of the center of gravity measured in the current calibration units. If the image is not calib-
rated, the coordinates are in pixels.
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CentreXabs, CentreYabs ,

Absolute coordinates of the center of gravity in the scope of the stage XY range. These features can be
measured only when a motorized stage is connected.

CentreXpx, CentreYpx , ,

Coordinates of the center of gravity measured in pixels.

Channel , , ,

Comma delimited list of channel names on which the measurement has been performed.

Circularity ,

Circularity equals to 1 only for circles; all other shapes are characterized by circularity smaller than 1.
It is a derived shape measure, calculated from the area and perimeter. This feature is useful for examining
shape characteristics.

For tracking: (requires: Advanced 2D Tracking).

Comment , , ,

This feature adds an editable column to the results table.

Convexity

Indicates convexity of the object edges.

DensityVariation , ,

DensityVariation is derived from density values. It is the usual standard deviation of density values.

Diameter

Diameter of a circle measured manually.

Diff Coef

The diffusion coefficient characterizes how a substance diffuses in time. It is a feature of a track. Having
a track over k frames, we get k value pairs ((MSD1, T1), ..., (MSDk, Tk)), from which k equations are created:

D Diffusion coefficient

MSD Mean Squared Displacement of the object in each frame (time T)

n number of dimensions. 2 for 2D tracking, 3 for 3D tracking

T Time
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Then, the method of least squares is used to calculate a single diffusion coefficient (D) from the set of
equations.

Diff Coef R2

Indicates how well the calculated diffusion coefficient (Diff Coef [?]) reflects the data. Diff Coef R2 =
1 means that the Diff Coef matches the data. If Diff Coef R2 = 0, Diff Coef does not match the data at
all.

Duration

Time duration of the track.

EdfRoughness , , ,

Based on the 3D EDF surface model, it indicates how much the surface is rough. Its value for a flat
surface is 1.

EdfRoughnessRA , , ,

Based on the 3D EDF surface model, it indicates how much the surface is rough. It is a sum of absolute
values of differences between Z value of each pixel and mean of all Z values divided by Area. Its value
for a flat surface is 0. It is the most widely used one-dimensional roughness parameter

EZ The mean height of the Z-map (mean of all Z coordinates of the EDFSurface).

n, Area, Ω Number of pixels in the measured area (image/object/ROI).
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Zi EDFSurface Z coordinate of a particular pixel.

EdfSurface , , ,

Based on the 3D surface model, it is an approximation of the surface area. Its value for a flat surface
= Area.

Figure 8.26. EdfSurface highlighted red, Area of four Edf surfaces highlighted yellow

Elevation

Elevation is the angle between the direction of the velocity vector and the XY plane. Positive elevation
is towards positive Z coordinates. The values range from -90 to 90.

(requires: Advanced 2D Tracking) and (requires: 3D Measurement).

Elongation , ,
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Characterizes the object shape.
Elongation2D Ratio of MaxFeret and MinFeret features.

Elongation3D Elongation is calculated as a ratio of axes lengths.

For tracking: (requires: Advanced 2D Tracking).

EqDiameter , , ,
EqDiameter2D A size feature derived from the area. It determines the diameter of a circle with the
same area as the measured object:

Figure 8.27. EqDiameter

EqDiameter3D A feature derived from the volume. It determines the diameter of a sphere with the
same volume as the measured object:

For tracking: (requires: Advanced 2D Tracking).

FieldID , ,

Automatically generated field ID. Each measurement per field generates a new ID.

File Name
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Name of the source file.

FillArea

If an object contains holes, FillArea remains the same while Area is reduced by the area of the holes.
In case an object does not contain holes, FillArea = Area.

Figure 8.28. FillArea

FillRatio

FillRatio is the ratio of Area and FillArea:

If an object does not contain holes the FillRatio is equal 1. If an object contains holes, FillRatio is less
than 1. This feature can distinguish objects with and without holes.

Generation

When track splitting is performed, this feature displays the generation of each track. The parent track
has Generation = 1, tracks after first splitting have Generation = 2, etc.

Green

Arithmetic mean of pixel intensities of the Green component.

Heading

Angle between the direction of the velocity vector and the X axis. Zero degrees is in the direction of X
axis (to the right) and increases counterclockwise until 360.

Height

Projection of 3D length measurement to the Z axis.

HueTypical , ,

HueTypical (H) is the hue value with maximum frequency in a hue value histogram. This feature describes
the most frequent hue (color) in an object or field.
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HueVariation , ,

HueVariation is the usual standard deviation of hue values. This feature describes hue (color) distribution
of inner structure of an object or field.

ID

Unique binary object identifier.

IntensityVariation , ,

IntensityVariation is derived from an intensity histogram. It is an usual standard deviation of intensity
values. This feature describes the inner structure of an object or a field.

Length , ,

Length is a derived feature appropriate for elongated or thin structures. As based on the rod model, it
is useful for calculating length of medial axis of thin rods.

Figure 8.29. Length

Length xyz, Length xy
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3D length measured manually. Length xyz is the actual length measured on Slices View or Volume View.
Length xy is length of a projection of the measured line to the XY plane.

LineLength ,

Line length is defined as the length of the object with elongated shape. For tracking it is the length of
a straight line from the track origin to the current point.

LineSpeed

Line Length divided by the time elapsed. It represents the speed of progression of a given object.

MaxFeret, MaxFeret90 , ,

The MaxFeret is the maximal value of the set of Feret's diameters. Generally (for convex objects), Feret's
diameter at angle α equals the projected length of object at angle α , α (0,180); NIS-Elements AR calcu-
lates Feret's diameter for α =0, 10, 20, 30, ..., 180.

The MaxFeret90 is a length projected across the MaxFeret diameter.

Figure 8.30. MaxFeret

For tracking: (requires: Advanced 2D Tracking).

MaxIntensity , , ,

MaxIntensity value is derived from the intensity histogram. It is the maximal of pixel intensity values (I).

Mean Sq. Displacement

Mean Square Displacement of the track calculated as a sum of squared distances from the beginning
of the track.

Mean*ChannelName*, MeanRed, MeanGreen, MeanBlue , ,

Arithmetic mean of pixel intensities of one image component.

MeanBrightness , , ,

Arithmetic mean of brightness values of pixels.

MeanChord , ,
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MeanChord is the mean value of secants in the 0, 45, 90 and 135 degrees directions. It is a derived
feature and is calculated from the Area and mean projection according to the following formula.

MeanDensity , , ,

Arithmetic mean of density values of pixels.

MeanIntensity , , , , ,
MeanIntensity2D MeanIntensity value is derived from the intensity histogram. It is the arithmetic
mean of pixel intensities (I).

MeanIntensity3D Arithmetic mean of intensities inside the object.

For tracking: (requires: Advanced 2D Tracking).

MeanRatio, MeanCa2+, MeanCorrFRET, MeanFRETEff, MeanTitration , ,

Arithmetic mean of intensities of the Ratio / Ca2+ / Corr FRET / FRET Eff / Ph channel. This feature is
activated upon creation of the channel view.

MeanSaturation , ,

Arithmetic mean of saturation values of pixels (S).

MeasuredArea , ,

MeasuredArea value is the area of the measurement frame or of a mask within the measurement frame,
if the mask status is on.

MinDistance

Distance between the centroid of the object and the centroid of the nearest object.

MinFeret , ,
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The MinFeret value is the minimal value of the set of Feret's diameters. Generally (for convex objects),
Feret's diameter at angle α equals the projected length of object at angle α , α (0,180); NIS-Elements
AR calculates Feret's diameter for α =0,10,20, 30, ..., 180.

For tracking: (requires: Advanced 2D Tracking).

MinIntensity , , ,

MinIntensity value is derived from the intensity histogram. It is the minimum of intensity values of pixels.

Figure 8.31. Calculation of Intensity (I)

ND.M , , ,

Number of the Multipoint.

ND.T , , ,

Frame index in time.

NearestObjDist

The smallest distance to another object (measured between centers of gravity).

Note

If ROIs are used during the measurement, NearestObjDist is calculated only between the objects
within the specific ROI (objects having the same ROI ID).

No.Segments

Number of segments in a track.

NumberObjects ,

NumberObjects value returns the number of objects in the measurement frame. Exclusion rules for
counting objects are taken into account.

NumberObjectsRestricted

Number of objects left after applying restrictions.

Numbers

Number of points clicked within one Count measurement. See 8.2.3.7. Count and Taxonomy [183]

ObjectAreaFraction
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ObjectsArea

Area of all binary objects within ROIArea [?].

ObjID

Binary object ID. Each binary object has a unique ID

Orientation ,

Orientation Orientation is the angle at which Feret's diameters have their maximum. The
diameters are calculated with 5 degrees angle increment.

Figure 8.32. Orientation

Orientation Angle (O) between the X axis and the projection of the Major (M) axis in the XY
plane. Orientation [0, 180).

Figure 8.33. Orientation (O) and Pitch (P)

OuterPerimeter

Length of the outer perimeter (unlike in Perimeter, holes inside the object do not count).

PathLength

Sum of the segment distances from the first frame to the current frame.

PathSpeed

Length of the path divided by the amount of time elapsed from the beginning to the current position.

Perimeter , , , ,
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Perimeter is the total boundary length. It includes both the outer and inner boundary (if there are holes
inside an object). The perimeter is calculated from four projections in the directions 0, 45, 90 and 135
degrees using Crofton's formula

Figure 8.34. Perimeter

For tracking: (requires: Advanced 2D Tracking).

PerimeterContour

Total boundary length computed from object contours. Compared to Perimeter, it is more accurate (es-
pecially on elongated objects) but slower to get the result.

Pitch

Angle between the Major axis and its projection in the XY plane. Pitch [0, 90].

Figure 8.35. Orientation (O) and Pitch (P)

PositionX, PositionY, PositionZ

X,Y,Z coordinates of the object's centroid.

Position Z: (requires: Advanced 2D Tracking), (requires: 3D Measurement).

Radius

Radius of a circle measured manually.

Red

Arithmetic mean of pixel intensities of the Red component.

RefLength
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Distance from the object centroid to the reference object. Any of the 3D object can be set as reference
from context menu in the Measure > 3D Object Measurement window.

RefLineLength

Length of a straight line from the Reference Point defined by the user to the current point.

RefObjLineLength

Length of a straight line from the Reference Object (e.g. Track) defined by the user to the current point.

ROIArea

Area of each ROI measured in the calibration units.

RoiID ,

ROI ID. Each ROI has a unique ID.

Roughness ,

This feature indicates how much the object is rough. “1” means the object roughness is minimal (the
object is circular). The feature may acquire values in range <0;1>.

RoughnessInf

This feature indicates how much the object is rough. “1” means the object roughness is minimal (the
object is circular). The feature may acquire values in range <1;inf>.

Seg.Length

Length between two neighboring frames.

ShapeFactor ,

This parameter is to define whether the object is rough or not.

Figure 8.36. ShapeFactor
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Source , , ,

Name of the measured image file.

Speed

Segment length divided by the amount of time elapsed between the two positions.

Sphericity

Similarity to a sphere, computed as the ratio of the object surface to the surface of a sphere with
matching volume. A sphere has the maximum Sphericity = 1.

V = volume, S = surface

StartX, StartY

When you scan the image from the origin as indicated (left->right), the first pixel of the object you hit is
the one with StartX and StartY coordinates.

Figure 8.37. StartX, StartY

StartXpx, StartYpx

StartX and StartY coordinates measured in pixels (see above).

StgPosX, StgPosY ,

StgPos features are coordinates of the absolute position of the measured field. It is available only for
systems equipped with an XY stage.
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Figure 8.38. StgPos

Straightness

Feature which shows overall straightness of the object trajectory calculated by formula: End Points
Distance / Trajectory Length. Values range is 0.0 - 1.0.

Sum*ChannelName* , ,

The sum of intensity of all pixels of the object/ROI/field.

SumBrightness , ,

SumBrightness is defined as the sum of brightness in every pixel of the object.

SumDensity , , ,

SumDensity is the sum of individual optical densities (O.D.) of each pixel in the area being measured.
This feature describes, for instance, the amount of a substance in biological sections. Optical density
is evaluated according to the following formula:

SumIntensity , , , , ,

Sum of intensity in every pixel/voxel of the object.

For tracking: (requires: Advanced 2D Tracking).

Surface ,

Surface of the object.

For tracking: (requires: Advanced 2D Tracking).

SurfVolumeRatio ,

SurfVolumeRatio is a feature with a strong stereological interpretation: if you measure on fields that are
sampled systematically and independently of the content of the sections, then the feature is an unbiased
estimator of the surface area of objects (inner structure) per volume of the whole sample.

Time ,
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Time Time assigns the time to a field (object) after a measurement has been performed. See
the SetReferenceTime function help.

Time Time interval measured on a 1DT document. See also Velocity.

TrackID ,

(requires: Object Tracking)

Objects measured with the Object Tracking [12] module provide this feature. If branching of tracks is
allowed, each branch has its own TrackID.

Figure 8.39. TrackID

Type

(requires: Advanced 2D Tracking)

Name of the binary layer (created by thresholding) or ROI with its number.

Velocity

This feature can be measured on a 1DT image using length measurement tools. 1DT image can be
created from a timalapse ND file.

1. Open a timelapse ND2 file and run View > Image > ND View > Slices View .

2. Rightclick one of the side views and select Create New Document from this View. A new image will
be created.

3. Perform length measurement on the new image.

Volume ,

Volume of the object.

For tracking: (requires: Advanced 2D Tracking).

VolumeEqCylinder

This parameter is based on the rod model. Length is interpreted as height and Width as the base dia-
meter of a cylinder. Bases are considered to be spherical.
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Figure 8.40. VolumeEqCylinder

VolumeEqSphere

Volume of a sphere whose diameter is equal to EqDiameter [?] of the measured 2D object.

Figure 8.41. VolumeEqSphere

Width ,

Width is a derived feature appropriate for elongated or thin structures. It is based on the rod model and
is calculated according to the following formula:

Figure 8.42. Width

For tracking: (requires: Advanced 2D Tracking).
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X, Y, Z

Coordinates of the binary centroid.
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9. Creating Reports

9.1. Report Generator
Report Generator allows the user to create a print-ready document which can contain measured data,
images, graphs etc. Once you start it by the File > Report > New Blank Report command, a graphical
editor appears.

Creating of a report in Report Generator is very similar to creating any document in a common text ed-
itor. You can insert text fields, simple shapes, images, tables or graphs. As well as in text editors, you
can create templates containing objects which do not change such as headers and footers, but also
dynamic objects to be filled with data (e.g.: image name, author, etc) filled upon creation of the report.
This comes especially handy in connection with the Database module where database fields are loaded
to the report(s) automatically.
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9.2. Report Objects
A report is composed from report objects. In the left toolbar, there are tools for inserting different objects.

1. Select one of the tools

2. Click and move the mouse inside the report to determine the area reserved for the object. Release
the mouse button.

3. Double-click the report object to open a window where its properties can be adjusted.

4. Confirm the changes by OK .

Tip

Vector objects (report objects, annotations, interactive measurement objects, ROIs) can be copied
by “drag and drop” while holding the Shift key down.

1. Select the object(s).

2. Press Shift and drag the object somewhere.

3. A copy of the object is placed to where you release the mouse button.

9.2.1. Aligning Objects

Align Objects

You can align two objects to the same horizontal or vertical level.

1. Select more objects (e.g. by holding down CTRL and clicking with the primary mouse button).

2. Right-click one of the selected objects and select the Align or Distribute > Align ... command from
the context menu.

3. The objects will be aligned as indicated on the command icon.

4. If the Relative to Page ( ) option is turned ON, the objects will be aligned to the edges or the center
of the page.

Distribute Objects

Objects of similar size can be distributed uniformly in the horizontal/vertical direction.

1. Select three or more objects.

2. Right click one of the objects and select the Align or Distribute > Distribute... command from the
context menu.

3. Distances between the objects will be adjusted to equal.
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4. If the Relative to Page option ( ) is turned ON, the outer objects will be moved to the edges of the
page.

Match Object Sizes

Sizes of objects can be unified too.

1. Select two or more objects.

2. Right-click the “master” object to the size of which you want to resize the other objects.

3. Select one of the Resize Objects sub-menu commands.

9.2.2. Dynamic Data

Results of automatic-interactive measurement, graphs, or the current image can be inserted to reports.

1. Insert an object which can contain dynamic data (text, picture, table, or graph).

2. Right-click the object and select Insert Dynamic Data/Insert Dynamic Picture from the context menu.

3. A window appears.

4. Select one of the available sources, and click Next .

5. Finish the source definition and click OK . The data appear on the report page.

List of Available Dynamic Data Sources:

• Data inserted by user (available for: image, text, table ) - the system will ask you to type a text or
browse for an image to insert during the report creation. When creating a dynamic object of this type,
a query text which will be used to prompt you for the data can be defined.

• System data (available for: text, table ) - enables you to insert some general data such as date, the
name of the user account currently logged in, the page number, or the page count.

• Macro (available for: text, table ) - enables you to insert expressions, values, or results of a macro.

• Measurement (available for: text, table, graph ) - enables you to insert results of automatic/interactive
measurement.

• Database (available for: image, text, table ) - this data source is displayed only when creating a
database report template (see below). It enables you to insert a link to any of the database records.

The real purpose of the dynamic data turns up when creating reports using report templates.

9.3. Report Templates
A report template is a layout defining the appearance of future reports, which is ready to be filled with
data. The data can be inserted by the user “on demand” or automatically (dynamic data).
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To Create a Report Template

1. Run the File > Report > New Template command. An empty report appears.

2. Edit the report template in the same way as a common report.

3. Insert the dynamic data where it is appropriate - measurement results to text boxes or tables, the
current image to the image field, etc.).

4. Save the report template (*.rtt) via the File > Save command.

To Create a Report FROM Template

1. If the template is opened inside the Report Generator, run the File > Create Report command. Other-
wise, use the File > Report > New Report from Template > Browse command inside the main ap-
plication window to open a template from harddisk.

2. A report opens and the dynamic data is inserted automatically.

3. Save the report, print it, or export the page(s) to PDF using the commands from the File menu.
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10. Macros

10.1. Creating Macros
A macro - an executable sequence of commands - can make the work very effective. NIS-Elements AR
provides a C-like programming language utilizing its internal set of functions. The sequence of functions
can be created either by recording the performed actions, by writing the functions within the macro
editor, or by modifying the command history (the history is recorded automatically during the work). The
macro can be saved to an external (*.mac) file for later use.

Recording a Macro

The fastest way to create a macro is to record it.

• Start the NIS-Elements AR macro recorder by selecting the Macro > Record command.

• Perform the series of actions you would like to record.

• Finish the recording by the same command again (its name changes to “Stop Recording”)

• It is recommended to check the macro in the macro editor before saving. Run the Macro > Edit
command to display it.

• Save the macro to a file via the Macro > Save As command.

Creating a Macro from History

You can create a macro using the list of recently performed commands.

1) Run the Macro > History command to display the Command History control panel:
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2) Push the Create Macro button.

3) Select what portion of the command history will be used in the macro:

Selection This option will use only commands which you have previously selected by mouse
within the Command History window. Group selection (holding Shift or Ctrl ) is available.

Whole History All commands listed in the Command History window will be used for the new
macro.

4) After you selected one of the options, the macro editor appears containing the new macro source
code. Use the editor to fine-tune it.

Note

The Remove Redundant command is automatically performed before the macro is opened
in the editor.

Writing/Editing a Macro

If you posses programmers skills, a macro can be written by hand in the built-in macro editor. Run the
Macro > Edit command to display it.

The macro editor provides:
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• Undo/Redo functionality.

• Command insertion from the list of available commands.

• Interactive command names list. Press Ctrl+Space to display a simplified list of all commands
while typing the macro.

• Syntax hints (parameter types and names) appear as you type a command name.

• Bookmarks can be placed to the code so you can easily roll to the important parts of the macro.

• Breakpoints can be placed to the code. A breakpoint forces the macro to stop the execution at a
certain point so you can check the state of variables and therefore inspect the macro functionality
thoroughly.

• Syntax highlighting.

• Help on commands with detailed description.

• Use the Save Macro and the Save Macro As commands in the macro editor to save the created
macro.

NIS-Elements automatically remembers the folder from where the macros were run the last time and
will open this folder when user clicks on Open/Save command in Macro menu.

10.2. Running a Macro
NIS-Elements AR provides several ways to run a macro.

• You can run the current macro loaded to NIS-Elements AR by choosing the Macro > Run command
or by pressing F4.

• A hotkey combination (Ctrl+Alt+1,2,3 ... 9) can be assigned to it in the Macro > Macro Options
window.

• You can run a macro at the beginning of the NIS-Elements AR session, by assigning the StartUp flag
to the macro in the Macro > Macro Options window.

• You can run a macro saved to a disk by using the Macro > Run From command.

• A toolbar button can be assigned to run a macro. See 3.6. Modifying Toolbars [34].

Breaking the Macro

The macro execution can whenever be stopped by pressing the Ctrl+Break key shortcut.

10.3. Macro Language Syntax
Specifies the NIS-Elements AR Macro Language features.
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10.3.1. Variable types

The following data types are implemented:

char text

char8 <-128, 127>

byte <0, 255>

int <-32768, 32767>

word <0, 65535>

long <-2 147 483 648, 2 147 483 647>

dword <0, 4 294 967 295>

double <1.7E +/- 308 (15 digits)>

10.3.2. Structures and Unions

Structures and unions are not supported.

10.3.3. Arrays

One and two dimensional arrays are supported.

10.3.4. Local and Global Variables

You should declare local variables at the beginning of macro or function only. You should declare global
variables only at the beginning of macro. You can run two nested macros declaring the same global
variables, but they must be of the same type. You can declare global variables by prefixing the declaration
global. Eg.:

global int Number_Rows;
global char buffer[200];

The “global” keyword in front of the variable definition assigns the variable to the global scope. Such
variable is then accessible from all function scopes within the macro interpreter.

10.3.5. Statements

Supported Statements

for The for statement lets you repeat a statement a specified number of times.
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Syntax

for([init-expr]; [cond-expr]; [loop-expr])
statement

First, the initialization (init-expr) is evaluated. Then, while the conditional expression (cond-expr) evaluates
to a non zero value, Statement is executed and the loop expression (loop-expr) is evaluated. When cond-
expr becomes 0, control passes to the statement the following the for loop.

while The while statement lets you repeat a statement until a specified expression becomes false.

Syntax

while(expression) statement

First, the expression is evaluated. If expression is initially false, the body of the while statement is never
executed, and control passes from the while statement to the next statement in the program. If expression
is true (nonzero), the body of the statement is executed and the process is repeated.

if, else Conditionally executes a statement or group of statements, depending on the value of an expres-
sion.

Syntax
if(expression) statement1

[else statement2]

The if keyword executes statement1 if expression is true (nonzero); if else is present and expression is
false (zero), it executes statement2. After executing statement1 or statement2, control passes to the
next statement.

goto Transfers control of the program execution.

Syntax

goto name;
. . .
name: statement

You cannot use goto to jump inside the block from outside. E.g. following is not allowed:

goto label;
if(k>5)
{

label:
DilateBinary(3, 5);
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FillHoles();
}

You cannot use goto to jump out from the block more then 2 block levels down. E.g. the following is not
allowed:

for(i=0; i<64; i=i+1)
{
for(j=0; j<64; j=j+1)

{
if(a[i] > b[i])

{
value = i;
goto end; // crossing 3 right brackets
}

}
}

end

break Terminates the execution of the nearest enclosing statement.

Syntax

break;

The break keyword terminates the execution of the smallest enclosing for or while statement in which
it appears. Control passes to the statement that follows the terminated statement.

continue Passes control to the next iteration of the statement in which it appears.

Syntax
continue;

The continue keyword passes control to the next iteration of the for orwhile statement in which it appears.
Within a while statement, the next iteration starts by reevaluating the expression of the while statement.
Within a for statement, the first expression of the for statement is evaluated. Then the compiler reevalu-
ates the conditional expression and, depending on the result, either terminates or iterates the statement
body.

Statements which are not supported

do, switch, case, default, typedef These statements are not supported.

10.3.6. Directives

The following directives are supported by the system:
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define The #define directive assigns a meaningful name to a constant in a program.

//Syntax

#define identifier token-string

The directive substitutes token-string for all subsequent occurrences of the identifier in the source file.
Token-string can be a value or a string (only for 32-bit version of NIS-Elements AR).

//Example

#define ERROR_SPRINTF 0
#define MAINDIR "c:\Images"

int main()
{
char buf[256];
int retval;

retval = sprintf(buf, "%s", "MAINDIR");
if(retval == ERROR_SPRINTF)
Beep();
else WaitText(0., buf);
return TRUE;
} \

include Specifies the name of the file to be included.

//Syntax

#include filename

The #include directive includes the contents a file with a specified filename in the source program at
the point where the directive appears.

Example
// if you do not specify the full path, NIS-Elements assumes, that \

it is a relative path to a main directory

#include "macros\my_macro.h"
#include "c:\NIS-Elements\macros\my_macro1.h"

import The #import directive is used to incorporate information from an external library.
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//Syntax

#import("DLLname");
#import function_declaration

NIS-Elements can call functions from external DLL's. You should import the DLL, where the functions
resides and then make a declaration of the functions. You should not import the following system DLL's:
kernel32.dll, user32.dll, gdi32.dll, com32.dll, comdlg32.dll. This feature is available only for 32 bit
version of NIS-Elements.

//Example

#import("luc_13.dll");
#import int RTF_ReplaceVariables(LPSTR destfile, LPSTR sourfile);
#import int RTF_FindQuestion(LPSTR sourfile, LPSTR question, long \

*length, LPSTR defvar);
#import int RTF_ReplaceQuestion(LPSTR destfile, LPSTR sourfile, LPSTR \

replacement);

__underC The __underC directive assigns a function to be interpreted by the UnderC engine instead of
the standard interpreter.

//Syntax
//works only on 32bit operating systems

__underC int inter_sharpen(int cols, int rows) { }

#importUC The #importUC directive imports an API function to the UnderC engine so that it can be used
from within there.

//Syntax
//works only on 32bit operating systems

#importUC DisplayCurrentPicture;

10.3.7. Operators

The following operators are supported by the system. If an expression contains more than one operator,
the order of operations is given by the priority of operators. Following operators have higher priority then
the others: / * %. You should use brackets to define evaluation order other than implemented in NIS-
Elements, which is: from right to the left.
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arithmetic operators

+ Addition

- Subtraction

* Multiplication

/ Division

assignment operators

The assignment operator assigns the value of the right operand to the left operand.

= Addition

bitwise operators

The bitwise operators compare each bit of the first operand to the corresponding bit of the second op-
erand. The following bitwise operators are supported.

& Bitwise AND

| Bitwise OR

~ One's complement

pointer operators

& Address of ?

* Indirection

relational operators

< Less than

<= Less than or equal to

> Greater than

>= Greater than or equal

== Equal

!= Not equal

logical operators

The logical operators perform logical operations on expressions. The following logical operators are
supported:

&& Logical AND

|| Logical OR
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! Logical NOT

10.3.8. Expression evaluator

Expression evaluator supports the precedence of operators / * %. It evaluates the expression strictly
from right to left, so you need to use brackets.

10.3.9. C-like functions

The system can interpret your own C - like functions. An entry point to program is the main() function in
your macro. If main() is not presented, for backward compatibility, the body of the macro is also considered
as “main function”. The new macros should use main() as an entry point.

The general C-like functions (also called interpreted functions, as opposed to basic, system functions
from NIS-Elements or LUC32_1.DLL) have the following syntax.

Syntax

int MyFunction(int a, LPSTR str, double d)
{
int retval;
. . .
return retval;
}

Return Value The return value can be any basic data types (char, int, word, dword, int, double or pointer).

Parameters Parameters can be any basic data types (char int, word, dword, int, double or pointer).

Note

Int and double parameters are automatically converted to string type, when they are assigned to
text variable, or are one of the parameters of a function.

Example
int main()
{
char buf[256];
my_function1(buf);
WaitText(0., buf);
return TRUE;
}

int my_function1(char *buf)
{
strcpy(buf, "This function has a pointer to char array as a \
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parameter");
return TRUE;

}

10.4. Controlling Cameras by Macro
Every camera can be controlled from within a macro by changing its properties. There is a CameraGet_*
and CameraSet_* macro function available for each camera property (e.g. CameraGet_ExposureTime();).
The number of functions (beginning with CameraSet_ and CameraGet_) and their actual names depend
on the type of camera(s) you have currently connected to NIS-Elements AR.

CameraGet_ The CameraGet_... functions retrieve current values of the properties determined by the
function name postfix. So the CameraGet_Exposure(int Mode, double *Exposure);
function retrieves the current value of Exposure of the specified Mode.

CameraSet TheCameraSet_... functions allows you to adjust camera properties. So theCameraSet_Ex-
posure(int Mode, double *Exposure); function sets a new Exposure value for the specified
Mode.

How To Set Camera Properties

Instead of describing each property function, it is better to show you a universal way to handle a camera
by macro:

1) Display the View > Acquisition Controls >Mono Sim Settings control panel and find the property
you would like to control.

2) Make a change of the property from within the control panel. For example, change the exposure
time.

3) Display the View > Macro Controls > Command History window and see the last function which
has been called and its parameters (e.g. CameraSet_ExposureTime(1, 500);). This is the function
you will control the exposure time with.

4) Experiment with the camera control panel in order to determine the right parameter values of
the functions to be called within your macro.

10.5. Macro Preferences
This window enables you to configure key shortcuts to macros and set a macro to run automatically on
startup. Run the Edit > General Options command and switch to the Macro tab.

Macros Lists of macros that can be executed using hot keys or automatically at the beginning of the
NIS-Elements AR session.
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Start Up To launch a macro automatically after starting the NIS-Elements AR program, select it
and press the StartUp button. StartUp field of the selected macro in the list box is filled.

Hot Key To assign a hot key to a macro, select the macro in the macro list box and press the Hotkey
button. Select one of the pre-defined key combination and press OK button.

Full Path Shows the full pathname of the selected macro.

Add Adds a macro to the macro list box. Select Macro dialog box appears and you can search the
disk for the macro.

Remove Removes a selected macro from the macro list box.

Edit Enables to edit a selected macro from the macro list box.

Filename substitution These lines display the current values of substitution strings available in macro
commands.

# Letter representing a drive e.g. “C”

## A customizable path e.g. “C:\Images”

### Path to a directory according to the macro function used. It leads to the folder where NIS-Ele-
ments EXE file is placed and to a subdirectory - “Images” for functions concerning image files or
“macros” for functions concerning macros. E.g.:

ImageOpen("###\agnor.tif"); //leads to the IMAGES subdir
RunMacro("###\macro_001.mac"); //leads to the MACROS subdir

####, ##### The current filename including/excluding the path. These substitutions can be used
with the Sequences or SequencesEx macro commands.

Information Shown in Caption Optionally, the name of the current macro and an arbitrary user text can
be displayed in the NIS-Elements AR caption.

Defaults for this Page Restores the default setting for Macro Options.
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11. Movies

11.1. Capturing AVI Movie

1. Display the AVI Acquisition control panel by the Camera > AVI Acquisition command.

2. Adjust the advanced settings, especially define the file name and the destination folder.

3. Click the Record button. The live image appears and recording starts according to the settings.

4. Stop recording by the Stop button, or wait until the time defined in the Duration field passes.

5. When stopped, the AVI file remains opened in a new image window.

11.2. Save ND2 as AVI
You can easily create an AVI movie from an nd2 file. Run the File > Save As command and select the
AVI format in the Save As Type pull-down menu. The Save Aswindow is extended by the following options:

Use Default Video Compression Either leave this box checked or select which video compression will
be applied to the movie file. See 11.4. About Video Compression [229].

XY Loop When the ND document contains XY points, you can decide how these are saved.
Current XY Only the currently selected XY loop will be saved as a movie.

All XY in separate files A movie will be saved for each XY loop present in the ND2 file. An automatic
number will be appended to the file name.

Output Timing Parameters Timing of frames of the resulting AVI movie may equal the Original Acquisition
Time. If this does not suit your needs, define a custom interval in ms .

Experiment Loop Select the dimension, frames of which will be used to create the AVI movie.
Use Time Loop The T dimension frames of the current Z stack position will be used.

Use Z-stack Loop The Z dimension frames of the current Time position will be used.

Use Z-stack and Time Loop All frames of the ND2 file will be used in the AVI movie.

Note

If you have the QuickTime Player installed on your PC, a QuickTime movie (*.mov) can be created
as well.
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11.3. Creating a Movie

11.3.1. Creating a Movie Step by Step

1. Display the current volumetric data set (an ND file containing Z) using the View > Image > ND View
> Volume View or the Applications > 6D > Show Surface View command.

2. Run the Movie Maker by the button.

3. Adjust the movie settings by the Settings button a window appears where the movie duration and
frame rate can be defined.

4. You can use one of the predefined presets or import some previously defined key frames by the Ex-
port/Import button.

5. Either enable or disable the Director's mode by the clapper button. See 11.3.3. Directors Mode [229].

6. Go to the beginning of the time line and define the initial zoom, position, rotation or component ap-
pearance of the object. This step is not necessary, but very much recommended. Press the Add/Update
key frame button to fix the initial appearance.

7. Browse the time line, modify the object position each time, and set key frames by clicking the
Add/Update key frame button. Press the Play Movie button for a preview.

8. When all the key frames are properly set, press the Create Movie button. The movie is created and
the AVI file will open in a new image window.

9. Save the new file by the standard File > Save As command.

11.3.2. Movie Maker Controls

When you start the movie maker, the following bar appears at the bottom of the image view. The user
is supposed to create a set of key-frames. The rest of the movie will be created by interpolation between
these key frames. This gives the user absolute freedom in how the movie will look like.

1. The Clapper button. By this button, the director's mode can be turned ON/OFF. See 11.3.3. Directors
Mode [229].

2. Time line. By clicking to the time line you can browse the movie frames. When a key frame is added,
a bold line appears in the time line to indicate its position.
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3. First Frame, Play, Last Frame buttons.

4. Settings - by this button, you can define the movie length and the frame rate.

5. Create Movie

6. The key frame buttons. The existing key frames may be browsed by pressing the Previous/Next Key
Frame buttons. The Add/Update Key Frame button inserts a key frame to the current position on the
time line.

7. Presets - a predefined rotation can be loaded. When you press the button and select the rotation
type, the existing key frames settings will be overwritten.

8. Import/Export Key Frames - this enables you to save and load the key frame settings. A file with the
*.KEY extension will be created during the export.

11.3.3. Directors Mode

In the directors mode it is not needed to press the Add key frame button every time the position of the
object is changed. The director's mode detects all changes made to the object position and adds a key
frame to the time line whenever such change is detected. A typical work-flow would look like this:

1. Turn ON the directors mode by the Clapper button. The time line gets highlighted with red color.

2. Click to the time line where a certain position of the object shall occur.

3. Move the object by mouse or adjust it in some way (zoom, crop, etc.) - at this moment, the key frame
will be added to the time line automatically.

4. Click to the time line where another position shall occur, and so on...

The director's mode shall be used when you know precisely how the movie shall look.

11.4. About Video Compression
It is common to encode (compress) movies in order to save some disk capacity. This can be done using
various types of codecs. A video codec is a software tool which can code (compress) and decode (de-
compress) video files. Remember that the codec you use to save the video will be required for playback
as well (when playing the video on other computers).

Look at the list of codecs coming with NIS-Elements AR by default. If other codecs are installed on the
computer, they become also available to NIS-Elements AR.

Caution

32bit operating systems provide better choice of codecs because a 64bit codec must be used on
a 64bit operating system, but there are not many of those in the meantime.
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NIS-Elements AR compression options

We performed a test by converting a 1 GB / 4000 frames ND2 file to AVI using different codecs. The
results are displayed in the list:

No compression Original quality, file size: 787 MB.

DV Video Encoder This codec produces only videos with 640 x 480 resolution. Videos with other resol-
utions are stretched to fit, therefore we do not recommend to use this codec.

MJPEG Compressor Very good quality, file size: 240 MB.

Cinepack Codec by Radius Average quality, file size: 70 MB.

Intel IYUV codec Very good quality, file size: 390 MB. Provides the best quality / compression rate.

Microsoft RLE Very poor quality, file size: 90 MB.

Microsoft Video 1 Very poor quality, file size: 6 MB.
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Image Filter (Displaying Images), 134
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Measurement Options (Measurement), 171
Measurement Tools (Measurement), 181
Methods Used for Stitching Large Images (Display-
ing Images), 124
Modifying Menus (User Interface), 36
Modifying the Layout Settings, 33
Modifying the Main Menu, 36
Modifying Toolbars (User Interface), 34
Motorized Stage Initialization, 53
Movie Maker Controls (Movies), 228

Movies, 227
Multi-channel Acquisition (Image Acquisition), 79
Multi-channel Images, 97
Multi-point Acquisition (Image Acquisition), 73
Multiple Binary Layers, 153
Multiple Cameras, 41
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Navigation axis and navigation cube, 110
Navigation in ND2 Files (Displaying Images), 100
ND Dimensions (Displaying Images), 100
ND Experiment Progress (Image Acquisition), 85
ND Sequence Options, 69
ND Views (Displaying Images), 104
ND2 (multi-dimensional) files / datasets, 97
ND2 files, 99
ND2 Files Processing (Image Analysis), 142
ND2 Information (Displaying Images), 106
New Engine (Displaying Images), 106
NIS-Elements AR compression options, 230
NIS-Elements authentication (Installation and Set-
tings), 15
NIS-Elements Installation Steps (Installation and
Settings), 5
NIS-Elements Preferences (Installation and Set-
tings), 21

O
Object Count (Measurement), 166
Object Count Procedure Example (Measurement),
170
Object/Field Measurement, 185
Objective Calibration (Cameras & Devices), 46
Objectives (Cameras & Devices), 45
Old Engine (Displaying Images), 114
Open and Close, 155
Open, Save, Close Images (Displaying Images), 89
Opening Files in Progressive Mode (Displaying Im-
ages), 123
Opening Image Files (Displaying Images), 89
Operations with Binary Layers (Image Analysis),
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Operations with Images within Organizer (Displaying
Images), 136
Operations with Optical Configurations (Cameras
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Organizer (Displaying Images), 134
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Orientation (O) and Pitch (P), 203, 204
Other (Installation and Settings), 14
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Overrun Indication (Image Analysis), 140

P
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Pixel Classifier (Measurement), 173
Pixel Saturation Indication sub-menu, 98
Pixel Size Calibration, 164
Playing Controls, 101
Playing options, 101
Point by Point (Manual) Multi-Point (Image Acquis-
ition), 74
pointer operators, 223
Predefined Camera ROI, 67
Preparation (Image Analysis), 139
Privileges tab, 20
Privileges Tab Options (Installation and Settings),
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Analysis), 142

Q
Quick Guide, 5
Quick Guide (Measurement), 186
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Radius (Measurement), 183
Random Multi-Point (Image Acquisition), 75
Recorded Data (Image Acquisition), 84
Recording a Macro, 215
Regions of Interest - ROIs (Image Analysis), 157
relational operators, 223
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Repetition issues (Image Analysis), 155
Report Generator (Creating Reports), 211
Report Objects (Creating Reports), 212
Report Templates (Creating Reports), 213
Reset of password, 18

Resizing the Organizer Panes (Displaying Images),
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Restricting the Area of Measurement, 185
Restrictions, 146
Restrictions from the Image, 168
Results (Measurement), 169
RGB Images, 96
RGB/Mono/Multichannel Image Processing (Image
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ROIs in Time - Moving ROIs (Image Analysis), 161
Rotation Controls, 119
Rough Measurement (Measurement), 165
Running a Macro (Macros), 217
Running a Macro Upon Layout Change (User Inter-
face), 37
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Sample Database Installation (Installation and
Settings), 10
Save ND2 as AVI (Movies), 227
Save Next Options (Displaying Images), 93
Save to File (Image Acquisition), 84
Saving Image Files (Displaying Images), 91
Saving Images with UAC (Displaying Images), 91
Scan Area, 81
Select Camera Driver, 41
Select Graticule Type, 165
Selecting a Camera, 42
Semiaxes (Measurement), 183
Set layout visibility, 15
Setting Software Limits to Stage Movement, 53
Setting Up the Camera, 41
Shading Correction (Image Acquisition), 64
ShapeFactor, 205
Shifting Image Channels (Displaying Images), 100
Shortcuts, 121
Shortcuts in Cropping Plane Mode, 120
Simple ROI Editor (Image Analysis), 160
Simple ROI Editor toolbar, 160
Single function applied to the original, 156
Slices View , 105
Software Copy Protection (Installation and Set-
tings), 10
Sorting of Images, 137
Source Data (Image Analysis), 139
Special Options, 70, 78, 79
Special Options (Image Acquisition), 75
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Splitting Large Images (Displaying Images), 123
Spot Detection (Image Analysis), 146
Start menu, 9
Startup Switches, 1
StartX, StartY, 206
Statements (Macros), 218
Statements which are not supported, 220
Statistics and Data Presentation, 186
Status Bar, 31
Status Bar (User Interface), 26
Status bar of the image window, 31
Step by Step, 5
StgPos, 207
Stitching, 81
Stitching via "Blending" (pixel intensity is changed
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Stitching via "Optimal path" (pixel intensity is pre-
served), 125
Structures and Unions (Macros), 218
Structuring Element = Kernel = Matrix (Image
Analysis), 154
Superresolution Calibration, 50
Supported Image Formats (Displaying Images), 94
Supported Statements, 218
Switching Between Loaded Images (Displaying
Images), 89
Synchronizer (Displaying Images), 122

T
TD channel, 131
The application status bar, 26
The Docked Control Panel Caption, 27
The Installation DVD-ROM Content (Installation and
Settings), 5
The NIS-Elements Main Window, 25
The organizer layout., 134
The XY plane is selected so the graticules will move
only in the X and Y axis direction, 121
Threshold Adjustments, 145
Thresholding (Image Analysis), 143
Thresholding Large Images (Image Analysis), 146
Thresholding panel, 144
Thresholding the Image (Measurement), 167
Thumbnail Displaying Options, 136
Tiled View, 106
Time Measurement (Measurement), 186
Time measurement window, 186

Time volume projection, 114, 121
Time-lapse Acquisition (Image Acquisition), 69
Timing Explanation (Image Acquisition), 72
Tips, 101, 126
Tips and Tricks (Image Analysis), 145
Tips on Moving ROI, 161
To Change a Single Z Coordinate (Image Acquisi-
tion), 75
To Create a New Layout, 32
To Create a Report FROM Template, 214
To Create a Report Template, 214
To define a moving ROI:, 161
To Display a Docking Pane, 26
To Reload Previous Layout Settings, 32
Toolbar, 170
Toolbars (User Interface), 26
Tools for Handling the Live Image, 63
Top and Bottom, Step, 77
TrackID, 208
True Color Displaying Mode, 131
Turn Camera ROI ON/OFF, 66
Turn the Buffer ON, 88
Types of ROI (Image Analysis), 158

U
Units (Measurement), 164
User Interface, 25
User name and password properties, 18
User Rights (Installation and Settings), 14
User Rights Options (Installation and Settings), 16
Users Tab Options (Installation and Settings), 17
Using Auto Exposure while Switching between Op-
tical Configurations (Cameras & Devices), 45
Using ROIs for analysis (Image Analysis), 160
Using two independent Z Drive devices, 54

V
Variable types (Macros), 218
Volume Options tab, 111
Volume Options Tab, 111
Volume View, 105
Volume Viewer (Displaying Images), 106
VolumeEqCylinder, 209
VolumeEqSphere, 209
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Well Plate (Rectangular) Multi-Point (Image Acquis-
ition), 74
What are Logical Devices? (Cameras & Devices),
51
Width, 209
Window Toolbar Options, 107, 114
Working with Objects, 118
Working with the Measurement and Annotation
Objects (Measurement), 180
Writing/Editing a Macro, 216

X
X axis, 189
XY Stages and Z Drives Tips (Cameras & Devices),
53

Y
Y axis left/right, 190

Z
Z Intensity Correction (Image Acquisition), 84
Z-series Acquisition (Image Acquisition), 77
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